summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2020-07-16 19:29:38 +0200
committerAlexis Ballier <aballier@gentoo.org>2020-07-16 19:34:51 +0200
commitb3d55262dffe27628564400f1caa11a4fb57e858 (patch)
treeafc8fe3684be3de9577cfb533a8092625a97e4e3
parentdev-ros/angles: Remove old (diff)
downloadgentoo-b3d55262dffe27628564400f1caa11a4fb57e858.tar.gz
gentoo-b3d55262dffe27628564400f1caa11a4fb57e858.tar.bz2
gentoo-b3d55262dffe27628564400f1caa11a4fb57e858.zip
dev-ros/actionlib: bump to 1.13.1
Package-Manager: Portage-2.3.103, Repoman-2.3.23 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
-rw-r--r--dev-ros/actionlib/Manifest1
-rw-r--r--dev-ros/actionlib/actionlib-1.13.1.ebuild28
-rw-r--r--dev-ros/actionlib/actionlib-9999.ebuild4
3 files changed, 31 insertions, 2 deletions
diff --git a/dev-ros/actionlib/Manifest b/dev-ros/actionlib/Manifest
index bf2c180b05e7..8d10149ade26 100644
--- a/dev-ros/actionlib/Manifest
+++ b/dev-ros/actionlib/Manifest
@@ -1,3 +1,4 @@
DIST actionlib-1.11.13.tar.gz 98518 BLAKE2B 918c541f3a6192ee9b89e4b2759651e027d447acc305aaf9bdeabb9587a527b6bd924eb812314c8c83baec3b6829ca0b5d126550ea70acc5d2739f7cd83e065d SHA512 273499a0a5b1c9b40147ba0bba61b44a2530c0a16d757a51f6b6211c95790e18ffe2c397582a429de84a639209779c2641a3013f71f75a2fd76d422115033601
DIST actionlib-1.11.14.tar.gz 98789 BLAKE2B fb4f7afbc2836f43ccfbb5d477a7e54ec4feb13244a797a057922b02cb97886052b2b6b2f2cb3cdf0ecb1b0c7dd09a24768ad9bc459498e0606ba534a82598c7 SHA512 147fc8642e8d46cf6dc353b4f8850c2682204a6f256a7e0a065db5adb67b72c54e2f40ff4cabbec2fab6d1a1b0c82ff0abbea571ae4202774892c3dae01ad8bd
DIST actionlib-1.11.15.tar.gz 99063 BLAKE2B 23cce02de41b7705645cd1bae35f90d8c89171f809c689323683bf4f644b7df8c46dc4c5cffa2de6a2791c3a77957964785fe6d99a77ccea25eee43fb88e4325 SHA512 3f6deb469b284ca7809a20779f8362cb48d2bf12d8fc4a546fb1fe28fc06baa9693f9efb576f27f1cac976051bcb966a2c47df1185847bea040c0ac0a915b6d9
+DIST actionlib-1.13.1.tar.gz 100763 BLAKE2B d1c9bac94ed5928409e831087893cdc4921163592b5c141deb6c888eaee5bd581141ef84e95735b67f18e0dcf7c24d3486c6d6f0a36018a0e24dad91427956b3 SHA512 1b2cf48c0d3d635d4a37f177f7c05dbb21ed027dbddb4ea713f765fea0db3fee00ae242b8d51907d4841544a9ed231785959241947126dfb857daee0ff7e4cb2
diff --git a/dev-ros/actionlib/actionlib-1.13.1.ebuild b/dev-ros/actionlib/actionlib-1.13.1.ebuild
new file mode 100644
index 000000000000..cc7b760ccf5d
--- /dev/null
+++ b/dev-ros/actionlib/actionlib-1.13.1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+CATKIN_HAS_MESSAGES=yes
+ROS_REPO_URI="https://github.com/ros/actionlib"
+KEYWORDS="~amd64 ~arm"
+CATKIN_MESSAGES_TRANSITIVE_DEPS="dev-ros/actionlib_msgs dev-ros/std_msgs"
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="Provides a standardized interface for interfacing with preemptable tasks"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="dev-libs/boost:=[threads]
+ dev-ros/roscpp
+ dev-ros/rospy[${PYTHON_USEDEP}]
+ "
+DEPEND="${RDEPEND}
+ dev-ros/rosunit[${PYTHON_USEDEP}]
+ test? ( dev-ros/rostest[${PYTHON_USEDEP}] )"
+RDEPEND="${RDEPEND}
+ dev-ros/roslib[${PYTHON_USEDEP}]
+ dev-ros/rostopic[${PYTHON_USEDEP}]
+"
diff --git a/dev-ros/actionlib/actionlib-9999.ebuild b/dev-ros/actionlib/actionlib-9999.ebuild
index 78149321f929..cc7b760ccf5d 100644
--- a/dev-ros/actionlib/actionlib-9999.ebuild
+++ b/dev-ros/actionlib/actionlib-9999.ebuild
@@ -1,12 +1,12 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=7
CATKIN_HAS_MESSAGES=yes
ROS_REPO_URI="https://github.com/ros/actionlib"
KEYWORDS="~amd64 ~arm"
-PYTHON_COMPAT=( python{2_7,3_6} pypy3 )
CATKIN_MESSAGES_TRANSITIVE_DEPS="dev-ros/actionlib_msgs dev-ros/std_msgs"
+ROS_SUBDIR=${PN}
inherit ros-catkin