summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-01-24 07:39:00 +0100
committerMichał Górny <mgorny@gentoo.org>2024-01-24 08:01:45 +0100
commitb4026109e84b4a886ec7a074aef38f09859381c5 (patch)
tree5da2155686550eb40b9c7ab67358ae3866321374
parentdev-python/toolz: Bump to 0.12.1 (diff)
downloadgentoo-b4026109e84b4a886ec7a074aef38f09859381c5.tar.gz
gentoo-b4026109e84b4a886ec7a074aef38f09859381c5.tar.bz2
gentoo-b4026109e84b4a886ec7a074aef38f09859381c5.zip
dev-python/bandit: Bump to 1.7.7
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/bandit/Manifest1
-rw-r--r--dev-python/bandit/bandit-1.7.7.ebuild42
2 files changed, 43 insertions, 0 deletions
diff --git a/dev-python/bandit/Manifest b/dev-python/bandit/Manifest
index 684db449dde1..cc8bfd947229 100644
--- a/dev-python/bandit/Manifest
+++ b/dev-python/bandit/Manifest
@@ -1 +1,2 @@
DIST bandit-1.7.6.tar.gz 1977532 BLAKE2B 2580641ee0e19364d36988ff3757a55bd7ff8c0a3e47d564873940b5f9c1b8335a2eb724c9394ff76e341a766054bec27ef296a9502fec60d96a5eb65a015f4b SHA512 6635704e2e60e23f5d21de345152e13ef1bde5efb92ccc0e6dde46e8405c1e5dd9530830af4d2a3c5d6e0bb0eb106ccce4cde3a7be678cce499486e752a26428
+DIST bandit-1.7.7.tar.gz 1980358 BLAKE2B 78330ff515a5b8200a05615c8fbad0a65011ffd9c29cf40464fee372417982738de7fd616d1b5f8910dbe45937ba6da6a87252f471e7d762a905f4683d3892f0 SHA512 32682a9a4c54532be398444799bc6d46d06e2806d3e3e851dd09f0151b21df5974eaa4c940307f32cd6c58b36b99a361cbd8c48f189c27071565be6de63b0db5
diff --git a/dev-python/bandit/bandit-1.7.7.ebuild b/dev-python/bandit/bandit-1.7.7.ebuild
new file mode 100644
index 000000000000..3e32542e7de7
--- /dev/null
+++ b/dev-python/bandit/bandit-1.7.7.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="A security linter from OpenStack Security"
+HOMEPAGE="
+ https://github.com/PyCQA/bandit/
+ https://pypi.org/project/bandit/
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~riscv ~x86"
+
+RDEPEND="
+ >=dev-python/pbr-2.0.0[${PYTHON_USEDEP}]
+ >=dev-python/GitPython-3.1.30[${PYTHON_USEDEP}]
+ >=dev-python/pyyaml-5.3.1[${PYTHON_USEDEP}]
+ dev-python/rich[${PYTHON_USEDEP}]
+ >=dev-python/stevedore-1.20.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ >=dev-python/pbr-2.0.0[${PYTHON_USEDEP}]
+ test? (
+ >=dev-python/fixtures-3.0.0[${PYTHON_USEDEP}]
+ >=dev-python/testscenarios-0.5.0[${PYTHON_USEDEP}]
+ >=dev-python/testtools-2.3.0[${PYTHON_USEDEP}]
+ >=dev-python/beautifulsoup4-4.8.0[${PYTHON_USEDEP}]
+ >=dev-python/pylint-1.9.4[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ >=dev-python/tomli-1.1.0[${PYTHON_USEDEP}]
+ ' 3.10)
+ )
+"
+
+distutils_enable_tests unittest