summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2023-07-21 18:47:11 -0400
committerMatt Turner <mattst88@gentoo.org>2023-07-21 18:55:01 -0400
commitb423744e6be5d9456592a37816454bd5d106dba5 (patch)
treeba3d1c585420d096e80ab93faab6fc7812bdbcdf
parenttoolchain-funcs.eclass: fix incomplete ninj rename (diff)
downloadgentoo-b423744e6be5d9456592a37816454bd5d106dba5.tar.gz
gentoo-b423744e6be5d9456592a37816454bd5d106dba5.tar.bz2
gentoo-b423744e6be5d9456592a37816454bd5d106dba5.zip
media-libs/glu: Version bump to 9.0.3
Signed-off-by: Matt Turner <mattst88@gentoo.org>
-rw-r--r--media-libs/glu/Manifest1
-rw-r--r--media-libs/glu/glu-9.0.3.ebuild31
-rw-r--r--media-libs/glu/glu-9999.ebuild22
3 files changed, 40 insertions, 14 deletions
diff --git a/media-libs/glu/Manifest b/media-libs/glu/Manifest
index e390518a3fc2..037938c1394a 100644
--- a/media-libs/glu/Manifest
+++ b/media-libs/glu/Manifest
@@ -1 +1,2 @@
DIST glu-9.0.2.tar.xz 436176 BLAKE2B 90485938e4809ce7bb56da25bd60be9f3f7b7f40d511ea6635e40d749e519d1dca6241d891224d3cf331b911f545df4ef9aa2101baf4e3b18df69244edbcb8a4 SHA512 2517d7406bb643d12c017a95dcb5d8716f307344332638bcbdf274a90752a7c22165d34745f1b082ed916bb07d40e62d1d1d67d96426225be63166f3480d6f64
+DIST glu-9.0.3.tar.xz 218968 BLAKE2B a6fc842004dcca4243ef285e26806afdfb931d21985ad8f9a3f03f438e66b810718bf04e588044ed8db99990e49f806d346dc2ce69cfa91450f046a4dfa39136 SHA512 b2781059c0e176192c3fc0d7244645020937a463311171efddb9f35fb94ee43faabcf627fa7f429d48fceaf6dd9c5adb69c86c7a21ec4ea490f4ab143d52e3ba
diff --git a/media-libs/glu/glu-9.0.3.ebuild b/media-libs/glu/glu-9.0.3.ebuild
new file mode 100644
index 000000000000..b231083a0962
--- /dev/null
+++ b/media-libs/glu/glu-9.0.3.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit meson-multilib
+
+DESCRIPTION="The OpenGL Utility Library"
+HOMEPAGE="https://gitlab.freedesktop.org/mesa/glu"
+
+if [[ ${PV} = 9999* ]]; then
+ EGIT_REPO_URI="https://gitlab.freedesktop.org/mesa/glu.git"
+ inherit git-r3
+else
+ SRC_URI="https://mesa.freedesktop.org/archive/glu/${P}.tar.xz"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~x64-solaris"
+fi
+
+LICENSE="SGI-B-2.0"
+SLOT="0"
+
+DEPEND="media-libs/libglvnd[${MULTILIB_USEDEP}]"
+RDEPEND="${DEPEND}"
+
+multilib_src_configure() {
+ local emesonargs=(
+ -Ddefault_library=shared
+ -Dgl_provider=glvnd
+ )
+ meson_src_configure
+}
diff --git a/media-libs/glu/glu-9999.ebuild b/media-libs/glu/glu-9999.ebuild
index 25992a6979a3..b231083a0962 100644
--- a/media-libs/glu/glu-9999.ebuild
+++ b/media-libs/glu/glu-9999.ebuild
@@ -1,36 +1,30 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
-EGIT_REPO_URI="https://gitlab.freedesktop.org/mesa/glu.git"
-
-if [[ ${PV} = 9999* ]]; then
- GIT_ECLASS="git-r3"
-fi
-
-inherit meson-multilib ${GIT_ECLASS}
+inherit meson-multilib
DESCRIPTION="The OpenGL Utility Library"
HOMEPAGE="https://gitlab.freedesktop.org/mesa/glu"
if [[ ${PV} = 9999* ]]; then
- SRC_URI=""
+ EGIT_REPO_URI="https://gitlab.freedesktop.org/mesa/glu.git"
+ inherit git-r3
else
SRC_URI="https://mesa.freedesktop.org/archive/glu/${P}.tar.xz"
- KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~x64-solaris"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~x64-solaris"
fi
LICENSE="SGI-B-2.0"
SLOT="0"
-IUSE="static-libs"
-DEPEND=">=virtual/opengl-7.0-r1[${MULTILIB_USEDEP}]"
+DEPEND="media-libs/libglvnd[${MULTILIB_USEDEP}]"
RDEPEND="${DEPEND}"
multilib_src_configure() {
local emesonargs=(
- -Ddefault_library=$(usex static-libs both shared)
+ -Ddefault_library=shared
-Dgl_provider=glvnd
)
meson_src_configure