summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2024-03-22 22:11:41 +0100
committerMaciej Barć <xgqt@gentoo.org>2024-03-22 22:17:15 +0100
commitb42be5e3006c0383e21451a38d5748b3af4b1b40 (patch)
treef86b5c2df147e23bbd75b0f7b9d2724bf680f757
parentnet-misc/gallery-dl: use unittest runner; disable net (diff)
downloadgentoo-b42be5e3006c0383e21451a38d5748b3af4b1b40.tar.gz
gentoo-b42be5e3006c0383e21451a38d5748b3af4b1b40.tar.bz2
gentoo-b42be5e3006c0383e21451a38d5748b3af4b1b40.zip
app-emacs/ts: switch to UTC zone
Closes: https://bugs.gentoo.org/927384 Signed-off-by: Maciej Barć <xgqt@gentoo.org>
-rw-r--r--app-emacs/ts/ts-0.3.ebuild24
1 files changed, 16 insertions, 8 deletions
diff --git a/app-emacs/ts/ts-0.3.ebuild b/app-emacs/ts/ts-0.3.ebuild
index 4f61deb30b25..87f02340e27c 100644
--- a/app-emacs/ts/ts-0.3.ebuild
+++ b/app-emacs/ts/ts-0.3.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -8,32 +8,40 @@ inherit elisp
DESCRIPTION="Emacs timestamp and date-time library"
HOMEPAGE="https://github.com/alphapapa/ts.el"
-if [[ ${PV} == *9999* ]] ; then
+if [[ "${PV}" == *9999* ]] ; then
inherit git-r3
+
EGIT_REPO_URI="https://github.com/alphapapa/ts.el.git"
else
- [[ ${PV} == 0.3 ]] && COMMIT=552936017cfdec89f7fc20c254ae6b37c3f22c5b
+ [[ "${PV}" == 0.3 ]] && COMMIT=552936017cfdec89f7fc20c254ae6b37c3f22c5b
SRC_URI="https://github.com/alphapapa/ts.el/archive/${COMMIT}.tar.gz
-> ${P}.tar.gz"
- S="${WORKDIR}"/ts.el-${COMMIT}
+ S="${WORKDIR}/ts.el-${COMMIT}"
+
KEYWORDS="~amd64 ~x86"
fi
LICENSE="GPL-3+"
SLOT="0"
+IUSE="test"
+RESTRICT="!test? ( test )"
RDEPEND="
app-emacs/dash
app-emacs/s
"
-BDEPEND="${RDEPEND}"
+BDEPEND="
+ ${RDEPEND}
+ test? (
+ sys-libs/timezone-data
+ )
+"
-PATCHES=( "${FILESDIR}"/ts-0.3-test.patch )
+PATCHES=( "${FILESDIR}/ts-0.3-test.patch" )
DOCS=( README.org notes.org )
SITEFILE="50${PN}-gentoo.el"
src_test() {
- LANG=C TZ=/usr/share/zoneinfo/America/Chicago \
- elisp-test-ert test -l test/test.el
+ LANG=C TZ=/usr/share/zoneinfo/UTC elisp-test-ert test -l test/test.el
}