summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2023-05-12 21:06:38 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2023-05-12 21:12:51 +0200
commitb42fc097ead5393b38972727befce130b0f54556 (patch)
tree98db566f65df9c891e79a8f4a64e72f018823cc0
parentmedia-sound/xmms2: add 0.9.3 (diff)
downloadgentoo-b42fc097.tar.gz
gentoo-b42fc097.tar.bz2
gentoo-b42fc097.zip
app-text/libwps: add 0.4.14
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
-rw-r--r--app-text/libwps/Manifest1
-rw-r--r--app-text/libwps/libwps-0.4.14.ebuild34
2 files changed, 35 insertions, 0 deletions
diff --git a/app-text/libwps/Manifest b/app-text/libwps/Manifest
index 49ba31d03455..642422199d5d 100644
--- a/app-text/libwps/Manifest
+++ b/app-text/libwps/Manifest
@@ -1 +1,2 @@
DIST libwps-0.4.13.tar.xz 717188 BLAKE2B 966d0e57668577620fc5fe8c222096fa1b51f3d2c149dab7fc182c2fe81b69363cfbcc2ff930d2719f9fcf735306d612a00ae863ff1a0d2f03fcd6c67b054489 SHA512 c88357cdb11a68148c9344cf3688d57d793089732ee9828d6ea5e86536eb5f60668326fa520e7609a48298051435f6cc570d0c58aa4aa96581a51c16f914a1d0
+DIST libwps-0.4.14.tar.xz 719016 BLAKE2B 9f89b8534851760bb2cc3453e75840dea22eb09fd51a1d8ec7b7308fbb63ef7e34416ccfdbb5b1abc87616b7da17edc0bcf1e7fcc93414bf197dd904f6de759b SHA512 bbf9047f35d1b42c2da8deee24116d6a3fb20749a4255d369b62967a99185f52f21dda3e1b385056c1924995f2a72b670960bb476f38c3bf78933e25ff4a5779
diff --git a/app-text/libwps/libwps-0.4.14.ebuild b/app-text/libwps/libwps-0.4.14.ebuild
new file mode 100644
index 000000000000..420242907315
--- /dev/null
+++ b/app-text/libwps/libwps-0.4.14.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Microsoft Works file word processor format import filter library"
+HOMEPAGE="https://sourceforge.net/p/libwps/wiki/Home/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.xz"
+
+LICENSE="|| ( LGPL-2.1 MPL-2.0 )"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~loong ~ppc64 ~riscv ~x86"
+IUSE="debug doc tools"
+
+DEPEND="dev-libs/librevenge"
+RDEPEND="${DEPEND}"
+BDEPEND="
+ virtual/pkgconfig
+ doc? ( app-doc/doxygen )
+"
+
+src_configure() {
+ local myeconfargs=(
+ $(use_enable debug)
+ $(use_with doc docs)
+ $(use_enable tools)
+ )
+ econf "${myeconfargs[@]}"
+}
+
+src_install() {
+ default
+ find "${D}" -name '*.la' -type f -delete || die
+}