summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2022-12-23 08:39:00 +0200
committerArthur Zamarin <arthurzam@gentoo.org>2022-12-23 09:30:37 +0200
commitb450251a63449e9ecc0d07ebe4136990d2c25c46 (patch)
tree071545dfba16b0ad2fd4ca5ade4d2b461608a59b
parentdev-python/botocore: add 1.29.36 (diff)
downloadgentoo-b450251a.tar.gz
gentoo-b450251a.tar.bz2
gentoo-b450251a.zip
dev-python/boto3: add 1.26.36
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
-rw-r--r--dev-python/boto3/Manifest1
-rw-r--r--dev-python/boto3/boto3-1.26.36.ebuild68
2 files changed, 69 insertions, 0 deletions
diff --git a/dev-python/boto3/Manifest b/dev-python/boto3/Manifest
index dd9c32783917..e5535b618805 100644
--- a/dev-python/boto3/Manifest
+++ b/dev-python/boto3/Manifest
@@ -4,3 +4,4 @@ DIST boto3-1.26.31.gh.tar.gz 580080 BLAKE2B 30d44e3df131aef363ccc2afdde43ee4b0d1
DIST boto3-1.26.32.gh.tar.gz 581235 BLAKE2B f8decc1e924ff5f5f98566084a55c36ea10ca38596e0f8398a9d5865e6246290e9e09ff3e95622eacca9f32b6f8119156b2ba5a6ce0135e988fad0bcdb161030 SHA512 73c6f8f1e1d5f12887e880cc651399fbd147c65740090bd09303540dcc902efc6b04605551f055341e84cb8b72cdcb9d8d444263fc0131b8f5013197e67c1fb5
DIST boto3-1.26.33.gh.tar.gz 581883 BLAKE2B a2ac93a516932b8cfcb039e215608ebdd3f5427c7abb016359ad2f1a9e5e4ed855a405bb0470b5ba4823ba59c21d21f2b3319dcc8ef0715a1293cb0219261ac1 SHA512 4bb267abfaa01643edd6670dc66c87225845dce31d1d4aa500f60a278326a8fe6f877d8af4bff460cea3b77ef316392a2acf10181d7ae2a7c59ca2f6ca5ec9aa
DIST boto3-1.26.34.gh.tar.gz 582767 BLAKE2B 279138d5b6093a16d54bd14bab6e9e4c4901d03a38e968c693dff6c585c30098d6520b3d7f5d98c8db94948bf431ff93531c5f706b9e8bf25501255b46c40203 SHA512 b9cc60eda79e8addba92013e34893cb7c59557d350d065f7406c1fb2b0c4256612a09d049ebc62f2ee447922f9ae99557a84f60379267f576a6665dbdc193d1e
+DIST boto3-1.26.36.gh.tar.gz 584205 BLAKE2B d5aad2ab0b8ee3392c636309454859e30cbe937d0dc2efb4b5a817fc83c555e5592ec8a8ae94a273ab2ab55be5d627b44475d0b5ca77caebc246229e3f78b155 SHA512 818843d82b27ee2e376382f1a74a950cbacf04a588bdc012e8c88d569ad5571d231a2dd399a3e26efc3de96c89f722ceabc3e70eb3cdba930c08277fa6c2c189
diff --git a/dev-python/boto3/boto3-1.26.36.ebuild b/dev-python/boto3/boto3-1.26.36.ebuild
new file mode 100644
index 000000000000..aa8071e64d5e
--- /dev/null
+++ b/dev-python/boto3/boto3-1.26.36.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit distutils-r1 multiprocessing
+
+DESCRIPTION="The AWS SDK for Python"
+HOMEPAGE="
+ https://github.com/boto/boto3/
+ https://pypi.org/project/boto3/
+"
+LICENSE="Apache-2.0"
+SLOT="0"
+
+if [[ "${PV}" == "9999" ]]; then
+ EGIT_REPO_URI="https://github.com/boto/boto3"
+ inherit git-r3
+ BOTOCORE_PV=${PV}
+else
+ SRC_URI="
+ https://github.com/boto/boto3/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+ "
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+ # botocore is x.(y+3).z
+ BOTOCORE_PV="$(ver_cut 1).$(( $(ver_cut 2) + 3)).$(ver_cut 3-)"
+fi
+
+RDEPEND="
+ >=dev-python/botocore-${BOTOCORE_PV}[${PYTHON_USEDEP}]
+ >=dev-python/jmespath-0.7.1[${PYTHON_USEDEP}]
+ >=dev-python/s3transfer-0.6.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_sphinx docs/source \
+ 'dev-python/guzzle_sphinx_theme'
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ # don't lock versions to narrow ranges
+ sed -e '/botocore/ d' \
+ -e '/jmespath/ d' \
+ -e '/s3transfer/ d' \
+ -i setup.py || die
+
+ # do not rely on bundled deps in botocore (sic!)
+ find -name '*.py' -exec sed -i \
+ -e 's:from botocore[.]vendored import:import:' \
+ -e 's:from botocore[.]vendored[.]:from :' \
+ {} + || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ epytest tests/{functional,unit} -n "$(makeopts_jobs)"
+}