summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-05-17 14:29:46 +0200
committerMichał Górny <mgorny@gentoo.org>2024-05-17 18:21:01 +0200
commitb45334ac9501efd6ed96ed439bf3786c8a84821c (patch)
tree161075c4b1e70fe9ad956fe7fb265c7ac5be77b5
parentsys-kernel/vanilla-kernel: Bump to 5.10.217 (diff)
downloadgentoo-b45334ac9501efd6ed96ed439bf3786c8a84821c.tar.gz
gentoo-b45334ac9501efd6ed96ed439bf3786c8a84821c.tar.bz2
gentoo-b45334ac9501efd6ed96ed439bf3786c8a84821c.zip
sys-kernel/gentoo-kernel: Bump to 5.10.217
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--sys-kernel/gentoo-kernel/Manifest2
-rw-r--r--sys-kernel/gentoo-kernel/gentoo-kernel-5.10.217.ebuild134
2 files changed, 136 insertions, 0 deletions
diff --git a/sys-kernel/gentoo-kernel/Manifest b/sys-kernel/gentoo-kernel/Manifest
index b98509cc0986..d11461a26135 100644
--- a/sys-kernel/gentoo-kernel/Manifest
+++ b/sys-kernel/gentoo-kernel/Manifest
@@ -1,5 +1,7 @@
DIST genpatches-5.10-227.base.tar.xz 6772808 BLAKE2B c026e8b9a2de5ed827e2027c80bda5e1f5c30fdffd82644d5c3001449263142dd6cda9937c4ad5afb63276b4c072ce72dfdb061bc3be432ba89f9aa98c5214d0 SHA512 69cc93e9c8f09443d9d1fc999ba8b9c1d2c2fb5182520a7d1530723ab4797f113c69ad0ed9b05743e8062441af0290e16dce3cd4eb4bdd1f805b43c54932c8f3
DIST genpatches-5.10-227.extras.tar.xz 3912 BLAKE2B bf7fb2754d5ff315fae18f3b82b2b9df80038bbac9a8fdeccb6cd567df6efbb41ba1c16440bbd839ca63f27218d0721016b016d4521b98ed04ecbac80c5ac0aa SHA512 c5b62dd417f727062ca73ff379fc8aac95a393931a379fa7aa83207d3b98128fd89f282a2454620a5a695db7dc3ca9ecb77e57c37f81bdec5abaa8fa84485766
+DIST genpatches-5.10-228.base.tar.xz 6796152 BLAKE2B ef28b957aac198478ba620253b1f3d85b723f0e47924cbc090d07a8ee28515c58cccc1c45494519e0dfddbd4e03a5c292273db84b46def70f7e38530dbbf3ebf SHA512 d090e87db62dd0e3c0bcab6ead66ba4380db2ef6d9b143e0632260c66ab245d459685226f30f721a51b5a45e9e24f66aa70b4783281b21c45cb29fce13d85d3f
+DIST genpatches-5.10-228.extras.tar.xz 4052 BLAKE2B 09c4b743daf726c89054d5e1ae0127e9d22dc23b167a3a6b387cc6ffd84a47d2ba70387869990ccd510bdcd5eea5f13a5579cd0c98432076a9a7ac7f6c944157 SHA512 634705678dc6693421e8ea3e985c4fbbd14b97b962e1b4aa50daa42ce47531b8e07b4255cd3e85429b1eccf103f74267e448c072771a195d39b4b6b8b52e099b
DIST genpatches-5.15-168.base.tar.xz 6757748 BLAKE2B 32b6ebb14ed20864b51fef7cf5e81bee96e4b634829d10b0f29172c41129caf856442cb7c116a4982c6ec92324661daca1a0644febac00d2d39ddd43fe1902b9 SHA512 62b37104e6ac0c9eb09de4fd1657e945be70e90d4682537e762f63ca8ef34da713619d518bf6a0fb35aac4b1541a44d91ee18d806211c7e4cc4124449de49bfc
DIST genpatches-5.15-168.extras.tar.xz 3972 BLAKE2B 6cde986105f72e9282c78f59c8bb82bd3ac7c5c03adb3b3c1c657204624df2a28048ac0fe095759d5906bcd6677831d9962894b76390c2861482440120e72fe5 SHA512 6e067603b8e0e318703a59347d38d7aeb44a3097c39df07881c0f5250207b05442053a8ddf32069ead729ab4c36ccc1177ee8d82417ae2dbe16014b221d0d1ad
DIST genpatches-6.1-99.base.tar.xz 5167668 BLAKE2B 0dfd80fa50e373b99b3ec8c2adcc80eabaa0df9606831465c2afbca34cc195f41902a5ad4472b822eb2e011356c51b257a39294ae1d123c7384f915bd0a6249a SHA512 39116b71b7da155596a158ebb1aeafb029bf5c0d1ec983efbbdb323af61fc505c3a67beac4e6f888b3b673cdc271ef1dbc3090580aa89f573a652ebe0d501ccf
diff --git a/sys-kernel/gentoo-kernel/gentoo-kernel-5.10.217.ebuild b/sys-kernel/gentoo-kernel/gentoo-kernel-5.10.217.ebuild
new file mode 100644
index 000000000000..0845d4e45e94
--- /dev/null
+++ b/sys-kernel/gentoo-kernel/gentoo-kernel-5.10.217.ebuild
@@ -0,0 +1,134 @@
+# Copyright 2020-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit kernel-build toolchain-funcs
+
+MY_P=linux-${PV%.*}
+GENPATCHES_P=genpatches-${PV%.*}-$(( ${PV##*.} + 11 ))
+# https://koji.fedoraproject.org/koji/packageinfo?packageID=8
+CONFIG_VER=5.10.12
+CONFIG_HASH=836165dd2dff34e4f2c47ca8f9c803002c1e6530
+GENTOO_CONFIG_VER=g13
+
+DESCRIPTION="Linux kernel built with Gentoo patches"
+HOMEPAGE="
+ https://wiki.gentoo.org/wiki/Project:Distribution_Kernel
+ https://www.kernel.org/
+"
+SRC_URI+="
+ https://cdn.kernel.org/pub/linux/kernel/v$(ver_cut 1).x/${MY_P}.tar.xz
+ https://dev.gentoo.org/~mpagano/dist/genpatches/${GENPATCHES_P}.base.tar.xz
+ https://dev.gentoo.org/~mpagano/dist/genpatches/${GENPATCHES_P}.extras.tar.xz
+ https://github.com/projg2/gentoo-kernel-config/archive/${GENTOO_CONFIG_VER}.tar.gz
+ -> gentoo-kernel-config-${GENTOO_CONFIG_VER}.tar.gz
+ amd64? (
+ https://src.fedoraproject.org/rpms/kernel/raw/${CONFIG_HASH}/f/kernel-x86_64-fedora.config
+ -> kernel-x86_64-fedora.config.${CONFIG_VER}
+ )
+ arm64? (
+ https://src.fedoraproject.org/rpms/kernel/raw/${CONFIG_HASH}/f/kernel-aarch64-fedora.config
+ -> kernel-aarch64-fedora.config.${CONFIG_VER}
+ )
+ ppc64? (
+ https://src.fedoraproject.org/rpms/kernel/raw/${CONFIG_HASH}/f/kernel-ppc64le-fedora.config
+ -> kernel-ppc64le-fedora.config.${CONFIG_VER}
+ )
+ x86? (
+ https://src.fedoraproject.org/rpms/kernel/raw/${CONFIG_HASH}/f/kernel-i686-fedora.config
+ -> kernel-i686-fedora.config.${CONFIG_VER}
+ )
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~x86"
+IUSE="debug hardened"
+REQUIRED_USE="arm? ( savedconfig )"
+
+RDEPEND="
+ !sys-kernel/gentoo-kernel-bin:${SLOT}
+"
+BDEPEND="
+ debug? ( dev-util/pahole )
+"
+PDEPEND="
+ >=virtual/dist-kernel-${PV}
+"
+
+QA_FLAGS_IGNORED="
+ usr/src/linux-.*/scripts/gcc-plugins/.*.so
+ usr/src/linux-.*/vmlinux
+"
+
+src_prepare() {
+ local PATCHES=(
+ # meh, genpatches have no directory
+ "${WORKDIR}"/*.patch
+ )
+ default
+
+ local biendian=false
+
+ # prepare the default config
+ case ${ARCH} in
+ amd64)
+ cp "${DISTDIR}/kernel-x86_64-fedora.config.${CONFIG_VER}" .config || die
+ ;;
+ arm)
+ return
+ ;;
+ arm64)
+ cp "${DISTDIR}/kernel-aarch64-fedora.config.${CONFIG_VER}" .config || die
+ biendian=true
+ ;;
+ hppa)
+ return
+ ;;
+ ppc)
+ # assume powermac/powerbook defconfig
+ # we still package.use.force savedconfig
+ cp "${WORKDIR}/${MY_P}/arch/powerpc/configs/pmac32_defconfig" .config || die
+ ;;
+ ppc64)
+ cp "${DISTDIR}/kernel-ppc64le-fedora.config.${CONFIG_VER}" .config || die
+ biendian=true
+ ;;
+ x86)
+ cp "${DISTDIR}/kernel-i686-fedora.config.${CONFIG_VER}" .config || die
+ ;;
+ *)
+ die "Unsupported arch ${ARCH}"
+ ;;
+ esac
+
+ local myversion="-gentoo-dist"
+ use hardened && myversion+="-hardened"
+ echo "CONFIG_LOCALVERSION=\"${myversion}\"" > "${T}"/version.config || die
+ local dist_conf_path="${WORKDIR}/gentoo-kernel-config-${GENTOO_CONFIG_VER}"
+
+ local merge_configs=(
+ "${T}"/version.config
+ "${dist_conf_path}"/base.config
+ )
+ use debug || merge_configs+=(
+ "${dist_conf_path}"/no-debug.config
+ )
+ if use hardened; then
+ merge_configs+=( "${dist_conf_path}"/hardened-base.config )
+
+ tc-is-gcc && merge_configs+=( "${dist_conf_path}"/hardened-gcc-plugins.config )
+
+ if [[ -f "${dist_conf_path}/hardened-${ARCH}.config" ]]; then
+ merge_configs+=( "${dist_conf_path}/hardened-${ARCH}.config" )
+ fi
+ fi
+
+ # this covers ppc64 and aarch64_be only for now
+ if [[ ${biendian} == true && $(tc-endian) == big ]]; then
+ merge_configs+=( "${dist_conf_path}/big-endian.config" )
+ fi
+
+ kernel-build_merge_configs "${merge_configs[@]}"
+}