summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2017-02-07 21:55:10 +0100
committerJeroen Roovers <jer@gentoo.org>2017-02-07 21:56:02 +0100
commitb457b8270d60299b364ca5b82aa2d28415886525 (patch)
treeb29bdac8c6002b49ab68f540a9d5aae54cee0c24
parentdev-util/pycharm-professional: Remove old versions. (diff)
downloadgentoo-b457b827.tar.gz
gentoo-b457b827.tar.bz2
gentoo-b457b827.zip
net-misc/youtube-dl: Version bump.
Package-Manager: Portage-2.3.3, Repoman-2.3.1
-rw-r--r--net-misc/youtube-dl/Manifest1
-rw-r--r--net-misc/youtube-dl/youtube-dl-2017.02.07.ebuild99
2 files changed, 100 insertions, 0 deletions
diff --git a/net-misc/youtube-dl/Manifest b/net-misc/youtube-dl/Manifest
index 3b12a9aaaed1..9ee5b13bea25 100644
--- a/net-misc/youtube-dl/Manifest
+++ b/net-misc/youtube-dl/Manifest
@@ -1,3 +1,4 @@
DIST youtube-dl-2016.12.22.tar.gz 2502964 SHA256 f5bc5eb1af17391b7a1da795f4181c3702fb2c1da2668b25f1260dbdba882524 SHA512 87fee134da660a4feb4cfcd2cbb35cb9682e6ed08c766e3c89f6c986f991cac78c64f5bf8a1d15c4080e4df0909c6a360137407a7896b93f8f41cf4493f341cb WHIRLPOOL 6909d34958e4152be3334723c68d207bb34db2996d90908829ebd3ee45d28768d7f6cba8ce0fb19de440b34fb96b46b3d5b8bf830c998037c4f4d59e574206c3
DIST youtube-dl-2017.01.28.tar.gz 2537285 SHA256 3ca165456799a9a60c875caed37e70c8fe3279326f2715837fcdc4304c64be99 SHA512 92329f37e743cf386d45e8f0113b79bed6465ad7fd03567c723bc6217b2b1652b8fbca93ffece4b3a75d9d33a530837451f88a4cb9d68d6a0a96d27898d8fd68 WHIRLPOOL 8f5b6e977575ce6a16ff8cd74fcf3066957b7c8f183f83202e9f3c536f06d17ddac75caf3aa595ca4e3bf1010e4bc7a2c261ad7a5fe2015a66fb0b137dba3c8f
DIST youtube-dl-2017.02.01.tar.gz 2547975 SHA256 ff77551020c4a81810cb40c9ad36e229db1955d38e390ecdd1333dfc265079ca SHA512 6eddb325238669d84f6d99273d654a34074b38450d6815a6e6ae397989d690126d701e1f0eead147edb8021a950b116ecebee272678b63a5271613c90d7133f0 WHIRLPOOL 99d816b0c48af2b5cd9932a91ae2846656157e1b8f6d411666fff6254552073679f0b21fa6a5dfc44db79767a8b72f6973306e215d9e55f5608375d87cd6f046
+DIST youtube-dl-2017.02.07.tar.gz 2567271 SHA256 e35415388815250e4d32055929850c8d6de0c1b4781b1f70eb80fda0b01a38bf SHA512 075417ba59660915db58a1a8a03a4212ebab73ddbf935d44b82482078d97d530770871ef7be7c7b10e01c2800c279642c988d19a7d546661422900aafe2c97a7 WHIRLPOOL afd425501294fc00241474d8ca540f1c0be87c7da9d4a02cc1bae6e66e08a79864aaf622c2d2be996259018f0be393b2070f25d4e4a430dea469193491b371ca
diff --git a/net-misc/youtube-dl/youtube-dl-2017.02.07.ebuild b/net-misc/youtube-dl/youtube-dl-2017.02.07.ebuild
new file mode 100644
index 000000000000..6cb33319c36f
--- /dev/null
+++ b/net-misc/youtube-dl/youtube-dl-2017.02.07.ebuild
@@ -0,0 +1,99 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=(python{2_7,3_4,3_5})
+inherit bash-completion-r1 distutils-r1 eutils
+
+DESCRIPTION="Download videos from YouTube.com (and more sites...)"
+HOMEPAGE="https://rg3.github.com/youtube-dl/"
+SRC_URI="http://youtube-dl.org/downloads/${PV}/${P}.tar.gz"
+
+LICENSE="public-domain"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~hppa ~ppc ~ppc64 ~x86 ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x86-solaris"
+IUSE="offensive test"
+
+RDEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+"
+DEPEND="
+ ${RDEPEND}
+ test? ( dev-python/nose[coverage(+)] )
+"
+
+S="${WORKDIR}/${PN}"
+
+python_prepare_all() {
+ if ! use offensive; then
+ sed -i -e "/__version__/s|'$|-gentoo_no_offensive_sites'|g" \
+ youtube_dl/version.py || die
+ # these have single line import statements
+ local xxx=(
+ alphaporno anysex behindkink camwithher chaturbate eporner
+ eroprofile extremetube fourtube foxgay goshgay hellporno
+ hentaistigma hornbunny keezmovies lovehomeporn mofosex motherless
+ myvidster porn91 porncom pornhd pornotube pornovoisines pornoxo
+ ruleporn sexu slutload spankbang spankwire sunporno thisav tube8
+ vporn watchindianporn xbef xnxx xtube xvideos xxxymovies youjizz
+ youporn
+ )
+ # these have multi-line import statements
+ local mxxx=(
+ drtuber pornhub redtube xhamster tnaflix
+ )
+ # do single line imports
+ sed -i \
+ -e $( printf '/%s/d;' ${xxx[@]} ) \
+ youtube_dl/extractor/extractors.py \
+ || die
+
+ # do multiple line imports
+ sed -i \
+ -e $( printf '/%s/,/)/d;' ${mxxx[@]} ) \
+ youtube_dl/extractor/extractors.py \
+ || die
+
+ sed -i \
+ -e $( printf '/%s/d;' ${mxxx[@]} ) \
+ youtube_dl/extractor/generic.py \
+ || die
+
+ rm \
+ $( printf 'youtube_dl/extractor/%s.py ' ${xxx[@]} ) \
+ $( printf 'youtube_dl/extractor/%s.py ' ${mxxx[@]} ) \
+ test/test_age_restriction.py \
+ || die
+ fi
+
+ epatch_user
+
+ distutils-r1_python_prepare_all
+}
+
+src_compile() {
+ distutils-r1_src_compile
+}
+
+python_test() {
+ emake test
+}
+
+python_install_all() {
+ dodoc README.txt
+ doman ${PN}.1
+
+ newbashcomp ${PN}.bash-completion ${PN}
+
+ insinto /usr/share/zsh/site-functions
+ newins youtube-dl.zsh _youtube-dl
+
+ insinto /usr/share/fish/completions
+ doins youtube-dl.fish
+
+ distutils-r1_python_install_all
+
+ rm -r "${ED}"/usr/etc || die
+}