summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFlorian Schmaus <flow@gentoo.org>2022-05-02 19:52:29 +0200
committerFlorian Schmaus <flow@gentoo.org>2022-05-02 19:53:42 +0200
commitb47bd160a8ccb0f23eefa018bd8367fc1605d716 (patch)
treef281bdeaef67dd7390bed0606c292974e26b31c9
parentmedia-radio/cwdaemon: destabilize 0.11.0 for ~amd64, ~ppc, ~x86 (diff)
downloadgentoo-b47bd160.tar.gz
gentoo-b47bd160.tar.bz2
gentoo-b47bd160.zip
net-analyzer/python-gvm: fix tests (jonas), PEP517 (sam), and code style
Closes: https://bugs.gentoo.org/842186 Signed-off-by: Florian Schmaus <flow@gentoo.org> Suggested-by: Sam James <sam@gentoo.org> Suggested-by: Jonas Licht <jonas.licht@fem.tu-ilmenau.de>
-rw-r--r--net-analyzer/python-gvm/python-gvm-21.11.0.ebuild16
1 files changed, 11 insertions, 5 deletions
diff --git a/net-analyzer/python-gvm/python-gvm-21.11.0.ebuild b/net-analyzer/python-gvm/python-gvm-21.11.0.ebuild
index b50a5c454cd0..72431694f204 100644
--- a/net-analyzer/python-gvm/python-gvm-21.11.0.ebuild
+++ b/net-analyzer/python-gvm/python-gvm-21.11.0.ebuild
@@ -4,24 +4,30 @@
EAPI=8
PYTHON_COMPAT=( python3_{8..10} )
-DISTUTILS_USE_SETUPTOOLS=pyproject.toml
+DISTUTILS_USE_PEP517=poetry
inherit distutils-r1
DESCRIPTION="Greenbone Vulnerability Management Python Library"
-HOMEPAGE="https://www.greenbone.net/en/ https://github.com/greenbone/python-gvm/"
+HOMEPAGE="https://www.greenbone.net https://github.com/greenbone/python-gvm/"
SRC_URI="https://github.com/greenbone/python-gvm/archive/v${PV}.tar.gz -> ${P}.tar.gz"
SLOT="0"
LICENSE="GPL-3"
KEYWORDS="~amd64 ~x86"
-IUSE=""
RDEPEND="
dev-python/defusedxml[${PYTHON_USEDEP}]
dev-python/lxml[${PYTHON_USEDEP}]
- dev-python/paramiko[${PYTHON_USEDEP}]"
-
+ dev-python/paramiko[${PYTHON_USEDEP}]
+"
DEPEND="${RDEPEND}"
distutils_enable_tests unittest
+
+src_prepare() {
+ distutils-r1_src_prepare
+
+ # drop connection tests
+ rm -r tests/connections || die
+}