summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-05-18 13:45:16 +0200
committerMichał Górny <mgorny@gentoo.org>2024-05-18 13:46:06 +0200
commitb483e4dfb81d2377b538e0dea31ca648f18820fe (patch)
treea5aec369f72fa46309a5e62b2b208b45c0d43a42
parentdev-python/xmlsec: Enable py3.13 (diff)
downloadgentoo-b483e4dfb81d2377b538e0dea31ca648f18820fe.tar.gz
gentoo-b483e4dfb81d2377b538e0dea31ca648f18820fe.tar.bz2
gentoo-b483e4dfb81d2377b538e0dea31ca648f18820fe.zip
dev-python/xmlsec: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/xmlsec/Manifest1
-rw-r--r--dev-python/xmlsec/files/xmlsec-1.3.11-fix-xml-testfail.patch23
-rw-r--r--dev-python/xmlsec/xmlsec-1.3.12-r4.ebuild58
3 files changed, 0 insertions, 82 deletions
diff --git a/dev-python/xmlsec/Manifest b/dev-python/xmlsec/Manifest
index 7a3a87d3cb5a..88f0b1c000c6 100644
--- a/dev-python/xmlsec/Manifest
+++ b/dev-python/xmlsec/Manifest
@@ -1,2 +1 @@
-DIST python-xmlsec-1.3.12.gh.tar.gz 77722 BLAKE2B b5ecece8063b823cdbe4d58967d10026bdc6f3774954021a3739d579ba3c5a08130af1792921c7892e6bc3d00f88ac83ab30e862775e419e0dad40b990b10cbe SHA512 19c5e3bf58b4b0f8a1cca3e60c08348b02ae298620f8c02b8cfb325aecf0313cb2bd1af89507b754ebe4c35af3b031e232d15ddcd42deae0821c9c0d7571aa7c
DIST python-xmlsec-1.3.14.gh.tar.gz 80643 BLAKE2B b256ad1aa18b5a746148ff4b2e8b3136a31105e1bb64d2dd686d5e62c16c183187432ee06f0f8b9da0bdba3b96c3c1e7fb6f51148bb5d5d60e54083841973399 SHA512 7a28695bf122a9c04ed20e4a6a09f9428372c908857b1dd983251a7b890cc50e92a6fbaa7f062cd58d86dda14257720e9c9554b2b54d840f9180110d93145335
diff --git a/dev-python/xmlsec/files/xmlsec-1.3.11-fix-xml-testfail.patch b/dev-python/xmlsec/files/xmlsec-1.3.11-fix-xml-testfail.patch
deleted file mode 100644
index 3e7ab8829c2f..000000000000
--- a/dev-python/xmlsec/files/xmlsec-1.3.11-fix-xml-testfail.patch
+++ /dev/null
@@ -1,23 +0,0 @@
-Taken from: https://github.com/mehcode/python-xmlsec/issues/84#issuecomment-632930116
-diff --git a/tests/base.py b/tests/base.py
-index b05de1d..5ec356f 100644
---- a/tests/base.py
-+++ b/tests/base.py
-@@ -94,6 +94,7 @@ class TestMemoryLeaks(unittest.TestCase):
-
- def load_xml(self, name, xpath=None):
- """returns xml.etree"""
-+ etree.set_default_parser(parser=etree.XMLParser())
- root = etree.parse(self.path(name)).getroot()
- if xpath is None:
- return root
-diff --git a/tests/test_doc_examples.py b/tests/test_doc_examples.py
-index 2fc490f..53d2377 100644
---- a/tests/test_doc_examples.py
-+++ b/tests/test_doc_examples.py
-@@ -42,3 +42,5 @@ def test_doc_example(example):
- """
- with cd(example.parent):
- runpy.run_path(str(example))
-+ from lxml import etree
-+ etree.set_default_parser(parser=etree.XMLParser())
diff --git a/dev-python/xmlsec/xmlsec-1.3.12-r4.ebuild b/dev-python/xmlsec/xmlsec-1.3.12-r4.ebuild
deleted file mode 100644
index 4dc3a59da936..000000000000
--- a/dev-python/xmlsec/xmlsec-1.3.12-r4.ebuild
+++ /dev/null
@@ -1,58 +0,0 @@
-# Copyright 2021-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_EXT=1
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{10..12} )
-
-inherit distutils-r1
-
-MY_P=python-xmlsec-${PV}
-DESCRIPTION="Python bindings for the XML Security Library"
-HOMEPAGE="
- https://github.com/xmlsec/python-xmlsec/
- https://pypi.org/project/xmlsec/
-"
-SRC_URI="
- https://github.com/xmlsec/python-xmlsec/archive/${PV}.tar.gz
- -> ${MY_P}.gh.tar.gz
-"
-S=${WORKDIR}/${MY_P}
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="amd64 arm64 ~ppc64 x86"
-
-# Doesn't yet support xmlsec-1.3.0: https://github.com/xmlsec/python-xmlsec/issues/252
-RDEPEND="
- <dev-libs/xmlsec-1.3.0:=[openssl]
- dev-python/lxml[${PYTHON_USEDEP}]
-"
-DEPEND="${RDEPEND}"
-BDEPEND="
- dev-python/pkgconfig[${PYTHON_USEDEP}]
- dev-python/setuptools-scm[${PYTHON_USEDEP}]
- dev-python/wheel[${PYTHON_USEDEP}]
- test? (
- dev-python/hypothesis[${PYTHON_USEDEP}]
- )
-"
-
-PATCHES=(
- "${FILESDIR}/${PN}-1.3.11-fix-xml-testfail.patch"
-)
-
-EPYTEST_DESELECT=(
- # Fragile based on black version?
- tests/test_type_stubs.py::test_xmlsec_constants_stub
-
- # Broken with xmlsec-1.2.36+.
- # https://github.com/xmlsec/python-xmlsec/issues/244
- tests/test_ds.py::TestSignContext::test_sign_case5
-)
-
-distutils_enable_tests pytest
-
-export SETUPTOOLS_SCM_PRETEND_VERSION=${PV}