summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Ammerlaan <andrewammerlaan@gentoo.org>2024-05-18 18:58:20 +0200
committerAndrew Ammerlaan <andrewammerlaan@gentoo.org>2024-05-18 19:00:15 +0200
commitb486f36fea247b526d628e3e04b5de2846eff730 (patch)
tree57507706078f753ee57175b69e3fb4d3dc821a26
parentdev-python/mamba: Enable py3.13 (diff)
downloadgentoo-b486f36fea247b526d628e3e04b5de2846eff730.tar.gz
gentoo-b486f36fea247b526d628e3e04b5de2846eff730.tar.bz2
gentoo-b486f36fea247b526d628e3e04b5de2846eff730.zip
media-libs/libvpl-tools: rework USE flags
Seems a bunch of things changed when this was separated from libvpl. Rework this now properly, fix required_use, enable vaapi and drm by default. Fix build failure when X flag disabled. Closes: https://bugs.gentoo.org/932141 Signed-off-by: Andrew Ammerlaan <andrewammerlaan@gentoo.org>
-rw-r--r--media-libs/libvpl-tools/libvpl-tools-1.0.0-r2.ebuild (renamed from media-libs/libvpl-tools/libvpl-tools-1.0.0-r1.ebuild)28
1 files changed, 20 insertions, 8 deletions
diff --git a/media-libs/libvpl-tools/libvpl-tools-1.0.0-r1.ebuild b/media-libs/libvpl-tools/libvpl-tools-1.0.0-r2.ebuild
index 503d1172c45c..ba84438f5c04 100644
--- a/media-libs/libvpl-tools/libvpl-tools-1.0.0-r1.ebuild
+++ b/media-libs/libvpl-tools/libvpl-tools-1.0.0-r2.ebuild
@@ -13,19 +13,21 @@ LICENSE="MIT"
SLOT="0"
KEYWORDS="~amd64"
-IUSE="dri drm test vaapi wayland X"
+IUSE="dri +drm opencl test +vaapi wayland X"
RESTRICT="!test? ( test )"
REQUIRED_USE="
- dri? ( X drm )
+ dri? ( X )
+ opencl? ( X )
+ vaapi? ( drm )
+ wayland? ( vaapi )
X? ( vaapi )
- wayland? ( drm )
"
RDEPEND="
- x11-libs/libpciaccess
- vaapi? ( media-libs/libva[X?,wayland?,drm(+)?] )
drm? ( x11-libs/libdrm )
+ opencl? ( virtual/opencl )
+ vaapi? ( media-libs/libva[X?,wayland?,drm(+)?] )
wayland? (
dev-libs/wayland
)
@@ -33,25 +35,35 @@ RDEPEND="
x11-libs/libX11
x11-libs/libxcb
)
+ x11-libs/libpciaccess
>=media-libs/libvpl-2.11.0
"
+
DEPEND="${RDEPEND}
wayland? (
dev-libs/wayland-protocols
)
"
+
BDEPEND="virtual/pkgconfig"
src_configure() {
local mycmakeargs=(
-DBUILD_SHARED_LIBS=ON
-DBUILD_TESTS="$(usex test)"
+
+ -DBUILD_EXPERIMENTAL="$(usex X)"
-DTOOLS_ENABLE_X11="$(usex X)"
- -DENABLE_WAYLAND="$(usex wayland)"
- -DENABLE_X11="$(usex X)"
+ -DTOOLS_ENABLE_SCREEN_CAPTURE="$(usex X)"
+ -DTOOLS_ENABLE_RENDER="$(usex X)"
+ -DTOOLS_ENABLE_OPENCL="$(usex opencl)"
+
-DENABLE_DRI3="$(usex dri)"
- -DENABLE_VA="$(usex vaapi)"
-DENABLE_DRM="$(usex drm)"
+ -DENABLE_VA="$(usex vaapi)"
+ -DENABLE_WAYLAND="$(usex wayland)"
+ -DENABLE_X11="$(usex X)"
+
-DCMAKE_INSTALL_PREFIX="${EPREFIX}/usr"
-DCMAKE_INSTALL_SYSCONFDIR="${EPREFIX}/etc"
)