summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2017-05-06 19:36:43 -0400
committerTim Harder <radhermit@gentoo.org>2017-05-06 19:37:23 -0400
commitb49b14ae6f5e552c4195d9eaaa0f6e4104f19e2f (patch)
treefbf68b37fac60e4d9bcd7ad47958f94e25cd7cf2
parentpackage.mask: Masked net-im/licq for removal. (diff)
downloadgentoo-b49b14ae.tar.gz
gentoo-b49b14ae.tar.bz2
gentoo-b49b14ae.zip
dev-vcs/tig: version bump to 2.2.2
-rw-r--r--dev-vcs/tig/Manifest1
-rw-r--r--dev-vcs/tig/tig-2.2.2.ebuild56
-rw-r--r--dev-vcs/tig/tig-9999.ebuild2
3 files changed, 58 insertions, 1 deletions
diff --git a/dev-vcs/tig/Manifest b/dev-vcs/tig/Manifest
index 569be884c4fc..1168d065b987 100644
--- a/dev-vcs/tig/Manifest
+++ b/dev-vcs/tig/Manifest
@@ -1 +1,2 @@
DIST tig-2.2.1.tar.gz 1028479 SHA256 0b48080896de59179c45c980080b4b414bb235df65ad08d661a9c9e169c3fa71 SHA512 6e483a400e222c01a4f518ee473b8d37933e820a2da1fc2cfe0ae9fb8217867d16f1aee3deecb14ce9af6a6dd2814d709d6ffce5f1f5054b94d2ab533b47008b WHIRLPOOL a4bcb381f81d07d92623a38c3ed5a78321043a776f0e4cb44e0f736cf960b01d2599b90f7a7f9056d0e0388ecd8112f25aed1b162c9b629c4bf9d10eaa98ebb7
+DIST tig-2.2.2.tar.gz 1046910 SHA256 316214d87f7693abc0cbe8ebbb85decdf5e1b49d7ad760ac801af3dd73385e35 SHA512 e43cf8b4e7938342b581a1238222d5cbf62e242208cd65fc9b3261c4076b7c60c182f9a80613538fcf8b50187cc2844c22f6d1aeaaa8b23864670667a91dbfcd WHIRLPOOL c4f569d969bacdea8f7a765acfced6c45b04f36c5eca915702c369de1ab11dbe4d8c01934852d40ffdd641dcbf5ed699803c67ea3deccf539721dba46ca23716
diff --git a/dev-vcs/tig/tig-2.2.2.ebuild b/dev-vcs/tig/tig-2.2.2.ebuild
new file mode 100644
index 000000000000..6e50ecf1bf1c
--- /dev/null
+++ b/dev-vcs/tig/tig-2.2.2.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit bash-completion-r1
+
+if [[ ${PV} == "9999" ]] ; then
+ EGIT_REPO_URI="https://github.com/jonas/tig.git"
+ inherit git-r3 autotools
+else
+ SRC_URI="https://github.com/jonas/tig/releases/download/${P}/${P}.tar.gz"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
+fi
+
+DESCRIPTION="text mode interface for git"
+HOMEPAGE="https://jonas.github.io/tig/"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="unicode"
+
+DEPEND="
+ sys-libs/ncurses:0=[unicode?]
+ sys-libs/readline:0="
+RDEPEND="${DEPEND}
+ dev-vcs/git"
+[[ ${PV} == "9999" ]] && DEPEND+=" app-text/asciidoc app-text/xmlto"
+
+src_prepare() {
+ default
+ [[ ${PV} == "9999" ]] && eautoreconf
+}
+
+src_configure() {
+ econf $(use_with unicode ncursesw)
+}
+
+src_compile() {
+ emake V=1
+ [[ ${PV} == "9999" ]] && emake V=1 doc-man doc-html
+}
+
+src_test() {
+ # workaround parallel test failures
+ emake -j1 test
+}
+
+src_install() {
+ emake DESTDIR="${D}" install install-doc-man
+ dodoc doc/manual.html README.html NEWS.html
+ newbashcomp contrib/tig-completion.bash ${PN}
+
+ docinto examples
+ dodoc contrib/*.tigrc
+}
diff --git a/dev-vcs/tig/tig-9999.ebuild b/dev-vcs/tig/tig-9999.ebuild
index 9a2e38d50158..6e50ecf1bf1c 100644
--- a/dev-vcs/tig/tig-9999.ebuild
+++ b/dev-vcs/tig/tig-9999.ebuild
@@ -10,7 +10,7 @@ if [[ ${PV} == "9999" ]] ; then
inherit git-r3 autotools
else
SRC_URI="https://github.com/jonas/tig/releases/download/${P}/${P}.tar.gz"
- KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
fi
DESCRIPTION="text mode interface for git"