summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-12-08 05:37:51 +0100
committerMichał Górny <mgorny@gentoo.org>2023-12-08 05:37:51 +0100
commitb4a9adc46f4f670c7a6cae2215d81afd4e687ef2 (patch)
tree71bc8311c1a4444a9bddc9c6e1084b6591a5f450
parentdev-python/gmpy: Remove old (diff)
downloadgentoo-b4a9adc4.tar.gz
gentoo-b4a9adc4.tar.bz2
gentoo-b4a9adc4.zip
dev-python/hypothesis: Bump to 6.91.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/hypothesis/Manifest1
-rw-r--r--dev-python/hypothesis/hypothesis-6.91.1.ebuild90
2 files changed, 91 insertions, 0 deletions
diff --git a/dev-python/hypothesis/Manifest b/dev-python/hypothesis/Manifest
index 0804cb2ad869..68f6881a7e2c 100644
--- a/dev-python/hypothesis/Manifest
+++ b/dev-python/hypothesis/Manifest
@@ -1,2 +1,3 @@
DIST hypothesis-6.90.0.gh.tar.gz 9395761 BLAKE2B fb910f8f885355d6045f1f218dedf35e6713fbed8d9d247310ec7a8b7aa4549b30715a50ebb0daa5e48f863b6c582a8cbc8910f26ab0da0476bc423f942534fc SHA512 02ca4f5b4c0c6cc2b949d46ac221a3c06a9d05fb89fc17c1a8e42813172b914822ba484970a20d1be1900e5396bf020ba1e274344aa8bf16253f18a6f11c6ac1
DIST hypothesis-6.91.0.gh.tar.gz 9396774 BLAKE2B c2db54aa0cb95725c2ef38854ee04d756551746ea2b9eb5b79728dec274ffed08b9e8357616ce7057f4e988d3194017ea35849bfb88a35ce8d9574dd6710c582 SHA512 e6280e14e600305a0d9007c086fb55a2c5f441e40274d920d627d7cf12f07b0fe65d1e64c42ad712d662cf0f5aa41bfbb00b6ae3a716e88dacb7c72c3067601c
+DIST hypothesis-6.91.1.gh.tar.gz 9398188 BLAKE2B 3a068ec668f84cf84ebd274505938d861ef7b6f50a9bb33403c26c53b783ee6fe6afba214ca5d9c31e933909dd657d367c09dd74dac257348316e308ed761ccb SHA512 4004fe0dcef1dc679ee512f901f1115426fdbd8d0f2b1fc539c331157d1840bb16c415c7bcf0cbfae3e1dcf6f9741eb8e2ec725810f5d65e20e75f0ea07369b8
diff --git a/dev-python/hypothesis/hypothesis-6.91.1.ebuild b/dev-python/hypothesis/hypothesis-6.91.1.ebuild
new file mode 100644
index 000000000000..832123b43c6e
--- /dev/null
+++ b/dev-python/hypothesis/hypothesis-6.91.1.ebuild
@@ -0,0 +1,90 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+CLI_COMPAT=( python3_{10..12} )
+PYTHON_COMPAT=( "${CLI_COMPAT[@]}" pypy3 )
+PYTHON_REQ_USE="threads(+),sqlite"
+
+inherit distutils-r1 multiprocessing optfeature
+
+TAG=hypothesis-python-${PV}
+MY_P=hypothesis-${TAG}
+DESCRIPTION="A library for property based testing"
+HOMEPAGE="
+ https://github.com/HypothesisWorks/hypothesis/
+ https://pypi.org/project/hypothesis/
+"
+SRC_URI="
+ https://github.com/HypothesisWorks/hypothesis/archive/${TAG}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+S="${WORKDIR}/${MY_P}/hypothesis-python"
+
+LICENSE="MPL-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+IUSE="cli"
+
+RDEPEND="
+ >=dev-python/attrs-22.2.0[${PYTHON_USEDEP}]
+ >=dev-python/sortedcontainers-2.1.0[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ >=dev-python/exceptiongroup-1.0.0_rc8[${PYTHON_USEDEP}]
+ ' 3.9 3.10)
+ cli? (
+ $(python_gen_cond_dep '
+ dev-python/black[${PYTHON_USEDEP}]
+ dev-python/click[${PYTHON_USEDEP}]
+ ' "${CLI_COMPAT[@]}")
+ )
+"
+BDEPEND="
+ test? (
+ dev-python/pexpect[${PYTHON_USEDEP}]
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ !!<dev-python/requests-toolbelt-0.10.1
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ # subtests are broken by warnings from random plugins
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ local -x PYTEST_PLUGINS=xdist.plugin,_hypothesis_pytestplugin
+ local -x HYPOTHESIS_NO_PLUGINS=1
+
+ # NB: paths need to be relative to pytest.ini,
+ # i.e. start with hypothesis-python/
+ local EPYTEST_DESELECT=()
+ case ${EPYTHON} in
+ pypy3)
+ EPYTEST_DESELECT+=(
+ # failing due to warnings from numpy/cython
+ hypothesis-python/tests/pytest/test_fixtures.py::test_given_plus_overridden_fixture
+ )
+ ;;
+ esac
+
+ epytest -o filterwarnings= -n "$(makeopts_jobs)" --dist=worksteal \
+ tests/cover tests/pytest tests/quality
+}
+
+python_install() {
+ distutils-r1_python_install
+ if ! use cli || ! has "${EPYTHON}" "${CLI_COMPAT[@]/_/.}"; then
+ rm -r "${ED}/usr/bin" "${D}$(python_get_scriptdir)" || die
+ fi
+}
+
+pkg_postinst() {
+ optfeature "datetime support" dev-python/pytz
+ optfeature "dateutil support" dev-python/python-dateutil
+ optfeature "numpy support" dev-python/numpy
+ optfeature "django support" dev-python/django dev-python/pytz
+ optfeature "pandas support" dev-python/pandas
+ optfeature "pytest support" dev-python/pytest
+}