summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEli Schwartz <eschwartz93@gmail.com>2024-03-17 00:06:59 -0400
committerSam James <sam@gentoo.org>2024-03-17 05:28:44 +0000
commitb4b0aaa72c3a9563736ae657f51e30b5f6584c81 (patch)
tree722cd05fe097f79805327e9c7ffe86e5561dac3b
parentwww-servers/gatling: update EAPI 7 -> 8 (diff)
downloadgentoo-b4b0aaa7.tar.gz
gentoo-b4b0aaa7.tar.bz2
gentoo-b4b0aaa7.zip
www-servers/gatling: drop old
Signed-off-by: Eli Schwartz <eschwartz93@gmail.com> Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--www-servers/gatling/gatling-0.16-r3.ebuild63
-rw-r--r--www-servers/gatling/gatling-0.16-r4.ebuild64
2 files changed, 0 insertions, 127 deletions
diff --git a/www-servers/gatling/gatling-0.16-r3.ebuild b/www-servers/gatling/gatling-0.16-r3.ebuild
deleted file mode 100644
index 6070f0332438..000000000000
--- a/www-servers/gatling/gatling-0.16-r3.ebuild
+++ /dev/null
@@ -1,63 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="7"
-
-inherit toolchain-funcs
-
-DESCRIPTION="High performance web server"
-HOMEPAGE="https://www.fefe.de/gatling/"
-SRC_URI="https://www.fefe.de/gatling/${P}.tar.xz"
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-
-IUSE="ssl diet"
-REQUIRED_USE="ssl? ( !diet )"
-
-DEPEND=">=dev-libs/libowfat-0.32-r2[diet=]
- virtual/libcrypt:=
- diet? ( dev-libs/dietlibc )
- ssl? (
- dev-libs/openssl:0=
- )"
-RDEPEND="${DEPEND}
- acct-group/gatling
- acct-user/gatling
- "
-
-PATCHES=(
- "${FILESDIR}/${PN}-0.13-compile.patch"
- "${FILESDIR}/${PN}-0.15-ar.patch"
-)
-
-src_prepare() {
- default
- rm Makefile # leaves us with GNUmakefile
-}
-
-src_compile() {
- local DIET=
- use diet && DIET='/usr/bin/diet'
-
- local targets='gatling'
- use ssl && targets+=' tlsgatling'
-
- emake DIET="${DIET}" CC="$(tc-getCC)" \
- CFLAGS="${CFLAGS} -I${ESYSROOT}/usr/include/libowfat" \
- LDFLAGS="${LDFLAGS}" prefix=/usr ${targets}
-}
-
-src_install() {
- doman gatling.1
-
- newconfd "${FILESDIR}/gatling.confd" gatling
- newinitd "${FILESDIR}/gatling.initd-3" gatling
- dodoc README.{ftp,http}
-
- dobin gatling
- use ssl && {
- dodoc README.tls
- dobin tlsgatling
- }
-}
diff --git a/www-servers/gatling/gatling-0.16-r4.ebuild b/www-servers/gatling/gatling-0.16-r4.ebuild
deleted file mode 100644
index 5562859bec4a..000000000000
--- a/www-servers/gatling/gatling-0.16-r4.ebuild
+++ /dev/null
@@ -1,64 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="7"
-
-inherit toolchain-funcs
-
-DESCRIPTION="High performance web server"
-HOMEPAGE="https://www.fefe.de/gatling/"
-SRC_URI="https://www.fefe.de/gatling/${P}.tar.xz"
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-
-IUSE="ssl diet"
-REQUIRED_USE="ssl? ( !diet )"
-
-DEPEND=">=dev-libs/libowfat-0.32-r2[diet=]
- virtual/libcrypt:=
- diet? ( dev-libs/dietlibc )
- ssl? (
- dev-libs/openssl:0=
- )"
-RDEPEND="${DEPEND}
- acct-group/gatling
- acct-user/gatling
- "
-
-PATCHES=(
- "${FILESDIR}/${PN}-0.13-compile.patch"
- "${FILESDIR}/${PN}-0.15-ar.patch"
- "${FILESDIR}/${PN}-0.16-r4-0001-try-alloca-socket-fix-Wimplicit-int.patch"
-)
-
-src_prepare() {
- default
- rm Makefile # leaves us with GNUmakefile
-}
-
-src_compile() {
- local DIET=
- use diet && DIET='/usr/bin/diet'
-
- local targets='gatling'
- use ssl && targets+=' tlsgatling'
-
- emake DIET="${DIET}" CC="$(tc-getCC)" \
- CFLAGS="${CFLAGS} -I${ESYSROOT}/usr/include/libowfat" \
- LDFLAGS="${LDFLAGS}" prefix=/usr ${targets}
-}
-
-src_install() {
- doman gatling.1
-
- newconfd "${FILESDIR}/gatling.confd" gatling
- newinitd "${FILESDIR}/gatling.initd-3" gatling
- dodoc README.{ftp,http}
-
- dobin gatling
- use ssl && {
- dodoc README.tls
- dobin tlsgatling
- }
-}