summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-05-26 22:01:47 +0200
committerMichał Górny <mgorny@gentoo.org>2021-05-26 22:39:37 +0200
commitb4b2e03bdb4330daf9c3930fe5292ca50f760754 (patch)
tree538965a212c88f1b78abcaffc7327426b019e5cd
parentdev-python/Faker: Bump to 8.3.0 (diff)
downloadgentoo-b4b2e03bdb4330daf9c3930fe5292ca50f760754.tar.gz
gentoo-b4b2e03bdb4330daf9c3930fe5292ca50f760754.tar.bz2
gentoo-b4b2e03bdb4330daf9c3930fe5292ca50f760754.zip
dev-python/google-api-python-client: Bump to 2.6.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/google-api-python-client/Manifest1
-rw-r--r--dev-python/google-api-python-client/google-api-python-client-2.6.0.ebuild49
2 files changed, 50 insertions, 0 deletions
diff --git a/dev-python/google-api-python-client/Manifest b/dev-python/google-api-python-client/Manifest
index 972ed4a92dd4..151b8cb4c2e9 100644
--- a/dev-python/google-api-python-client/Manifest
+++ b/dev-python/google-api-python-client/Manifest
@@ -2,3 +2,4 @@ DIST google-api-python-client-2.2.0.tar.gz 24631108 BLAKE2B 377b87d30a0adb2bdbf9
DIST google-api-python-client-2.3.0.tar.gz 24912943 BLAKE2B 60233808f0f6243c37e8915791975e9aa10fa2d82e54c183582db9712dc36920d7d99f6caa67a25a96b1806ae9f96fd4f371010472b753f7a80d5e4fab49bd3e SHA512 11b9ba2f6417c017d47c9563460c38afdbfd01658e6c0f1812b1cdd1068b04bd37bb362e2ade4214fcc9a89d758f31bc977e281b093793a48641a2b7d926715e
DIST google-api-python-client-2.4.0.tar.gz 24853833 BLAKE2B 4ed2083a9bb8b4f8fe31ab5dbd7875c0c36c972cdb0f71a59565fe4eb23ff1ef0a40794acd7af9646c1ee3904fbab3caaeb2700a3660b66d3069d2bc4f811e76 SHA512 db545850b9d2746e3bcf7b4a2f12b0d4827bd68f44d5627fd80d39bff2ca3303c8d520f72ee17637fe700bc935548706ce885ff0d7fe737ae157668e0314fbc6
DIST google-api-python-client-2.5.0.tar.gz 24996941 BLAKE2B cd29420cde87584324fedc8a0ebb91fa20e65a84418cab1eae8ac5a7adedbb09a8f5b1367e3ff7606f448b1125c6d4289cb2dcd908031707774fe7dad50c9229 SHA512 b97abbf87aab42ea14907500d5955d43e318087a73ddb08c43d8f073aefdb56ef31dce7d3ce054ac8bbe6140d5adbb6a54dc977b4c504cad00fe99937f5acb7e
+DIST google-api-python-client-2.6.0.tar.gz 25405797 BLAKE2B 4961d4940b82edb1ef839b7433c69a0c0abded1593a7a229a97e52f42583d6808a3325d76a1dab4c6ff3d9c66462190e408ac22afc66b8c0585205ff7b0974af SHA512 eaf0bb958d54a5b74916ac962e6d0b1b55679ffe6a2bf663e0574a86c799e9ba3ae49ff9a986b81ebe8ba407c8dfe4e46388325f3725afe49f2b157fca10b978
diff --git a/dev-python/google-api-python-client/google-api-python-client-2.6.0.ebuild b/dev-python/google-api-python-client/google-api-python-client-2.6.0.ebuild
new file mode 100644
index 000000000000..5ab50082b8d7
--- /dev/null
+++ b/dev-python/google-api-python-client/google-api-python-client-2.6.0.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..9} )
+
+inherit distutils-r1
+
+DESCRIPTION="Google API Client for Python"
+HOMEPAGE="https://github.com/googleapis/google-api-python-client"
+SRC_URI="https://github.com/googleapis/google-api-python-client/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+
+RDEPEND="
+ >=dev-python/httplib2-0.15[${PYTHON_USEDEP}]
+ <dev-python/httplib2-1[${PYTHON_USEDEP}]
+ dev-python/google-api-core[${PYTHON_USEDEP}]
+ >=dev-python/google-auth-1.16.0[${PYTHON_USEDEP}]
+ >=dev-python/google-auth-httplib2-0.1.0[${PYTHON_USEDEP}]
+ >=dev-python/uritemplate-3.0.0[${PYTHON_USEDEP}]
+ <dev-python/uritemplate-4[${PYTHON_USEDEP}]
+ >=dev-python/six-1.13.0[${PYTHON_USEDEP}]
+ <dev-python/six-2[${PYTHON_USEDEP}]
+ "
+BDEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/oauth2client[${PYTHON_USEDEP}]
+ dev-python/pandas[${PYTHON_USEDEP}]
+ dev-python/parameterized[${PYTHON_USEDEP}]
+ dev-python/unittest2[${PYTHON_USEDEP}]
+ )"
+
+distutils_enable_tests --install pytest
+
+python_test() {
+ local deselect=(
+ # require Internet access (and credentials)
+ tests/test_discovery.py::DiscoveryErrors::test_credentials_and_credentials_file_mutually_exclusive
+ tests/test_discovery.py::DiscoveryFromDocument::test_api_endpoint_override_from_client_options_mapping_object
+ )
+
+ distutils_install_for_testing
+ epytest ${deselect[@]/#/--deselect }
+}