summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2022-12-05 21:55:34 +0100
committerAlfredo Tupone <tupone@gentoo.org>2022-12-05 21:55:58 +0100
commitb4b442f8c20eee754e88d01747e6983618075522 (patch)
treedc0220f837b3de0670466405ae72ae2f47521f01
parentapp-eselect/eselect-wine: add 2.0.2, drop 2.0.1-r2 (diff)
downloadgentoo-b4b442f8c20eee754e88d01747e6983618075522.tar.gz
gentoo-b4b442f8c20eee754e88d01747e6983618075522.tar.bz2
gentoo-b4b442f8c20eee754e88d01747e6983618075522.zip
dev-ada/e3-core: add 22.2.0
Signed-off-by: Alfredo Tupone <tupone@gentoo.org>
-rw-r--r--dev-ada/e3-core/Manifest1
-rw-r--r--dev-ada/e3-core/e3-core-22.2.0.ebuild55
2 files changed, 56 insertions, 0 deletions
diff --git a/dev-ada/e3-core/Manifest b/dev-ada/e3-core/Manifest
index f40ace1eb88e..b90a2b0749f9 100644
--- a/dev-ada/e3-core/Manifest
+++ b/dev-ada/e3-core/Manifest
@@ -1 +1,2 @@
DIST e3-core-22.1.0.tar.gz 442938 BLAKE2B b207a09d8b97f707e8b3a6255b9ef7161e40f716a8bcd853923df2310f2413689ddadf9db98e90f103f8a93813eec20bf462e47541d6f409df5966b0b1d9fca7 SHA512 e887fea2140bb42ebc9d8596b87dc077f8da6a0ed4178081aedaaf3f462b76a431c53e6e56bcb7efee2ed3854c50d7b989819b469b394977d6d25f644368f12d
+DIST e3-core-22.2.0.tar.gz 383417 BLAKE2B ef595dc785b0073a53ddb06ab1ab7b1a0e9eea0131d2a15318f6355a581f83d14f61f6b0f23d4e3df4afe31e0c03a6b1b4ca8b5aefdb3f982ccaa3454f127f0d SHA512 a2bc2a183b3fed9ad2f0119406dc26857254e4a68014f618a75c062518b990e5f1f3af72e9dc321dea3f9248bd97bded87a20b5389a3e03f2d3b76bb83f56216
diff --git a/dev-ada/e3-core/e3-core-22.2.0.ebuild b/dev-ada/e3-core/e3-core-22.2.0.ebuild
new file mode 100644
index 000000000000..34a0061cc70f
--- /dev/null
+++ b/dev-ada/e3-core/e3-core-22.2.0.ebuild
@@ -0,0 +1,55 @@
+# Copyright 2021-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8,9,10} )
+DISTUTILS_USE_PEP517=setuptools
+inherit distutils-r1 toolchain-funcs
+
+DESCRIPTION="Ease the development of portable automated build systems"
+HOMEPAGE="https://www.adacore.com/"
+SRC_URI="https://github.com/AdaCore/${PN}/archive/refs/tags/v${PV}.tar.gz
+ -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+RESTRICT="test"
+
+RDEPEND="dev-python/colorama[${PYTHON_USEDEP}]
+ dev-python/stevedore[${PYTHON_USEDEP}]
+ dev-python/distro[${PYTHON_USEDEP}]
+ dev-python/tqdm[${PYTHON_USEDEP}]
+ dev-python/psutil[${PYTHON_USEDEP}]
+ dev-python/requests-toolbelt[${PYTHON_USEDEP}]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ dev-python/tomlkit[${PYTHON_USEDEP}]
+ !app-editors/e3"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ test? (
+ dev-python/httpretty[${PYTHON_USEDEP}]
+ dev-vcs/subversion
+ dev-python/mock[${PYTHON_USEDEP}]
+ )"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-22.1.0-distro.patch
+ "${FILESDIR}"/${PN}-22.1.0-test.patch
+)
+
+distutils_enable_tests pytest
+
+python_compile() {
+ distutils-r1_python_compile
+ find "${BUILD_DIR}" -name '*.pth' -delete || die
+}
+
+src_compile() {
+ local PLATFORM=x86_64-linux
+ rm src/e3/os/data/rlimit* || die
+ $(tc-getCC) ${CFLAGS} -o src/e3/os/data/rlimit-${PLATFORM} tools/rlimit/rlimit.c ${LDFLAGS}
+ distutils-r1_src_compile
+}