summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authororbea <orbea@riseup.net>2023-04-26 09:00:23 -0700
committerSam James <sam@gentoo.org>2023-04-28 01:48:09 +0100
commitb4d09bb5d767ebb39c3133c6456c018c74562e0e (patch)
tree242b25bcfd8b9ab0e91cb04195741deb50ae6d19
parentdev-cpp/tbb: fix build w/ gcc 13 (diff)
downloadgentoo-b4d09bb5d767ebb39c3133c6456c018c74562e0e.tar.gz
gentoo-b4d09bb5d767ebb39c3133c6456c018c74562e0e.tar.bz2
gentoo-b4d09bb5d767ebb39c3133c6456c018c74562e0e.zip
sys-auth/pam_p11: Add upstream libressl patch
This patch was accepted upstream and fixes the build with libressl >= 3.0.0. Bug: https://bugs.gentoo.org/903001 Upstream-PR: https://github.com/OpenSC/pam_p11/pull/26 Upstream-Commit: https://github.com/OpenSC/pam_p11/commit/cb2f0c318c94e30addfce3b432ed91496a43e411 Signed-off-by: orbea <orbea@riseup.net> Closes: https://github.com/gentoo/gentoo/pull/30771 Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--sys-auth/pam_p11/files/pam_p11-0.3.1-libressl.patch28
-rw-r--r--sys-auth/pam_p11/pam_p11-0.3.1.ebuild6
2 files changed, 33 insertions, 1 deletions
diff --git a/sys-auth/pam_p11/files/pam_p11-0.3.1-libressl.patch b/sys-auth/pam_p11/files/pam_p11-0.3.1-libressl.patch
new file mode 100644
index 000000000000..e085e06e9006
--- /dev/null
+++ b/sys-auth/pam_p11/files/pam_p11-0.3.1-libressl.patch
@@ -0,0 +1,28 @@
+https://bugs.gentoo.org/903001
+https://github.com/OpenSC/pam_p11/pull/26
+https://github.com/OpenSC/pam_p11/commit/cb2f0c318c94e30addfce3b432ed91496a43e411
+
+From b307045a93d042ac9e3871e35f8495e8bb201574 Mon Sep 17 00:00:00 2001
+From: orbea <orbea@riseup.net>
+Date: Tue, 11 Apr 2023 07:29:12 -0700
+Subject: [PATCH] match_openssh: Fix the build for LibreSSL >= 3.0.0
+
+Newer LibreSSL versions no longer need the older OpenSSL APIs.
+---
+ src/match_openssh.c | 3 ++-
+ 1 file changed, 2 insertions(+), 1 deletion(-)
+
+diff --git a/src/match_openssh.c b/src/match_openssh.c
+index 89cbd73..fb59308 100644
+--- a/src/match_openssh.c
++++ b/src/match_openssh.c
+@@ -22,7 +22,8 @@
+
+ #define OPENSSH_LINE_MAX 16384 /* from openssh SSH_MAX_PUBKEY_BYTES */
+
+-#if (OPENSSL_VERSION_NUMBER < 0x10100000L) || defined (LIBRESSL_VERSION_NUMBER)
++#if (OPENSSL_VERSION_NUMBER < 0x10100000L) || \
++ (defined(LIBRESSL_VERSION_NUMBER) && LIBRESSL_VERSION_NUMBER < 0x3000000L)
+ void RSA_get0_key(const RSA *r,
+ const BIGNUM **n, const BIGNUM **e, const BIGNUM **d)
+ {
diff --git a/sys-auth/pam_p11/pam_p11-0.3.1.ebuild b/sys-auth/pam_p11/pam_p11-0.3.1.ebuild
index 0322e3038be0..4b50c70d2edc 100644
--- a/sys-auth/pam_p11/pam_p11-0.3.1.ebuild
+++ b/sys-auth/pam_p11/pam_p11-0.3.1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -20,6 +20,10 @@ RDEPEND="sys-libs/pam
DEPEND="${RDEPEND}"
BDEPEND="virtual/pkgconfig"
+PATCHES=(
+ "${FILESDIR}/${P}-libressl.patch" #903001
+)
+
src_configure() {
# Ugly way to work around deprecated declarations in openssl-3
append-cflags -Wno-error=deprecated-declarations