summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2021-06-26 00:30:03 -0700
committerMatt Turner <mattst88@gentoo.org>2021-06-26 13:19:32 -0700
commitb4d18d1f0f07ad26667f599190c5e8410caf9336 (patch)
tree3b49baa268f6f3284ba07abdf9cd92f6debee31f
parentdev-python/tikzplotlib: drop version 0.9.8 (diff)
downloadgentoo-b4d18d1f.tar.gz
gentoo-b4d18d1f.tar.bz2
gentoo-b4d18d1f.zip
dev-libs/totem-pl-parser: Version bump to 3.26.6
Signed-off-by: Matt Turner <mattst88@gentoo.org>
-rw-r--r--dev-libs/totem-pl-parser/Manifest1
-rw-r--r--dev-libs/totem-pl-parser/metadata.xml1
-rw-r--r--dev-libs/totem-pl-parser/totem-pl-parser-3.26.6.ebuild68
3 files changed, 70 insertions, 0 deletions
diff --git a/dev-libs/totem-pl-parser/Manifest b/dev-libs/totem-pl-parser/Manifest
index d8238945bd3a..eb05de219b41 100644
--- a/dev-libs/totem-pl-parser/Manifest
+++ b/dev-libs/totem-pl-parser/Manifest
@@ -1 +1,2 @@
DIST totem-pl-parser-3.26.5.tar.xz 1318700 BLAKE2B 18cea2edff1206ed9c77ac07fb018da0c9bc5550599b45e363d745166f4828adba6a2f77b763602af011c0a12e9f1f9765402fbafbe097fb69890ec7a9520825 SHA512 ce110d92f60da328272a8135a57ba60785ea4bca1fde3703a734969e7ba5b382ef19dc3b8930a5641d8f8effabf627f7e9b2727ee94e69e6144e0f085079e14d
+DIST totem-pl-parser-3.26.6.tar.xz 1503888 BLAKE2B b0768f54c77ff902ad20aeaa9162c616e0cc64ccfc2839d2db2e4c9076f82a611baedf127b0b74f84ec8698a5adc25c43fb9245dcb26a221da7024372a61896b SHA512 1a7aa69e147b55c3c9761328604821a7e40bac4e7b82492e5ce1b2405e3b6d5154e3b06687f2446ec923b34bf6ea96eef179ef8410c005a061d448fc6b3e754e
diff --git a/dev-libs/totem-pl-parser/metadata.xml b/dev-libs/totem-pl-parser/metadata.xml
index 085e8b59297c..aac38cae424b 100644
--- a/dev-libs/totem-pl-parser/metadata.xml
+++ b/dev-libs/totem-pl-parser/metadata.xml
@@ -9,5 +9,6 @@
<flag name="archive">Enables ISO detection with <pkg>app-arch/libarchive</pkg></flag>
<flag name="crypt">Support AmazonAMZ decoding with <pkg>dev-libs/libgcrypt</pkg></flag>
<flag name="quvi">Use <pkg>media-libs/libquvi</pkg> for parsing video links</flag>
+ <flag name="uchardet">Enable charset discovery via <pkg>app-i18n/uchardet</pkg></flag>
</use>
</pkgmetadata>
diff --git a/dev-libs/totem-pl-parser/totem-pl-parser-3.26.6.ebuild b/dev-libs/totem-pl-parser/totem-pl-parser-3.26.6.ebuild
new file mode 100644
index 000000000000..8b68d7150cd0
--- /dev/null
+++ b/dev-libs/totem-pl-parser/totem-pl-parser-3.26.6.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit gnome.org meson xdg
+
+DESCRIPTION="Playlist parsing library"
+HOMEPAGE="https://developer.gnome.org/totem-pl-parser/stable/"
+
+LICENSE="LGPL-2+"
+SLOT="0/18"
+IUSE="archive crypt gtk-doc +introspection test +uchardet"
+RESTRICT="!test? ( test )"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+
+RDEPEND="
+ >=dev-libs/glib-2.56:2
+ archive? ( >=app-arch/libarchive-3:0= )
+ dev-libs/libxml2:2
+ crypt? ( dev-libs/libgcrypt:0= )
+ uchardet? ( app-i18n/uchardet )
+ introspection? ( >=dev-libs/gobject-introspection-1.54:= )
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ dev-util/glib-utils
+ gtk-doc? (
+ >=dev-util/gtk-doc-1.14
+ app-text/docbook-xml-dtd:4.3
+ )
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+ test? (
+ gnome-base/gvfs[http]
+ sys-apps/dbus
+ )
+"
+
+src_prepare() {
+ # Disable tests requiring network access, bug #346127
+ # 3rd test fails on upgrade, not once installed
+ # Leio: I consider network tests important for ensuring full functionality, thus trying with them again */
+ #sed -e 's:\(g_test_add_func.*/parser/resolution.*\):/*\1*/:' \
+ # -e 's:\(g_test_add_func.*/parser/parsing/itms_link.*\):/*\1*/:' \
+ # -e 's:\(g_test_add_func.*/parser/parsability.*\):/*\1*/:'\
+ # -i plparse/tests/parser.c || die "sed failed"
+
+ xdg_src_prepare
+}
+
+src_configure() {
+ # uninstalled-tests is abused to switch from loading live FS helper
+ # to in-build-tree helper, check on upgrades this is not having other
+ # consequences, bug #630242
+ local emesonargs=(
+ -Denable-libarchive=$(usex archive)
+ -Denable-libgcrypt=$(usex crypt)
+ -Denable-uchardet=$(usex uchardet)
+ $(meson_use gtk-doc enable-gtk-doc)
+ $(meson_use introspection)
+ )
+ meson_src_configure
+}
+
+src_test() {
+ # This is required as told by upstream in bgo#629542
+ GVFS_DISABLE_FUSE=1 dbus-run-session meson test -C "${BUILD_DIR}"
+}