summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-04-19 08:51:29 +0200
committerMichał Górny <mgorny@gentoo.org>2021-04-19 08:51:29 +0200
commitb4e464d80b4513abe3f1c4b3e90b11e711aa58a8 (patch)
tree42de28ecdc1783d93a2fd5b94a2067749b65f88c
parentdev-python/pytest-asyncio: Bump to 0.15.0 (diff)
downloadgentoo-b4e464d80b4513abe3f1c4b3e90b11e711aa58a8.tar.gz
gentoo-b4e464d80b4513abe3f1c4b3e90b11e711aa58a8.tar.bz2
gentoo-b4e464d80b4513abe3f1c4b3e90b11e711aa58a8.zip
dev-python/rope: Bump to 0.19.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/rope/Manifest1
-rw-r--r--dev-python/rope/rope-0.19.0.ebuild40
2 files changed, 41 insertions, 0 deletions
diff --git a/dev-python/rope/Manifest b/dev-python/rope/Manifest
index d974435341f9..5f56e4e67695 100644
--- a/dev-python/rope/Manifest
+++ b/dev-python/rope/Manifest
@@ -1 +1,2 @@
DIST rope-0.18.0.tar.gz 249828 BLAKE2B 2aac0541936c671f9b70528da28b2c016f14c7a3e5f368aecb6a3f2a39d2b447d70943bf00b7a49702f5d341504da7398ca5b1240d625275f749de1e530fb178 SHA512 9f706da345866447ff7e4027e6f9f0719d4b823253155881efcdd3a9e9a6f42fa9e194cd9547df4a6f752ae0cec739045e52bb7edd5cfa04ad4079fe06808298
+DIST rope-0.19.0.tar.gz 252902 BLAKE2B 41760dc29d26558bdf5f296238b7d59ca949530826953fe5592b763b8d24fb49a90a56b9c7d0e3475daf145185987116a7dd0cbfba74829abfa4bf6a57c79937 SHA512 fd41777d76861837479bf0777ea42cc052eed7ba396bc4531a0c7f101b05b1c5a57c300950b7a3c8a2902e28ff049d146646f83f8a8a447ab9ccd7cd8aa48110
diff --git a/dev-python/rope/rope-0.19.0.ebuild b/dev-python/rope/rope-0.19.0.ebuild
new file mode 100644
index 000000000000..dff0792c6594
--- /dev/null
+++ b/dev-python/rope/rope-0.19.0.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..9} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python refactoring library"
+HOMEPAGE="https://github.com/python-rope/rope"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc"
+
+# Dependency for docbuild documentation which is not noted in
+# setup.py, using standard docutils builds docs successfully.
+BDEPEND="doc? ( dev-python/docutils[${PYTHON_USEDEP}] )"
+
+distutils_enable_tests pytest
+
+python_compile_all() {
+ if use doc; then
+ pushd docs > /dev/null || die
+ mkdir build || die
+ local i
+ for i in ./*.rst; do
+ rst2html.py $i > ./build/${i/rst/html} || die
+ done
+ popd > /dev/null || die
+ fi
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/build/. )
+ distutils-r1_python_install_all
+}