summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2021-10-19 15:22:30 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2021-10-19 15:22:41 -0500
commitb4e4bbb89cdc7b81d38b84c6b925f2134748314c (patch)
treef0cc9827caf144395ac77890533384f2022835c0
parentdev-lua/luasec: unbundle luasocket usage (diff)
downloadgentoo-b4e4bbb89cdc7b81d38b84c6b925f2134748314c.tar.gz
gentoo-b4e4bbb89cdc7b81d38b84c6b925f2134748314c.tar.bz2
gentoo-b4e4bbb89cdc7b81d38b84c6b925f2134748314c.zip
dev-python/pychromecast: 9.3.1 bump
Closes: https://bugs.gentoo.org/818844 Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
-rw-r--r--dev-python/pychromecast/Manifest1
-rw-r--r--dev-python/pychromecast/pychromecast-9.3.1.ebuild21
2 files changed, 22 insertions, 0 deletions
diff --git a/dev-python/pychromecast/Manifest b/dev-python/pychromecast/Manifest
index b27eb658a113..bbc528da24c9 100644
--- a/dev-python/pychromecast/Manifest
+++ b/dev-python/pychromecast/Manifest
@@ -1 +1,2 @@
DIST PyChromecast-8.1.0.tar.gz 50867 BLAKE2B c5d3e07f1644d0a83ba25826e27ee62f36b80f594f6851714c2d17ab6e8bb9e982bfa72731715bba15b6b587967461bb5def3cc49569d43b5186ceebc4a360c0 SHA512 882ab5987a7ddbf61a177ff867986461bc21bb5560a7de1bafb3a873173981139897ca36336e5b21b0e013f0100d437d1077038f35676998d3eccf353d684f9b
+DIST PyChromecast-9.3.1.tar.gz 53253 BLAKE2B f246a38c79ececa17721ba2d8397da691310462ce9b19aab2ad525d82ff8c4db213fbc8fa3e9205bac3ffbde72f7bd75eab26c6b5430921bd2fb561a49808110 SHA512 ee4ad719a1142e1a4c67b99b6ceadfd076cb8b818474c5a5b9bc9dd2d03f13feddcece4983459013192f85bdc73339749d0b2f2c1881ac879d211dbe2e578605
diff --git a/dev-python/pychromecast/pychromecast-9.3.1.ebuild b/dev-python/pychromecast/pychromecast-9.3.1.ebuild
new file mode 100644
index 000000000000..da95c8815f5d
--- /dev/null
+++ b/dev-python/pychromecast/pychromecast-9.3.1.ebuild
@@ -0,0 +1,21 @@
+# Copyright 2020-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{7..9} )
+inherit distutils-r1
+
+DESCRIPTION="Python module to talk to Google Chromecast"
+HOMEPAGE="https://github.com/home-assistant-libs/pychromecast"
+S="${WORKDIR}/PyChromecast-${PV}"
+SRC_URI="mirror://pypi/P/PyChromecast/PyChromecast-${PV}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ >=dev-python/casttube-0.2.0[${PYTHON_USEDEP}]
+ >=dev-python/protobuf-python-3.0.0[${PYTHON_USEDEP}]
+ >=dev-python/zeroconf-0.25.1[${PYTHON_USEDEP}]"