summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConrad Kostecki <conikost@gentoo.org>2022-06-06 14:35:40 +0200
committerConrad Kostecki <conikost@gentoo.org>2022-06-06 14:37:15 +0200
commitb4e8a00419e73619b40a16662ad02b9a8f6c9f59 (patch)
tree2e759c32a417fde88f1da1eaef61ce14f986e673
parentmail-mta/postfix: drop 3.6.5-r2, 3.6.6, 3.7.1 (diff)
downloadgentoo-b4e8a004.tar.gz
gentoo-b4e8a004.tar.bz2
gentoo-b4e8a004.zip
sys-apps/onerng: add 3.7
Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
-rw-r--r--sys-apps/onerng/Manifest1
-rw-r--r--sys-apps/onerng/onerng-3.7.ebuild40
2 files changed, 41 insertions, 0 deletions
diff --git a/sys-apps/onerng/Manifest b/sys-apps/onerng/Manifest
index 44cc68c1624c..a4c9e6a26280 100644
--- a/sys-apps/onerng/Manifest
+++ b/sys-apps/onerng/Manifest
@@ -1 +1,2 @@
DIST onerng-3.6.tar.gz 108126 BLAKE2B 717fc2b795aa991fdca28e2032da0a7729c487cb684361799421f806f60ae4cb70e8d29cd72de2eec9bdf38e4bf1d530261fc19bfbee6e95360a7648b8a45858 SHA512 d2f2bceb458e1441c4321526e5477ecb26df9f84e8554df723b97c3f09ad4c04149ac844bb88a182abf5350566cd5762c35137ba3c6b71685671a69ba12ccc58
+DIST onerng-3.7.tar.gz 133016 BLAKE2B 8bae3f51baf3526e68070856d216de9e99064e8a728942fd4b926495ae34f3021ae3c99c8b5e4ea73dacdf8fa870cba67e1d3e94f5a3f0acddef0e48c02111e4 SHA512 6150787fc8415c7aaa13d6e98c3dc72e9160308eb912d97b7c9f59c6d4f5a9612917a7ff34084ba52a80e0aac6c65dd29653dd3bd211bd261fb89273f02be830
diff --git a/sys-apps/onerng/onerng-3.7.ebuild b/sys-apps/onerng/onerng-3.7.ebuild
new file mode 100644
index 000000000000..e8aa548f36d0
--- /dev/null
+++ b/sys-apps/onerng/onerng-3.7.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+MY_P="${P/-/_}"
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit python-single-r1 udev
+
+DESCRIPTION="Software for the Open Hardware Random Number Generator called OneRNG"
+HOMEPAGE="https://www.onerng.info/"
+SRC_URI="https://github.com/OneRNG/onerng.github.io/raw/master/sw/${MY_P}.orig.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${MY_P}"
+
+LICENSE="|| ( LGPL-2.1 LGPL-3 )"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+BDEPEND="virtual/pkgconfig"
+
+DEPEND="virtual/udev"
+
+RDEPEND="
+ ${DEPEND}
+ ${PYTHON_DEPS}
+ app-crypt/gnupg
+ $(python_gen_cond_dep 'dev-python/python-gnupg[${PYTHON_USEDEP}]')
+ sys-apps/rng-tools
+ sys-process/at
+"
+
+pkg_postinst() {
+ udev_reload
+}
+
+pkg_postrm() {
+ udev_reload
+}