summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthias Maier <tamiko@gentoo.org>2019-04-29 10:21:30 -0500
committerMatthias Maier <tamiko@gentoo.org>2019-04-29 10:22:22 -0500
commitb4eab1a0b8049fd0346e609d359a9eac1854469e (patch)
tree4491f3a4402a5419967940bcbf512a66d2329e59
parentapp-laptop/mbpfan: bump to 2.1.1 (diff)
downloadgentoo-b4eab1a0.tar.gz
gentoo-b4eab1a0.tar.bz2
gentoo-b4eab1a0.zip
app-emulation/qemu: do not strip QA_PREBUILT
Package-Manager: Portage-2.3.65, Repoman-2.3.12 Signed-off-by: Matthias Maier <tamiko@gentoo.org> Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
-rw-r--r--app-emulation/qemu/qemu-4.0.0.ebuild3
-rw-r--r--app-emulation/qemu/qemu-9999.ebuild3
2 files changed, 6 insertions, 0 deletions
diff --git a/app-emulation/qemu/qemu-4.0.0.ebuild b/app-emulation/qemu/qemu-4.0.0.ebuild
index dc29a0e79203..1880553a9742 100644
--- a/app-emulation/qemu/qemu-4.0.0.ebuild
+++ b/app-emulation/qemu/qemu-4.0.0.ebuild
@@ -696,6 +696,9 @@ src_install() {
dodoc Changelog MAINTAINERS docs/specs/pci-ids.txt
newdoc pc-bios/README README.pc-bios
+ # Disallow stripping of prebuilt firmware files.
+ dostrip -x ${QA_PREBUILT}
+
if [[ -n ${softmmu_targets} ]]; then
# Remove SeaBIOS since we're using the SeaBIOS packaged one
rm "${ED}/usr/share/qemu/bios.bin"
diff --git a/app-emulation/qemu/qemu-9999.ebuild b/app-emulation/qemu/qemu-9999.ebuild
index fb90986754bf..e765af785c68 100644
--- a/app-emulation/qemu/qemu-9999.ebuild
+++ b/app-emulation/qemu/qemu-9999.ebuild
@@ -695,6 +695,9 @@ src_install() {
dodoc Changelog MAINTAINERS docs/specs/pci-ids.txt
newdoc pc-bios/README README.pc-bios
+ # Disallow stripping of prebuilt firmware files.
+ dostrip -x ${QA_PREBUILT}
+
if [[ -n ${softmmu_targets} ]]; then
# Remove SeaBIOS since we're using the SeaBIOS packaged one
rm "${ED}/usr/share/qemu/bios.bin"