summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2022-11-03 13:20:32 -0400
committerMatt Turner <mattst88@gentoo.org>2022-11-03 13:22:56 -0400
commitb4fda02e9ad319a19467f60d9c40717999afe4ab (patch)
tree0836af0ca6bc6071fa06f4153aed5bcc6d939568
parentdev-libs/libgcrypt: destabilize 1.10.1-r3 (diff)
downloadgentoo-b4fda02e9ad319a19467f60d9c40717999afe4ab.tar.gz
gentoo-b4fda02e9ad319a19467f60d9c40717999afe4ab.tar.bz2
gentoo-b4fda02e9ad319a19467f60d9c40717999afe4ab.zip
x11-base/xwayland: Version bump to 22.1.5
Closes: https://bugs.gentoo.org/879235 Signed-off-by: Matt Turner <mattst88@gentoo.org>
-rw-r--r--x11-base/xwayland/Manifest1
-rw-r--r--x11-base/xwayland/xwayland-22.1.5.ebuild100
2 files changed, 101 insertions, 0 deletions
diff --git a/x11-base/xwayland/Manifest b/x11-base/xwayland/Manifest
index 933dbf228c2d..3c3ae0bcc003 100644
--- a/x11-base/xwayland/Manifest
+++ b/x11-base/xwayland/Manifest
@@ -1,2 +1,3 @@
DIST xwayland-22.1.3.tar.xz 1272440 BLAKE2B 5f35d6675ee90d910ed39921b4590e7a5325f941238c69b09d6b7063bcded992d1e4425327ae4626e8e9cead7dc17b4d892642a1a3bdb3a4de797f8f733202c4 SHA512 be15cb398f9a8aad70352d09b0745c827d4766d5996e817b92c828b5ede27b10186c7ee319901abdc5e141da97170a3ace039269146461d4e2ceb5002a7c35b4
DIST xwayland-22.1.4.tar.xz 1273552 BLAKE2B c492968f335ebd5b194d91729476047760b85620366fc587cace5f1cdef8cb22576293fb3799eedfe4a9c1eeff78dd18abaead67422caeb04b1ceb419509fbc6 SHA512 a1301df1687ac276172565c98b1fb3d5f35f67d47f625b81fce485d1818cf4896f88c2750b4e93596fa6f7fd515e258d201ca3d0cc39943b576f2d2c3f9be8cd
+DIST xwayland-22.1.5.tar.xz 1273444 BLAKE2B a6773f2b9655d0651a0a686f5e1fa41bdeaba998dc3e42c2c24dcc262d2affdb055c7ab0cf32b94ba11c82cbfe91bfcf10eb651f678feda95fccb55cc21d2e4f SHA512 806219692be297419777ad5343158f72473a691f7c8be4468fac185a3bc5e3b6811755de3133c12f3694480e51529ac3fa409b22640a80a233925716fec24c06
diff --git a/x11-base/xwayland/xwayland-22.1.5.ebuild b/x11-base/xwayland/xwayland-22.1.5.ebuild
new file mode 100644
index 000000000000..384312c2aa5c
--- /dev/null
+++ b/x11-base/xwayland/xwayland-22.1.5.ebuild
@@ -0,0 +1,100 @@
+# Copyright 2021-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit meson
+
+if [[ ${PV} == "9999" ]] ; then
+ EGIT_REPO_URI="https://gitlab.freedesktop.org/xorg/xserver.git"
+ inherit git-r3
+else
+ SRC_URI="https://xorg.freedesktop.org/archive/individual/xserver/${P}.tar.xz"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux"
+fi
+
+DESCRIPTION="Standalone X server running under Wayland"
+HOMEPAGE="https://wayland.freedesktop.org/xserver.html"
+
+IUSE="selinux video_cards_nvidia unwind xcsecurity"
+
+LICENSE="MIT"
+SLOT="0"
+
+COMMON_DEPEND="
+ dev-libs/libbsd
+ dev-libs/openssl:=
+ >=dev-libs/wayland-1.20
+ >=dev-libs/wayland-protocols-1.22
+ media-fonts/font-util
+ >=media-libs/libepoxy-1.5.4[X,egl(+)]
+ media-libs/libglvnd[X]
+ >=media-libs/mesa-21.1[X(+),egl(+),gbm(+)]
+ >=x11-libs/libdrm-2.4.89
+ >=x11-libs/libXau-1.0.4
+ x11-libs/libxcvt
+ >=x11-libs/libXdmcp-1.0.2
+ >=x11-libs/libXfont2-2.0.1
+ x11-libs/libxkbfile
+ >=x11-libs/libxshmfence-1.1
+ >=x11-libs/pixman-0.27.2
+ >=x11-misc/xkeyboard-config-2.4.1-r3
+
+ unwind? ( sys-libs/libunwind )
+ video_cards_nvidia? ( gui-libs/egl-wayland )
+"
+DEPEND="
+ ${COMMON_DEPEND}
+ x11-base/xorg-proto
+ >=x11-libs/xtrans-1.3.5
+"
+RDEPEND="
+ ${COMMON_DEPEND}
+ x11-apps/xkbcomp
+ !<=x11-base/xorg-server-1.20.11
+ selinux? ( sec-policy/selinux-xserver )
+"
+BDEPEND="
+ sys-devel/flex
+ dev-util/wayland-scanner
+"
+
+PATCHES=(
+ "${FILESDIR}"/xwayland-drop-redundantly-installed-files.patch
+)
+
+src_configure() {
+ local emesonargs=(
+ $(meson_use selinux xselinux)
+ $(meson_use unwind libunwind)
+ $(meson_use xcsecurity)
+ $(meson_use video_cards_nvidia xwayland_eglstream)
+ -Ddpms=true
+ -Ddri3=true
+ -Ddrm=true
+ -Ddtrace=false
+ -Dglamor=true
+ -Dglx=true
+ -Dipv6=true
+ -Dsecure-rpc=false
+ -Dscreensaver=true
+ -Dsha1=libcrypto
+ -Dxace=true
+ -Dxdmcp=true
+ -Dxinerama=true
+ -Dxvfb=true
+ -Dxv=true
+ -Dxwayland-path="${EPREFIX}"/usr/bin
+ -Ddocs=false
+ -Ddevel-docs=false
+ -Ddocs-pdf=false
+ )
+
+ meson_src_configure
+}
+
+src_install() {
+ dosym ../bin/Xwayland /usr/libexec/Xwayland
+
+ meson_src_install
+}