summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-08-01 03:58:18 +0100
committerSam James <sam@gentoo.org>2022-08-01 04:14:23 +0100
commitb54147860c8e9ee6eaca0e4ac6ee809c2c24a049 (patch)
tree49b3732e195c194581c9a5c83b9d7efdc908a6ee
parentmedia-libs/harfbuzz: add 5.1.0 (diff)
downloadgentoo-b5414786.tar.gz
gentoo-b5414786.tar.bz2
gentoo-b5414786.zip
app-text/html-xml-utils: [QA] EAPI 8, drop multilib, fix tests, fix deps
- EAPI 8 - Drop multilib-minimal (installs only binaries) - Clean up phase definitions (almost all not needed) - Fix tests (missing shebang and fail w/ non-bash, so force bash for them) - Fix dependencies (missing libidn2, although could use libidn, let's not add deps on legacy stuff). Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--app-text/html-xml-utils/html-xml-utils-7.8-r1.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/app-text/html-xml-utils/html-xml-utils-7.8-r1.ebuild b/app-text/html-xml-utils/html-xml-utils-7.8-r1.ebuild
new file mode 100644
index 000000000000..28ec0c74a63f
--- /dev/null
+++ b/app-text/html-xml-utils/html-xml-utils-7.8-r1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="A number of simple utilities for manipulating HTML and XML files"
+HOMEPAGE="https://www.w3.org/Tools/HTML-XML-utils/"
+SRC_URI="https://www.w3.org/Tools/HTML-XML-utils/${P}.tar.gz"
+
+LICENSE="W3C"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~x86-linux ~ppc-macos"
+
+RDEPEND="
+ net-dns/libidn2:=
+ net-misc/curl
+"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ default
+ sed -e "/doc_DATA = COPYING/d" -i Makefile.in || die
+}
+
+src_test() {
+ # Lots of tests lack a shebang and use bashisms
+ emake check SHELL="${BROOT}"/bin/bash
+}