summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2016-05-05 09:39:56 +0200
committerJeroen Roovers <jer@gentoo.org>2016-05-05 09:39:56 +0200
commitb5617c37000635a2aa330ae5c9f9ff3507532a0e (patch)
tree320cefe286866e8b7ef00a5c6dd550930385c40a
parentapp-arch/mt-st: Version bump. (diff)
downloadgentoo-b5617c37.tar.gz
gentoo-b5617c37.tar.bz2
gentoo-b5617c37.zip
net-misc/youtube-dl: Version bump.
Package-Manager: portage-2.2.28
-rw-r--r--net-misc/youtube-dl/Manifest1
-rw-r--r--net-misc/youtube-dl/youtube-dl-2016.05.01.ebuild96
2 files changed, 97 insertions, 0 deletions
diff --git a/net-misc/youtube-dl/Manifest b/net-misc/youtube-dl/Manifest
index bdd0f0ba375c..395722fbed7b 100644
--- a/net-misc/youtube-dl/Manifest
+++ b/net-misc/youtube-dl/Manifest
@@ -1,3 +1,4 @@
DIST youtube-dl-2016.01.01.tar.gz 1874602 SHA256 732f37c99d71b4239d72d61dd32214b5a5a618671fb0629c8f8deb28209a172c SHA512 fdb022bed426250e5ee1c2bcc1354dd195c0f9793ca479ca8ca4cfe2f71e07ba100b0dbcda2fb9f310308ab130587d06b16a6a86f9036f0d196b317d2e5b5e92 WHIRLPOOL 152e709ba15264c35a89644ea0d4793bb47c82b317e54043ccfff72e40bdf95e42d76605e801233632d3863537a945cfb9ecc2f75245171b8de31b51ce6af801
DIST youtube-dl-2016.04.19.tar.gz 2075147 SHA256 09ba62900703a1439659a5394d802c7b03fd3a7b35d604e94a256ae9ccd1b6a0 SHA512 96a5e8ed081355d6a4682355004b26c62385f89091a39ebaadd3cd4b655872db0e196dea44377e98d882d98581f6d5983aa3e7522d1292c4e57b86bcc252aa2b WHIRLPOOL ba8938c6fd34e4a7a32ccb16240ac1d48c2266cad46b2a79d02a2759c1a03d2bc2f2429e02674d6cf97fade60f44fdc9423d45c906eff9b64434977734ee081a
DIST youtube-dl-2016.04.24.tar.gz 2084276 SHA256 9ca83ae9cf783b3d9a231611ef5e446fa61fa77d0f4c9d0545895e6ce691321f SHA512 b30b01eb9100a30ce792283e1598f5f2058a56a90d1a1f0359efb79ca2d360dff4f525a3b906d777d4e09e046e3e21ed0342b29bf90c42be6321fc77a303ee42 WHIRLPOOL d875ece17393b7a413718bad1010ac6934f7f853a38d66af96b165399473f60280dfda7b1173b16fa8db7f7ba5816b9ee67e55438b8191d944b2dc28c5d5e506
+DIST youtube-dl-2016.05.01.tar.gz 2097882 SHA256 adc812e840f8f2461d6b7e72876c9219bfc8004e650a6ac7ddf216ccab5304f0 SHA512 c94c0bb222ca6e866646fef201b53cdf9a6d5a89921f34ef3d557822fe9398268251f9221ac2b5e11b7580d7b566b7795a7d8b7945672f3bc07ef8f11de18969 WHIRLPOOL 641dc9f582fed6ccc9a973e7cfab37540a0ea3483ef7ecc0f057ee9e2f08e1a57eaf2ee4030b2fc501ecf15da731cb7a58a7ecda75f2b999c9cb7cecb8ea8cd0
diff --git a/net-misc/youtube-dl/youtube-dl-2016.05.01.ebuild b/net-misc/youtube-dl/youtube-dl-2016.05.01.ebuild
new file mode 100644
index 000000000000..5bafd2029fe8
--- /dev/null
+++ b/net-misc/youtube-dl/youtube-dl-2016.05.01.ebuild
@@ -0,0 +1,96 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=(python{2_7,3_3,3_4,3_5})
+DISTUTILS_SINGLE_IMPL=true
+inherit bash-completion-r1 distutils-r1 eutils
+
+DESCRIPTION="Download videos from YouTube.com (and more sites...)"
+HOMEPAGE="https://rg3.github.com/youtube-dl/"
+SRC_URI="http://youtube-dl.org/downloads/${PV}/${P}.tar.gz"
+
+LICENSE="public-domain"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~hppa ~ppc ~ppc64 ~x86 ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x86-solaris"
+IUSE="offensive test"
+
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/nose[coverage(+)] )
+"
+
+S="${WORKDIR}/${PN}"
+
+src_prepare() {
+ if ! use offensive; then
+ sed -i -e "/__version__/s|'$|-gentoo_no_offensive_sites'|g" \
+ youtube_dl/version.py || die
+ # these have single line import statements
+ local xxx=(
+ alphaporno anysex behindkink camwithher chaturbate drtuber eporner
+ eroprofile extremetube fourtube foxgay goshgay hellporno
+ hentaistigma hornbunny keezmovies lovehomeporn mofosex motherless
+ myvidster porn91 pornhd pornotube pornovoisines pornoxo redtube
+ ruleporn sexu slutload spankbang spankwire sunporno thisav trutube
+ tube8 vporn watchindianporn xbef xnxx xtube xvideos xxxymovies
+ youjizz youporn
+ )
+ # these have multi-line import statements
+ local mxxx=(
+ pornhub xhamster tnaflix
+ )
+ # do single line imports
+ sed -i \
+ -e $( printf '/%s/d;' ${xxx[@]} ) \
+ youtube_dl/extractor/extractors.py \
+ || die
+
+ # do multiple line imports
+ sed -i \
+ -e $( printf '/%s/,/)/d;' ${mxxx[@]} ) \
+ youtube_dl/extractor/extractors.py \
+ || die
+
+ sed -i \
+ -e $( printf '/%s/d;' ${mxxx[@]} ) \
+ youtube_dl/extractor/generic.py \
+ || die
+
+ rm \
+ $( printf 'youtube_dl/extractor/%s.py ' ${xxx[@]} ) \
+ $( printf 'youtube_dl/extractor/%s.py ' ${mxxx[@]} ) \
+ test/test_age_restriction.py \
+ || die
+ fi
+
+ epatch_user
+}
+
+src_compile() {
+ distutils-r1_src_compile
+}
+
+src_test() {
+ emake test
+}
+
+src_install() {
+ python_domodule youtube_dl
+ dobin bin/${PN}
+
+ dodoc README.txt
+ doman ${PN}.1
+
+ newbashcomp ${PN}.bash-completion ${PN}
+
+ insinto /usr/share/zsh/site-functions
+ newins youtube-dl.zsh _youtube-dl
+
+ insinto /usr/share/fish/completions
+ doins youtube-dl.fish
+
+ python_fix_shebang "${ED}"
+}