summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBen Kohler <bkohler@gentoo.org>2021-01-21 12:34:39 -0600
committerBen Kohler <bkohler@gentoo.org>2021-01-21 12:35:18 -0600
commitb566d5a03d9d8827f29246c8d09b82af30e38f93 (patch)
tree2d9be8ff60f7d52dc0118a5b8f91a8a08f77e8fa
parentdev-lang/python: Restore prematurely removed eselect-python PDEP (diff)
downloadgentoo-b566d5a03d9d8827f29246c8d09b82af30e38f93.tar.gz
gentoo-b566d5a03d9d8827f29246c8d09b82af30e38f93.tar.bz2
gentoo-b566d5a03d9d8827f29246c8d09b82af30e38f93.zip
sys-apps/memtest86-bin: bump to 9.0_beta2
Package-Manager: Portage-3.0.14, Repoman-3.0.2 Signed-off-by: Ben Kohler <bkohler@gentoo.org>
-rw-r--r--sys-apps/memtest86-bin/Manifest1
-rw-r--r--sys-apps/memtest86-bin/memtest86-bin-9.0_beta2.ebuild37
2 files changed, 38 insertions, 0 deletions
diff --git a/sys-apps/memtest86-bin/Manifest b/sys-apps/memtest86-bin/Manifest
index dfc9bfb972ae..e8a2361a1625 100644
--- a/sys-apps/memtest86-bin/Manifest
+++ b/sys-apps/memtest86-bin/Manifest
@@ -1 +1,2 @@
DIST memtest86-bin-9.0_beta1.zip 9208162 BLAKE2B d21a2755b08a61c56e25f57a2e253ff6ab8f5e7aec9b291aa33daeb817ee9c6a5da7d40c5d2e97bfa39ba633567c9e601971767c1d6a6e6f699616b37b2149c4 SHA512 86c7962ad5abaf300f7a29cbcfc33bd20ad6d3b363d0c76a426682ec7ea2195e351c2fcace387e81e927aa30d2c66050ddc5415180401d17af3ef77d6a8b41a1
+DIST memtest86-bin-9.0_beta2.zip 10126202 BLAKE2B b6b7e2e5f6bba76fedc37244fd92b56be6fc3ed40efd42c55fc061c403a0e492f58f2ed719b2ff7b47596f41b3b6ccab1e13fbe885c168f59b51a783d7eb400f SHA512 f28cd912e98b2fa0a3a0f98a10b57627073e85acc24eb79a4e326ff5fe9c8401fa093a8007179365137cac2654de9a762f31373fa0b66850400c9884f925393f
diff --git a/sys-apps/memtest86-bin/memtest86-bin-9.0_beta2.ebuild b/sys-apps/memtest86-bin/memtest86-bin-9.0_beta2.ebuild
new file mode 100644
index 000000000000..c6682f17f678
--- /dev/null
+++ b/sys-apps/memtest86-bin/memtest86-bin-9.0_beta2.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit mount-boot
+
+MY_PV=${PV/_beta/-beta-}
+
+DESCRIPTION="Stand alone memory testing software for x86 computers"
+HOMEPAGE="http://www.memtest86.com/"
+SRC_URI="https://www.memtest86.com/downloads/memtest86-usb-${MY_PV}.zip -> ${P}.zip"
+
+LICENSE="PassMark-EULA"
+SLOT="0"
+KEYWORDS="-* ~amd64"
+IUSE=""
+
+BDEPEND="app-arch/unzip
+ sys-fs/fatcat"
+
+S=${WORKDIR}
+
+src_unpack() {
+ default
+ fatcat memtest86-usb.img -O 1048576 -r /EFI/BOOT/BOOTX64.efi > ${PN}.efi || die
+}
+
+src_install() {
+ insinto /boot
+ doins ${PN}.efi
+
+ exeinto /etc/grub.d/
+ newexe "${FILESDIR}"/${PN}-grub.d 39_memtest86-bin
+
+ dodoc MemTest86_User_Guide_UEFI.pdf
+}