summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRonny (tastytea) Gutbrod <gentoo@tastytea.de>2023-03-12 15:53:05 +0100
committerViorel Munteanu <ceamac@gentoo.org>2023-03-20 08:43:05 +0200
commitb58bfca12d8af0a0da3c86a22cb840e0750117f4 (patch)
tree8aa6a26077e2197adf7af2fa4ad93e6483e40e1e
parentwww-apps/hugo: add 0.111.3 (diff)
downloadgentoo-b58bfca1.tar.gz
gentoo-b58bfca1.tar.bz2
gentoo-b58bfca1.zip
www-apps/hugo: fix build flags
EGO_BUILD_FLAGS is only used in golang-build.eclass, not in go-module.eclass. Bug: https://github.com/gentoo/gentoo/pull/29807#issuecomment-1465214240 Signed-off-by: Ronny (tastytea) Gutbrod <gentoo@tastytea.de> Closes: https://github.com/gentoo/gentoo/pull/30047 Signed-off-by: Viorel Munteanu <ceamac@gentoo.org>
-rw-r--r--www-apps/hugo/hugo-0.110.0-r2.ebuild (renamed from www-apps/hugo/hugo-0.110.0-r1.ebuild)6
-rw-r--r--www-apps/hugo/hugo-0.111.3.ebuild6
2 files changed, 6 insertions, 6 deletions
diff --git a/www-apps/hugo/hugo-0.110.0-r1.ebuild b/www-apps/hugo/hugo-0.110.0-r2.ebuild
index 2844ad2eecb8..68c6effbbe55 100644
--- a/www-apps/hugo/hugo-0.110.0-r1.ebuild
+++ b/www-apps/hugo/hugo-0.110.0-r2.ebuild
@@ -48,7 +48,7 @@ src_configure() {
export CGO_CPPFLAGS="${CPPFLAGS}"
export CGO_CXXFLAGS="${CXXFLAGS}"
export CGO_LDFLAGS="${LDFLAGS}"
- export EGO_BUILD_FLAGS="$(usev sass "-tags extended")"
+ export MY_BUILD_FLAGS="$(usev sass "-tags extended")"
default
}
@@ -56,7 +56,7 @@ src_configure() {
src_compile() {
mkdir -pv bin || die
ego build -ldflags "-X github.com/gohugoio/hugo/common/hugo.vendorInfo=gentoo:${PVR}" \
- -o "${S}/bin/hugo"
+ ${MY_BUILD_FLAGS} -o "${S}/bin/hugo"
bin/hugo gen man --dir man || die
@@ -71,7 +71,7 @@ src_compile() {
}
src_test() {
- ego test "./..."
+ ego test "./..." ${MY_BUILD_FLAGS}
}
src_install() {
diff --git a/www-apps/hugo/hugo-0.111.3.ebuild b/www-apps/hugo/hugo-0.111.3.ebuild
index ebf86fa34f56..7eb297bafecd 100644
--- a/www-apps/hugo/hugo-0.111.3.ebuild
+++ b/www-apps/hugo/hugo-0.111.3.ebuild
@@ -48,7 +48,7 @@ src_configure() {
export CGO_CPPFLAGS="${CPPFLAGS}"
export CGO_CXXFLAGS="${CXXFLAGS}"
export CGO_LDFLAGS="${LDFLAGS}"
- export EGO_BUILD_FLAGS="$(usev sass "-tags extended")"
+ export MY_BUILD_FLAGS="$(usev sass "-tags extended")"
default
}
@@ -56,7 +56,7 @@ src_configure() {
src_compile() {
mkdir -pv bin || die
ego build -ldflags "-X github.com/gohugoio/hugo/common/hugo.vendorInfo=gentoo:${PVR}" \
- -o "${S}/bin/hugo"
+ ${MY_BUILD_FLAGS} -o "${S}/bin/hugo"
bin/hugo gen man --dir man || die
@@ -71,7 +71,7 @@ src_compile() {
}
src_test() {
- ego test "./..."
+ ego test "./..." ${MY_BUILD_FLAGS}
}
src_install() {