summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJaco Kroon <jaco@uls.co.za>2022-01-20 11:14:12 +0200
committerSam James <sam@gentoo.org>2022-01-20 12:37:09 +0000
commitb5b0a869b6d98b25d8494c48a9e21db4398dc4a3 (patch)
tree9bb623551f584e763837d266828ba3b41e13a8df
parentwww-servers/uwsgi: add additional Python 3.10 patch (diff)
downloadgentoo-b5b0a869.tar.gz
gentoo-b5b0a869.tar.bz2
gentoo-b5b0a869.zip
net-voip/captagent: revision bump to fix clang compile
Upstream: https://github.com/sipcapture/captagent/pull/245 Not expecting a new release soon. Closes: https://bugs.gentoo.org/831391 Package-Manager: Portage-3.0.28, Repoman-3.0.3 Signed-off-by: Jaco Kroon <jaco@uls.co.za> Closes: https://github.com/gentoo/gentoo/pull/23880 Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--net-voip/captagent/captagent-6.3.1-r1.ebuild (renamed from net-voip/captagent/captagent-6.3.1.ebuild)6
-rw-r--r--net-voip/captagent/files/captagent-6.3.1-r1-clang.patch63
2 files changed, 67 insertions, 2 deletions
diff --git a/net-voip/captagent/captagent-6.3.1.ebuild b/net-voip/captagent/captagent-6.3.1-r1.ebuild
index 7addb19c0e0d..3023031778b2 100644
--- a/net-voip/captagent/captagent-6.3.1.ebuild
+++ b/net-voip/captagent/captagent-6.3.1-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -15,8 +15,10 @@ KEYWORDS="~amd64 ~x86"
IUSE="ipv6 mysql pcre redis ssl"
PATCHES=(
- # https://github.com/sipcapture/captagent/pull/239 (should be accepted).
+ # https://github.com/sipcapture/captagent/pull/239 (merged).
"${FILESDIR}/${P}-gcc10.patch"
+ # https://github.com/sipcapture/captagent/pull/245 (merged).
+ "${FILESDIR}/${P}-captagent-6.3.1-r1-clang.patch"
# Already upstreamed for next version.
"${FILESDIR}/${P}-configure.patch"
)
diff --git a/net-voip/captagent/files/captagent-6.3.1-r1-clang.patch b/net-voip/captagent/files/captagent-6.3.1-r1-clang.patch
new file mode 100644
index 000000000000..02940147d30f
--- /dev/null
+++ b/net-voip/captagent/files/captagent-6.3.1-r1-clang.patch
@@ -0,0 +1,63 @@
+From a4b5cc7806861b75b03ea0d31e1413e3e293770c Mon Sep 17 00:00:00 2001
+From: Jaco Kroon <jaco@uls.co.za>
+Date: Thu, 20 Jan 2022 07:07:40 +0200
+Subject: [PATCH] Move declaration of usage() function to avoid conflicting
+ implicit declaration.
+
+Signed-off-by: Jaco Kroon <jaco@uls.co.za>
+---
+ src/captagent.c | 31 +++++++++++++++----------------
+ 1 file changed, 15 insertions(+), 16 deletions(-)
+
+diff --git a/src/captagent.c b/src/captagent.c
+index 6f5f533..052b0bb 100644
+--- a/src/captagent.c
++++ b/src/captagent.c
+@@ -108,6 +108,21 @@ void handler(int value) {
+ exit(0);
+ }
+
++void usage(int8_t e)
++{
++ printf(
++ "usage: Captagent <-vh> <-f config>\n"
++ " -h display help/usage\n"
++ " -a print a list of all availlable devices\n"
++ " -v display version information\n"
++ " -c validate configuration and exit\n"
++ " -d enable daemon mode\n"
++ " -n enable foreground mode\n"
++ " -f [/path/to/rtpagent.xml] to specify a config file\n"
++ " -D [/path/to/file.pcap] to specify a pcap file as input\n"
++ " -x [1 - 10] set debug level\n");
++ exit(e);
++}
+
+ // Print the list of availlable devices
+ static void print_all_devices()
+@@ -230,22 +245,6 @@ int daemonize(int nofork)
+ error: return -1;
+ }
+
+-void usage(int8_t e)
+-{
+- printf(
+- "usage: Captagent <-vh> <-f config>\n"
+- " -h display help/usage\n"
+- " -a print a list of all availlable devices\n"
+- " -v display version information\n"
+- " -c validate configuration and exit\n"
+- " -d enable daemon mode\n"
+- " -n enable foreground mode\n"
+- " -f [/path/to/rtpagent.xml] to specify a config file\n"
+- " -D [/path/to/file.pcap] to specify a pcap file as input\n"
+- " -x [1 - 10] set debug level\n");
+- exit(e);
+-}
+-
+ void print_hw() {
+
+ char k[33];
+--
+2.33.1
+