summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCraig Andrews <candrews@gentoo.org>2020-09-15 00:05:51 -0400
committerCraig Andrews <candrews@gentoo.org>2020-09-15 00:06:21 -0400
commitb5b243505349276133affb82ebf37ac3e0f5c2e8 (patch)
treef097a3e5eb9d6574f085e2323ab34e5369e9836f
parentsys-apps/restorecond: Version bump to 3.1. (diff)
downloadgentoo-b5b243505349276133affb82ebf37ac3e0f5c2e8.tar.gz
gentoo-b5b243505349276133affb82ebf37ac3e0f5c2e8.tar.bz2
gentoo-b5b243505349276133affb82ebf37ac3e0f5c2e8.zip
net-analyzer/netdata: 1.25.0 version bump
Package-Manager: Portage-3.0.7, Repoman-3.0.1 Signed-off-by: Craig Andrews <candrews@gentoo.org>
-rw-r--r--net-analyzer/netdata/Manifest1
-rw-r--r--net-analyzer/netdata/netdata-1.25.0.ebuild141
2 files changed, 142 insertions, 0 deletions
diff --git a/net-analyzer/netdata/Manifest b/net-analyzer/netdata/Manifest
index 6e0d6fa46c13..cf89fd34ad5c 100644
--- a/net-analyzer/netdata/Manifest
+++ b/net-analyzer/netdata/Manifest
@@ -1,2 +1,3 @@
DIST netdata-1.23.2.tar.gz 3839012 BLAKE2B f0c225307b61a0a3b5d581e6d5e4a90d5f26ad0aae49e32dfd3dc36405e48d2e8f7a088c31a2a19059418f88e362eb9840b6c020f5459a0d0388f10b7c729eb0 SHA512 4a4dc647e0326da4f785444e15e2f74af09428374bfe2db57c44dd2765ce77b2babbd8b52e33e04f49b95937a6ca8691ffa18b51d1717ea927025b70fa7e369f
DIST netdata-1.24.0.tar.gz 3876403 BLAKE2B 36a2413039f89d4a9f4c60a6ebe319b5e818b9a0f57e722cd7e29293452faebf264cf961530a03c9a8ffa27fe9f12caf5c54d1e58741641a1be76e936a0e3222 SHA512 18276605f74520b3d55b8a67bfbee7cb2483d472becbcab7e2b1af19f08b05ffd2a83e6e8eec98733abde8ba1f552eec919e8ae59266cbec7c2c94beb4a2aeb4
+DIST netdata-1.25.0.tar.gz 3891805 BLAKE2B 42e6f1d2a20bce352fa5bbac162ff906a150069d3dd7e4c83f7315a6962f4e33f6a5a65e500b4763ad6f0778d71e93226604c6b0bee2f8fdcdfc9f36f07f7033 SHA512 d92249a2fab28ae26132708bc79af591f8050fef2e82b331d3756c84e21072bfd6f6b1158d8ca912a500ed7fd65e4e3005828b28180befa88d2984dde8bd816b
diff --git a/net-analyzer/netdata/netdata-1.25.0.ebuild b/net-analyzer/netdata/netdata-1.25.0.ebuild
new file mode 100644
index 000000000000..48231022d056
--- /dev/null
+++ b/net-analyzer/netdata/netdata-1.25.0.ebuild
@@ -0,0 +1,141 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python{3_6,3_7,3_8,3_9} )
+
+inherit autotools fcaps linux-info python-single-r1 systemd
+
+if [[ ${PV} == *9999 ]] ; then
+ EGIT_REPO_URI="https://github.com/netdata/${PN}.git"
+ inherit git-r3
+else
+ SRC_URI="https://github.com/netdata/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+DESCRIPTION="Linux real time system monitoring, done right!"
+HOMEPAGE="https://github.com/netdata/netdata https://my-netdata.io/"
+
+LICENSE="GPL-3+ MIT BSD"
+SLOT="0"
+IUSE="caps +compression cpu_flags_x86_sse2 cups +dbengine ipmi +jsonc kinesis mongodb mysql nfacct nodejs postgres prometheus +python tor xen"
+REQUIRED_USE="
+ mysql? ( python )
+ python? ( ${PYTHON_REQUIRED_USE} )
+ tor? ( python )"
+
+# most unconditional dependencies are for plugins.d/charts.d.plugin:
+RDEPEND="
+ acct-group/netdata
+ acct-user/netdata
+ app-misc/jq
+ >=app-shells/bash-4:0
+ || (
+ net-analyzer/openbsd-netcat
+ net-analyzer/netcat
+ )
+ net-misc/curl
+ net-misc/wget
+ sys-apps/util-linux
+ virtual/awk
+ caps? ( sys-libs/libcap )
+ cups? ( net-print/cups )
+ dbengine? (
+ app-arch/lz4
+ dev-libs/judy
+ dev-libs/openssl:=
+ )
+ dev-libs/libuv
+ compression? ( sys-libs/zlib )
+ ipmi? ( sys-libs/freeipmi )
+ jsonc? ( dev-libs/json-c:= )
+ kinesis? ( dev-libs/aws-sdk-cpp[kinesis] )
+ mongodb? ( dev-libs/mongo-c-driver )
+ nfacct? (
+ net-firewall/nfacct
+ net-libs/libmnl
+ )
+ nodejs? ( net-libs/nodejs )
+ prometheus? (
+ dev-libs/protobuf:=
+ app-arch/snappy
+ )
+ python? (
+ ${PYTHON_DEPS}
+ $(python_gen_cond_dep 'dev-python/pyyaml[${PYTHON_MULTI_USEDEP}]')
+ mysql? (
+ || (
+ $(python_gen_cond_dep 'dev-python/mysqlclient[${PYTHON_MULTI_USEDEP}]')
+ $(python_gen_cond_dep 'dev-python/mysql-python[${PYTHON_MULTI_USEDEP}]')
+ )
+ )
+ postgres? ( $(python_gen_cond_dep 'dev-python/psycopg:2[${PYTHON_MULTI_USEDEP}]') )
+ tor? ( $(python_gen_cond_dep 'net-libs/stem[${PYTHON_MULTI_USEDEP}]') )
+ )
+ xen? (
+ app-emulation/xen-tools
+ dev-libs/yajl
+ )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+FILECAPS=(
+ 'cap_dac_read_search,cap_sys_ptrace+ep' 'usr/libexec/netdata/plugins.d/apps.plugin'
+)
+
+pkg_setup() {
+ use python && python-single-r1_pkg_setup
+ linux-info_pkg_setup
+}
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ # --disable-cloud: https://github.com/netdata/netdata/issues/8961
+ econf \
+ --localstatedir="${EPREFIX}"/var \
+ --with-user=netdata \
+ --disable-cloud \
+ $(use_enable jsonc) \
+ $(use_enable cups plugin-cups) \
+ $(use_enable dbengine) \
+ $(use_enable nfacct plugin-nfacct) \
+ $(use_enable ipmi plugin-freeipmi) \
+ $(use_enable kinesis backend-kinesis) \
+ $(use_enable mongodb backend-mongodb) \
+ $(use_enable prometheus backend-prometheus-remote-write) \
+ $(use_enable xen plugin-xenstat) \
+ $(use_enable cpu_flags_x86_sse2 x86-sse) \
+ $(use_with compression zlib)
+}
+
+src_install() {
+ default
+
+ rm -rf "${D}/var/cache" || die
+
+ keepdir /var/log/netdata
+ fowners -Rc netdata:netdata /var/log/netdata
+ keepdir /var/lib/netdata
+ keepdir /var/lib/netdata/registry
+ fowners -Rc netdata:netdata /var/lib/netdata
+
+ fowners -Rc root:netdata /usr/share/${PN}
+
+ newinitd system/netdata-openrc ${PN}
+ systemd_dounit system/netdata.service
+ insinto /etc/netdata
+ doins system/netdata.conf
+}
+
+pkg_postinst() {
+ fcaps_pkg_postinst
+
+ if use xen ; then
+ fcaps 'cap_dac_override' 'usr/libexec/netdata/plugins.d/xenstat.plugin'
+ fi
+}