summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrahmajit Das <brahmajit.xyz@gmail.com>2023-10-17 23:27:59 +0530
committerPacho Ramos <pacho@gentoo.org>2023-10-20 15:14:37 +0200
commitb5b534144b816d2724ee5e0d764538710db5e20a (patch)
tree6f7637d9537d95b61394983f01f13dce3c496b2c
parentsci-chemistry/gromacs: Fix compilation with gcc-13 (diff)
downloadgentoo-b5b53414.tar.gz
gentoo-b5b53414.tar.bz2
gentoo-b5b53414.zip
sys-power/upower: add 1.90.2
Signed-off-by: Brahmajit Das <brahmajit.xyz@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/33342 Signed-off-by: Pacho Ramos <pacho@gentoo.org>
-rw-r--r--sys-power/upower/Manifest1
-rw-r--r--sys-power/upower/upower-1.90.2.ebuild116
2 files changed, 117 insertions, 0 deletions
diff --git a/sys-power/upower/Manifest b/sys-power/upower/Manifest
index 1f9e6dd964b8..d17cda19358b 100644
--- a/sys-power/upower/Manifest
+++ b/sys-power/upower/Manifest
@@ -1 +1,2 @@
DIST upower-v0.99.20.tar.bz2 126098 BLAKE2B 670a2ad746c5cf8b2aca332f1f8c36fc96cd82b3ad8a7a5337dd3edce60cd73b1a83e807ec3f257d5216b3b4873f1bcf6cc9c434c195f75680e891c653f44fe1 SHA512 50e5b03f1319da3869b0caba4fbe78c8eabf1df6f783f1463b06394bee58bae42ad411780faa503965c5fdb983d723c0b5ae0731fae4220997a17875f4850b1e
+DIST upower-v1.90.2.tar.bz2 138265 BLAKE2B f00b3a584f5564a0edc7fadad2e005da5938e61005c0c84ed6bfb9e612a5964a1f4b0a051a2a78eb1b71666e4182ce2e01e16f1b32269ed2db848b570f71fd09 SHA512 9cdaea76d604e79bb385c2d7d8df26ab74d8fbbd5ddd271d7dc3323ae4f98ce9504ce807638e008869fdec0e1fcaf8d4be53e486714913616b8df73d8e4ac396
diff --git a/sys-power/upower/upower-1.90.2.ebuild b/sys-power/upower/upower-1.90.2.ebuild
new file mode 100644
index 000000000000..04bbbd818ccb
--- /dev/null
+++ b/sys-power/upower/upower-1.90.2.ebuild
@@ -0,0 +1,116 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{9..11} )
+inherit meson python-any-r1 systemd udev xdg-utils
+
+DESCRIPTION="D-Bus abstraction for enumerating power devices, querying history and statistics"
+HOMEPAGE="https://upower.freedesktop.org/"
+SRC_URI="https://gitlab.freedesktop.org/${PN}/${PN}/-/archive/v${PV}/${PN}-v${PV}.tar.bz2"
+S="${WORKDIR}/${PN}-v${PV}"
+
+LICENSE="GPL-2+"
+SLOT="0/3" # based on SONAME of libupower-glib.so
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~loong ~mips ~ppc ~ppc64 ~riscv ~sparc ~x86"
+
+# gtk-doc files are not available as prebuilt in the tarball
+IUSE="doc +introspection ios selinux test"
+RESTRICT="!test? ( test )"
+
+DEPEND="
+ >=dev-libs/glib-2.58:2
+ sys-apps/dbus:=
+ introspection? ( dev-libs/gobject-introspection:= )
+ kernel_linux? (
+ >=dev-libs/libgudev-236:=
+ virtual/udev
+ ios? (
+ >=app-pda/libimobiledevice-1:=
+ >=app-pda/libplist-2:=
+ )
+ )
+"
+RDEPEND="${DEPEND}
+ selinux? ( sec-policy/selinux-devicekit )
+"
+BDEPEND="
+ app-text/docbook-xsl-stylesheets
+ dev-libs/libxslt
+ dev-util/gdbus-codegen
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+ doc? ( dev-util/gtk-doc )
+ test? (
+ $(python_gen_any_dep '
+ dev-python/dbus-python[${PYTHON_USEDEP}]
+ dev-python/python-dbusmock[${PYTHON_USEDEP}]
+ ')
+ dev-util/umockdev
+ )
+"
+
+QA_MULTILIB_PATHS="usr/lib/${PN}/.*"
+
+python_check_deps() {
+ python_has_version -b "dev-python/dbus-python[${PYTHON_USEDEP}]" &&
+ python_has_version -b "dev-python/python-dbusmock[${PYTHON_USEDEP}]"
+}
+
+pkg_setup() {
+ use test && python-any-r1_pkg_setup
+}
+
+src_prepare() {
+ default
+ xdg_environment_reset
+}
+
+src_configure() {
+ local backend
+
+ if use kernel_linux ; then
+ backend=linux
+ else
+ backend=dummy
+ fi
+
+ local emesonargs=(
+ --localstatedir "${EPREFIX}"/var
+
+ -Dman=true
+ $(meson_use doc gtk-doc)
+ $(meson_feature introspection)
+ -Dudevrulesdir="${EPREFIX}$(get_udevdir)/rules.d"
+ -Dsystemdsystemunitdir="$(systemd_get_systemunitdir)"
+ -Dos_backend="${backend}"
+ $(meson_feature ios idevice)
+ )
+ meson_src_configure
+}
+
+src_install() {
+ meson_src_install
+ keepdir /var/lib/upower #383091
+}
+
+pkg_postinst() {
+ udev_reload
+
+ if [[ ${REPLACING_VERSIONS} ]] && ver_test ${REPLACING_VERSIONS} -lt 0.99.12; then
+ elog "Support for Logitech Unifying Receiver battery state readout was"
+ elog "removed in version 0.99.12, these devices have been directly"
+ elog "supported by the Linux kernel since version >=3.2."
+ elog
+ elog "Support for CSR devices battery state was removed from udev rules"
+ elog "in version 0.99.12. This concerns the following Logitech products"
+ elog "from the mid 2000s:"
+ elog "Mouse/Dual/Keyboard+Mouse Receiver, Freedom Optical, Elite Duo,"
+ elog "MX700/MX1000, Optical TrackMan, Click! Mouse, Presenter."
+ fi
+}
+
+pkg_postrm() {
+ udev_reload
+}