summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBen Kohler <bkohler@gentoo.org>2019-10-01 17:13:48 -0500
committerBen Kohler <bkohler@gentoo.org>2019-10-01 17:14:47 -0500
commitb5b7254c3b19bdf4f8d5e514c98c7d36b2cfdbe9 (patch)
treec80e86300650da09ec047014813b36fcf450a2b3
parentmedia-libs/gmmlib: bump to 19.2.4 (diff)
downloadgentoo-b5b7254c.tar.gz
gentoo-b5b7254c.tar.bz2
gentoo-b5b7254c.zip
net-misc/dropbox: add new dropbox@ service
Closes: https://bugs.gentoo.org/618580 Package-Manager: Portage-2.3.76, Repoman-2.3.17 Signed-off-by: Ben Kohler <bkohler@gentoo.org>
-rw-r--r--net-misc/dropbox/dropbox-81.4.195.ebuild4
-rw-r--r--net-misc/dropbox/files/dropbox_at.service-r237
2 files changed, 39 insertions, 2 deletions
diff --git a/net-misc/dropbox/dropbox-81.4.195.ebuild b/net-misc/dropbox/dropbox-81.4.195.ebuild
index 48e763d95e01..c21396bd015d 100644
--- a/net-misc/dropbox/dropbox-81.4.195.ebuild
+++ b/net-misc/dropbox/dropbox-81.4.195.ebuild
@@ -11,7 +11,7 @@ SRC_URI="
x86? ( https://clientupdates.dropboxstatic.com/dbx-releng/client/dropbox-lnx.x86-${PV}.tar.gz )
amd64? ( https://clientupdates.dropboxstatic.com/dbx-releng/client/dropbox-lnx.x86_64-${PV}.tar.gz )"
-LICENSE="CC-BY-ND-3.0 FTL MIT LGPL-2 openssl dropbox"
+LICENSE="BSD-2 CC-BY-ND-3.0 FTL MIT LGPL-2 openssl dropbox"
SLOT="0"
KEYWORDS="~amd64 ~x86 ~x86-linux"
IUSE="+librsync-bundled selinux X"
@@ -98,7 +98,7 @@ src_install() {
newinitd "${FILESDIR}"/dropbox.initd dropbox
newconfd "${FILESDIR}"/dropbox.conf dropbox
- systemd_newunit "${FILESDIR}"/dropbox_at.service-r1 "dropbox@.service"
+ systemd_newunit "${FILESDIR}"/dropbox_at.service-r2 "dropbox@.service"
dodoc "${T}"/{README,ACKNOWLEDGEMENTS}
}
diff --git a/net-misc/dropbox/files/dropbox_at.service-r2 b/net-misc/dropbox/files/dropbox_at.service-r2
new file mode 100644
index 000000000000..a21362f3ca78
--- /dev/null
+++ b/net-misc/dropbox/files/dropbox_at.service-r2
@@ -0,0 +1,37 @@
+# Copyright (c) 2015, Joe Roback
+# All rights reserved.
+#
+# Redistribution and use in source and binary forms, with or without
+# modification, are permitted provided that the following conditions are met:
+#
+# * Redistributions of source code must retain the above copyright notice, this
+# list of conditions and the following disclaimer.
+#
+# * Redistributions in binary form must reproduce the above copyright notice,
+# this list of conditions and the following disclaimer in the documentation
+# and/or other materials provided with the distribution.
+#
+# THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS "AS IS"
+# AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE
+# IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE
+# DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT HOLDER OR CONTRIBUTORS BE LIABLE
+# FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL
+# DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR
+# SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER
+# CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY,
+# OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE
+# OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+[Unit]
+Description=Dropbox as a system service
+After=local-fs.target network.target
+
+[Service]
+Type=simple
+ExecStart=/usr/bin/env "/home/%i/.dropbox-dist/dropboxd"
+Restart=on-failure
+RestartSec=1
+User=%i
+
+[Install]
+WantedBy=multi-user.target