summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLuca Barbato <lu_zero@gentoo.org>2018-12-12 15:02:09 +0000
committerLuca Barbato <lu_zero@gentoo.org>2018-12-12 15:02:28 +0000
commitb5cd649e07a13c158ff097cc631a96042a0581fc (patch)
tree4ca22e219c6b5a1d21bcdbf347c755075f22317a
parentsci-physics/lammps: version bump (diff)
downloadgentoo-b5cd649e07a13c158ff097cc631a96042a0581fc.tar.gz
gentoo-b5cd649e07a13c158ff097cc631a96042a0581fc.tar.bz2
gentoo-b5cd649e07a13c158ff097cc631a96042a0581fc.zip
media-libs/dav1d: First release
Update the useflag description and add the new ebuild. Package-Manager: Portage-2.3.52, Repoman-2.3.12 Signed-off-by: Luca Barbato <lu_zero@gentoo.org>
-rw-r--r--media-libs/dav1d/Manifest1
-rw-r--r--media-libs/dav1d/dav1d-0.1.0.ebuild58
-rw-r--r--media-libs/dav1d/dav1d-9999.ebuild4
-rw-r--r--media-libs/dav1d/metadata.xml4
4 files changed, 63 insertions, 4 deletions
diff --git a/media-libs/dav1d/Manifest b/media-libs/dav1d/Manifest
new file mode 100644
index 000000000000..766c5b355cc5
--- /dev/null
+++ b/media-libs/dav1d/Manifest
@@ -0,0 +1 @@
+DIST dav1d-0.1.0.tar.bz2 351745 BLAKE2B 302680ddfdc8d5a3eff90541ed156e820c3322bfb93316da1b2deabeac40062103af19e99dfa810678e62ad668c4aed944ac9bf8160afb301b100063919ed2a1 SHA512 5893ad40af7c4f5c3678ecc604ad360b5d1cd3fadaa16f7183d638745097fed091aeb3456540db61a2f4f0fc8bb93f2a20f428c76a7976d3fd186cc8b8baed53
diff --git a/media-libs/dav1d/dav1d-0.1.0.ebuild b/media-libs/dav1d/dav1d-0.1.0.ebuild
new file mode 100644
index 000000000000..8b2a1f361334
--- /dev/null
+++ b/media-libs/dav1d/dav1d-0.1.0.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+SCM=""
+if [[ "${PV}" == "9999" ]]; then
+ SCM="git-r3"
+ EGIT_REPO_URI="https://code.videolan.org/videolan/dav1d"
+else
+ KEYWORDS="~amd64"
+ SRC_URI="https://code.videolan.org/videolan/dav1d/-/archive/${PV}/${P}.tar.bz2"
+fi
+
+inherit ${SCM} meson ninja-utils multilib-minimal
+
+DESCRIPTION="dav1d is an AV1 Decoder :)"
+HOMEPAGE="https://code.videolan.org/videolan/dav1d"
+
+LICENSE="BSD-2"
+SLOT="0"
+IUSE="+8bit +10bit +asm"
+
+ASM_DEPEND=">=dev-lang/nasm-2.13"
+RDEPEND=""
+DEPEND="${RDEPEND}
+ asm? (
+ abi_x86_32? ( ${ASM_DEPEND} )
+ abi_x86_64? ( ${ASM_DEPEND} )
+ )"
+
+DOCS=( README.md doc/PATENTS )
+
+multilib_src_configure() {
+ local -a bits=()
+ use 8bit && bits+=( 8 )
+ use 10bit && bits+=( 16 )
+
+ if [[ ${MULTILIB_ABI_FLAG} == abi_x86_x32 ]]; then
+ build_asm=false
+ else
+ build_asm=$(usex asm true false)
+ fi
+
+ local emesonargs=(
+ -D bitdepths=$(IFS=,; echo "${bits[*]}")
+ -D build_asm=$build_asm
+ )
+ meson_src_configure
+}
+
+multilib_src_compile() {
+ eninja
+}
+
+multilib_src_install() {
+ DESTDIR="${D}" eninja install
+}
diff --git a/media-libs/dav1d/dav1d-9999.ebuild b/media-libs/dav1d/dav1d-9999.ebuild
index c5eab1165a34..8b2a1f361334 100644
--- a/media-libs/dav1d/dav1d-9999.ebuild
+++ b/media-libs/dav1d/dav1d-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -34,7 +34,7 @@ DOCS=( README.md doc/PATENTS )
multilib_src_configure() {
local -a bits=()
use 8bit && bits+=( 8 )
- use 10bit && bits+=( 10 )
+ use 10bit && bits+=( 16 )
if [[ ${MULTILIB_ABI_FLAG} == abi_x86_x32 ]]; then
build_asm=false
diff --git a/media-libs/dav1d/metadata.xml b/media-libs/dav1d/metadata.xml
index 96b9f2cd5594..112a2f9c98f1 100644
--- a/media-libs/dav1d/metadata.xml
+++ b/media-libs/dav1d/metadata.xml
@@ -6,8 +6,8 @@
</maintainer>
<use>
<flag name="8bit">Add support for decoding 8-bit AV1.</flag>
- <flag name="10bit">Add support for building 10-bit AV1.</flag>
- <flag name="asm">Enable custom x86 assembly for faster decoding.</flag>
+ <flag name="10bit">Add support for building 10-bit and 12-bit AV1.</flag>
+ <flag name="asm">Enable custom assembly for faster decoding.</flag>
</use>
<upstream>
<bugs-to>https://code.videolan.org/videolan/dav1d/issues</bugs-to>