summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2022-03-24 10:46:25 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2022-03-24 10:47:20 -0500
commitb5cf91dd6a1cd23cb7be4272a28629c1d8972ecb (patch)
tree789f1d5fe22bc4db8114c1009139d61c130ad72c
parentsys-apps/attr: Add BDEPEND on binutils (diff)
downloadgentoo-b5cf91dd6a1cd23cb7be4272a28629c1d8972ecb.tar.gz
gentoo-b5cf91dd6a1cd23cb7be4272a28629c1d8972ecb.tar.bz2
gentoo-b5cf91dd6a1cd23cb7be4272a28629c1d8972ecb.zip
www-apps/icingaweb2: 2.10.0 bump
Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
-rw-r--r--www-apps/icingaweb2/Manifest1
-rw-r--r--www-apps/icingaweb2/icingaweb2-2.10.0.ebuild81
2 files changed, 82 insertions, 0 deletions
diff --git a/www-apps/icingaweb2/Manifest b/www-apps/icingaweb2/Manifest
index 5e05a3512b06..6ddfc6950ec3 100644
--- a/www-apps/icingaweb2/Manifest
+++ b/www-apps/icingaweb2/Manifest
@@ -1 +1,2 @@
+DIST icingaweb2-2.10.0.tar.gz 11491028 BLAKE2B bee48e59ec7d0a564e7056986a84fda9639e61ed82ea65d35da310916e7058837fc146ee06f2c044748f72424198dc42f75b32de4b6ab39f673e2a9bbaf46966 SHA512 e26a4382970ece503c18ac9f93bb9e7ac24fd827dd84fd04352aeeff796ab58dac747840c6153cea5711d548603f219ba32aeffe76d87359ea72f2d3a598468b
DIST icingaweb2-2.9.6.tar.gz 12313930 BLAKE2B 696b882fc1bb0fd0452dca9e8b13b336181d953c05ab43c1db38073aa817496ca431dfb0f68adab0a6eae7c2238878dda98a57d8b69b2bc19ed94f1afbd26fe5 SHA512 507ce9ab8e31f0afc19de173c56e9ce2986c9c2e945ff3516e005b49a69993ccb00ec53d4c53bc0beee865cebc533b4b91b0d7707abf9d30d4cb76b7545fb6a4
diff --git a/www-apps/icingaweb2/icingaweb2-2.10.0.ebuild b/www-apps/icingaweb2/icingaweb2-2.10.0.ebuild
new file mode 100644
index 000000000000..1c12f98d4b39
--- /dev/null
+++ b/www-apps/icingaweb2/icingaweb2-2.10.0.ebuild
@@ -0,0 +1,81 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit depend.apache multilib
+
+DESCRIPTION="Icinga Web 2 - Frontend for icinga2"
+HOMEPAGE="http://www.icinga.org/"
+
+if [[ ${PV} == *9999 ]];then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/Icinga/icingaweb2.git"
+ EGIT_BRANCH="master"
+else
+ SRC_URI="https://codeload.github.com/Icinga/${PN}/tar.gz/v${PV} -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="apache2 apache2-server fpm ldap mysql nginx pdf postgres"
+REQUIRED_USE="( ^^ ( apache2-server nginx ) ) apache2? ( apache2-server )"
+
+DEPEND=">=net-analyzer/icinga2-2.1.1
+ dev-php/pecl-imagick
+ pdf? ( media-gfx/imagemagick[png] )
+ apache2-server? ( >=www-servers/apache-2.4.0 )
+ nginx? ( >=www-servers/nginx-1.7.0:* )
+ || (
+ dev-lang/php:7.3[apache2?,cli,fpm?,gd,json,intl,ldap?,mysql?,nls,pdo,postgres?,sockets,ssl,xslt,xml]
+ dev-lang/php:7.4[apache2?,cli,fpm?,gd,json,intl,ldap?,mysql?,nls,pdo,postgres?,sockets,ssl,xslt,xml]
+ dev-lang/php:8.0[apache2?,cli,fpm?,gd,intl,ldap?,mysql?,nls,pdo,postgres?,sockets,ssl,xslt,xml]
+ )
+ dev-libs/icinga-php-library
+ dev-libs/icinga-php-thirdparty
+ acct-group/icingacmd
+ acct-group/icingaweb2"
+RDEPEND="${DEPEND}"
+
+want_apache2
+
+pkg_setup() {
+ depend.apache_pkg_setup
+
+ use nginx && usermod -a -G icingacmd,icingaweb2 nginx
+ use apache2 && usermod -a -G icingacmd,icingaweb2 apache
+}
+
+pkg_config() {
+ if [[ -d /etc/icingaweb2 ]] ; then
+ einfo "Updating existing installation ..."
+ else
+ einfo "Running first time setup ..."
+ einfo "Creating configuration directory ..."
+ /usr/share/${PN}/bin/icingacli setup config directory
+ einfo "Creating authentication token for web setup ..."
+ /usr/share/${PN}/bin/icingacli setup token create
+ if use apache2 ; then
+ einfo "The following might be useful for your Apache2 configuration:"
+ /usr/share/${PN}/bin/icingacli setup config webserver apache --document-root /usr/share/${PN}/public
+ fi
+ if use nginx ; then
+ einfo "The following might be useful for your NGinx configuration:"
+ /usr/share/${PN}/bin/icingacli setup config webserver nginx --document-root /usr/share/${PN}/public
+ fi
+ fi
+ einfo "All done."
+}
+
+src_install() {
+ insinto "/usr/share/${PN}"
+ doins -r "${S}"/*
+ fperms -R a+rX "/usr/share/${PN}/public/"
+ fperms u+x,g+x "/usr/share/${PN}/bin/icingacli"
+ fowners root:icingaweb2 "/usr/share/${PN}/bin/icingacli"
+}
+
+pkg_postinst() {
+ einfo "Run 'emerge --config =${CATEGORY}/${PF}' to finish setup."
+}