summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConrad Kostecki <conrad@kostecki.com>2018-07-14 21:57:28 +0200
committerMart Raudsepp <leio@gentoo.org>2018-07-15 00:01:01 +0300
commitb5d8b1a54d4376eb945bf203764a4a00690ab923 (patch)
tree01de8bb521549307b5369e0c6091d5f828ac8563
parentapp-forensics/chkrootkit: stable 0.52 for ppc, bug #660906 (diff)
downloadgentoo-b5d8b1a5.tar.gz
gentoo-b5d8b1a5.tar.bz2
gentoo-b5d8b1a5.zip
app-i18n/poedit: bump to version 2.0.9
Closes: https://bugs.gentoo.org/661172 Package-Manager: Portage-2.3.42, Repoman-2.3.9
-rw-r--r--app-i18n/poedit/Manifest1
-rw-r--r--app-i18n/poedit/metadata.xml7
-rw-r--r--app-i18n/poedit/poedit-2.0.9.ebuild62
3 files changed, 69 insertions, 1 deletions
diff --git a/app-i18n/poedit/Manifest b/app-i18n/poedit/Manifest
index 90c4b3e1128a..8d90dba88ef7 100644
--- a/app-i18n/poedit/Manifest
+++ b/app-i18n/poedit/Manifest
@@ -1,2 +1,3 @@
DIST poedit-2.0.6.tar.gz 2511777 BLAKE2B f28e8940310e80ee15fc70f10492e061097f88b62938f8a85194170fd107100c739dbfd1c1cf12516e6fe3d2a9b282986a4368615cf8fcb2ac889075fe64cc6b SHA512 e7beceeb4cd9e4e0269666d634e48622f175a7788219288ba6349a5b15f8360a929018480372e3eecb664d7d2e3093d6788640651696323d6dda0f0780aa5cd2
DIST poedit-2.0.7.tar.gz 2558220 BLAKE2B e4a958e516a5c4b56331b6f9f37d9fa627072a4a161f17b9e809df86af7ab86130c704b9f41d081a86dbc2dc3b24acf62615e843b73f78874c42730bd46f9b55 SHA512 7b8b41b5f55252b1845c452edbdad56dc841c507c4fb7a24267bd2af8490610f5f3eb72f31ed4d062fdaef939ef4ecd9c30ddc85a5dad3a792ac5857567dac71
+DIST poedit-2.0.9.tar.gz 2567156 BLAKE2B 29e616256a19430cb3efd3db5d6c2cc450155009e30ee056f6be712bac9e631e5aa20b0758262e9fbe00937eedf6ac777cd8e7407a3060f04503e3fa4d9cd6d0 SHA512 9981339ae0c3f11f972ed2f25e0c96e5c0cc0210771cc44d163e219c32eb951fa4180c8a03acdd7f0232a5e4b535f3202dda703b57ccfb02773eb24e6a1eb02d
diff --git a/app-i18n/poedit/metadata.xml b/app-i18n/poedit/metadata.xml
index ce23bed0e6f5..59291cd93ece 100644
--- a/app-i18n/poedit/metadata.xml
+++ b/app-i18n/poedit/metadata.xml
@@ -5,8 +5,13 @@
<email>wxwidgets@gentoo.org</email>
<name>Gentoo wxWidgets Project</name>
</maintainer>
+ <longdescription>
+ This program is a GUI frontend to the GNU gettext utilities
+ and a catalogs editor/source code parser.
+ It helps with translating applications into another language.
+ </longdescription>
<upstream>
+ <bugs-to>https://github.com/vslavik/poedit/issues</bugs-to>
<remote-id type="github">vslavik/poedit</remote-id>
- <remote-id type="sourceforge">poedit</remote-id>
</upstream>
</pkgmetadata>
diff --git a/app-i18n/poedit/poedit-2.0.9.ebuild b/app-i18n/poedit/poedit-2.0.9.ebuild
new file mode 100644
index 000000000000..f985ecb9e16c
--- /dev/null
+++ b/app-i18n/poedit/poedit-2.0.9.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PLOCALES="an ar az be be@latin bg bs ca ckb co cs da de el en_GB es et eu fa fi fr ga gl he hr hu hy id is it ja ka kab kk ko lt lv ms nb nl oc pa pl pt_BR pt_PT ro ru sk sl sq sr sv tg th tr uk uz vi zh_CN zh_TW"
+WX_GTK_VER=3.0-gtk3
+
+inherit gnome2-utils l10n wxwidgets xdg
+
+DESCRIPTION="GUI gettext translations editor"
+HOMEPAGE="https://poedit.net"
+SRC_URI="https://github.com/vslavik/${PN}/releases/download/v${PV}-oss/${P}.tar.gz"
+
+KEYWORDS="~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
+LICENSE="MIT"
+SLOT="0"
+
+RDEPEND="
+ app-text/gtkspell:3
+ x11-libs/gtk+:3
+ >=dev-cpp/lucene++-3.0.5
+ dev-libs/boost:=[nls]
+ dev-libs/icu:=
+ >=x11-libs/wxGTK-3.0.3:${WX_GTK_VER}[X]
+"
+
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+src_prepare() {
+ my_rm_loc() {
+ sed -i -e "/^POEDIT_LINGUAS = /s: ${1}::" locales/Makefile.in || die
+ rm "locales/${1}.mo" || die
+ }
+
+ l10n_find_plocales_changes 'locales' '' '.mo'
+ l10n_for_each_disabled_locale_do my_rm_loc
+
+ setup-wxwidgets
+ xdg_src_prepare
+}
+
+src_configure() {
+ # CLD2 and C++ Rest are not available in Gentoo
+ local myeconfargs=(
+ --without-cld2
+ --without-cpprest
+ )
+
+ econf "${myeconfargs[@]}"
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+ gnome2_icon_cache_update
+}