summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-01-31 11:54:51 +0100
committerMichał Górny <mgorny@gentoo.org>2023-01-31 12:22:18 +0100
commitb5e7f47bbd8bc89a3144023460db1ffc17aeec32 (patch)
tree349ed821b2a936e9d2a0d29f64407a603894139a
parentdev-python/jupyter_client: Bump to 8.0.2 (diff)
downloadgentoo-b5e7f47b.tar.gz
gentoo-b5e7f47b.tar.bz2
gentoo-b5e7f47b.zip
dev-python/jupyter_core: Bump to 5.2.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/jupyter_core/Manifest1
-rw-r--r--dev-python/jupyter_core/jupyter_core-5.2.0.ebuild39
2 files changed, 40 insertions, 0 deletions
diff --git a/dev-python/jupyter_core/Manifest b/dev-python/jupyter_core/Manifest
index fcccf392414d..619dad8e0866 100644
--- a/dev-python/jupyter_core/Manifest
+++ b/dev-python/jupyter_core/Manifest
@@ -3,3 +3,4 @@ DIST jupyter_core-5.1.2.tar.gz 82374 BLAKE2B aace9207d31c896017cf132f15da705118e
DIST jupyter_core-5.1.3.tar.gz 82657 BLAKE2B d57f97bb698bc8caccce5dd5509f9288db418335bc24283e55200505b4cca04d420f00747e04429b4256b40f722ae8b21441455a5ee8509c3e2ea4f96edbb658 SHA512 49afdb2361eee88f19abd59d1e201d2234591041dd07d42f36c3a4eed039ed2d42bb39a1789be4d0ed03f02183b6ff598338cac85fdc17dad1dfc4c75e44f380
DIST jupyter_core-5.1.4.tar.gz 82756 BLAKE2B 0d2653d4642ed9e83a1a52b1eb8c486cbaccf1e3f92b434895275320e710944704802b49a5ec1ed2bac4535b8db44ea6b987c381da842479aa5df3906800cd3a SHA512 a520dccdf6da56a9d7c001fd22566aa60c82451a08357ac2aa5098cfcbecad52f6b7166c22fcc61df314302758718dcf9db785a48001af42f130328e642bee9c
DIST jupyter_core-5.1.5.tar.gz 82838 BLAKE2B 33e9f569bfcf66e679611b00fd99f272b845685d7132f616141143ab0b894b54cb499c6da2112ccd760a00e5313c742830943e77ac6b40277db371b6002b6220 SHA512 2fc9150de96e7a084aa9bf334a71e342f0ab1946943e25a66a4760097fa662290a732ac30356c8ddb595fc05414edb1d9c06ac5eaf41099aaccb695d6a9357a6
+DIST jupyter_core-5.2.0.tar.gz 83861 BLAKE2B 97a96201199640963e9ebedf1b8ecffb66d6153e40a77cbe1d615ad9a5b60d3c7deb5c5965bdf7f8001db4967af30f39e576570160229201cc9a5b585c37abcf SHA512 7e4e6bbc338876fd213ae1a8028066f1f33010bb0196e26d6c6d7b872b60612d38d9d32b3d2ee4155f86dabf3b89e8282fef268d1dcd6fd740fd2fd3f0bd0bc2
diff --git a/dev-python/jupyter_core/jupyter_core-5.2.0.ebuild b/dev-python/jupyter_core/jupyter_core-5.2.0.ebuild
new file mode 100644
index 000000000000..632659336271
--- /dev/null
+++ b/dev-python/jupyter_core/jupyter_core-5.2.0.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Core common functionality of Jupyter projects"
+HOMEPAGE="
+ https://jupyter.org/
+ https://github.com/jupyter/jupyter_core/
+ https://pypi.org/project/jupyter-core/
+"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ >=dev-python/platformdirs-2.5[${PYTHON_USEDEP}]
+ >=dev-python/traitlets-5.3[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ >=dev-python/ipython-4.0.1[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_sphinx docs \
+ dev-python/myst_parser \
+ dev-python/sphinx-autodoc-typehints \
+ dev-python/sphinxcontrib-github-alt \
+ dev-python/sphinxcontrib-spelling \
+ dev-python/traitlets
+distutils_enable_tests pytest