summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2021-02-02 06:47:56 +0100
committerHans de Graaff <graaff@gentoo.org>2021-02-02 06:47:56 +0100
commitb5e8d42ac7e3acd62123b543f636904874192319 (patch)
tree56ef5761a7910266fd36658c8707d7cdfe011917
parentdev-ruby/rake: fix gemspec generation (diff)
downloadgentoo-b5e8d42a.tar.gz
gentoo-b5e8d42a.tar.bz2
gentoo-b5e8d42a.zip
dev-ruby/net-http-digest_auth: EAPI=7; add ruby30
Package-Manager: Portage-3.0.13, Repoman-3.0.2 Signed-off-by: Hans de Graaff <graaff@gentoo.org>
-rw-r--r--dev-ruby/net-http-digest_auth/net-http-digest_auth-1.4.1-r1.ebuild24
-rw-r--r--dev-ruby/net-http-digest_auth/net-http-digest_auth-1.4.1.ebuild2
2 files changed, 25 insertions, 1 deletions
diff --git a/dev-ruby/net-http-digest_auth/net-http-digest_auth-1.4.1-r1.ebuild b/dev-ruby/net-http-digest_auth/net-http-digest_auth-1.4.1-r1.ebuild
new file mode 100644
index 000000000000..52b2b62e979e
--- /dev/null
+++ b/dev-ruby/net-http-digest_auth/net-http-digest_auth-1.4.1-r1.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+USE_RUBY="ruby25 ruby26 ruby27 ruby30"
+
+RUBY_FAKEGEM_EXTRADOC="History.txt README.txt"
+
+inherit ruby-fakegem
+
+DESCRIPTION="An implementation of RFC 2617 - Digest Access Authentication"
+HOMEPAGE="https://github.com/drbrain/net-http-digest_auth"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-solaris"
+IUSE="test"
+
+ruby_add_bdepend "test? ( dev-ruby/minitest )"
+
+each_ruby_test() {
+ ${RUBY} -Ilib:. -e 'Dir["test/test_*.rb"].each{|f| require f}' || die
+}
diff --git a/dev-ruby/net-http-digest_auth/net-http-digest_auth-1.4.1.ebuild b/dev-ruby/net-http-digest_auth/net-http-digest_auth-1.4.1.ebuild
index fa7c2dd90474..a8b4de7219e5 100644
--- a/dev-ruby/net-http-digest_auth/net-http-digest_auth-1.4.1.ebuild
+++ b/dev-ruby/net-http-digest_auth/net-http-digest_auth-1.4.1.ebuild
@@ -3,7 +3,7 @@
EAPI=5
-USE_RUBY="ruby24 ruby25 ruby26 ruby27"
+USE_RUBY="ruby25 ruby26 ruby27"
RUBY_FAKEGEM_RECIPE_DOC="rdoc"
RUBY_FAKEGEM_DOCDIR="doc"