summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-05-28 00:57:08 +0200
committerMichał Górny <mgorny@gentoo.org>2021-05-28 01:18:36 +0200
commitb5ff0178e406ba4ad47e46a6c1fd63f1b5f39655 (patch)
tree421affc04c17b86ccf9460baaa935aead1c6ff0f
parentdev-python/cliff: Bump to 3.8.0 (diff)
downloadgentoo-b5ff0178.tar.gz
gentoo-b5ff0178.tar.bz2
gentoo-b5ff0178.zip
dev-python/fakeredis: Bump to 1.5.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/fakeredis/Manifest1
-rw-r--r--dev-python/fakeredis/fakeredis-1.5.1.ebuild44
2 files changed, 45 insertions, 0 deletions
diff --git a/dev-python/fakeredis/Manifest b/dev-python/fakeredis/Manifest
index b360bc563ea5..aee3e9d2605a 100644
--- a/dev-python/fakeredis/Manifest
+++ b/dev-python/fakeredis/Manifest
@@ -1 +1,2 @@
DIST fakeredis-1.5.0.gh.tar.gz 66371 BLAKE2B da9a961b9e163ba8221193c9c353f17bd23a710bd105b4fc6b9249a857828ece0b3551e3890818b0519f96aa9691166658332c25b796b22827f0951d3f50cebf SHA512 5bd4965c36abada4b937b635318d58e88ba76d30ff577b0f9b9134a94a3407a8c0e92d953e6b5299cabfe11ebe5a785e9d75406e8a07a4257674be64f6b8cffb
+DIST fakeredis-1.5.1.gh.tar.gz 67064 BLAKE2B 6eac029b7de6fb2c9b56a60655b6a224cdcba25fa86662a0423044ab97248984c4c6cfbaacbe4bbb2e3fc6826693791f232c6c55d7f15995d0e5bd00370a9ba8 SHA512 74a238573f9f911e9a39885b52d8c908d51d5620e346b8927c161111ce193566c315999f71d3edb1cb1326970985fd73d533b5483afe0c98ad76798a3c15e242
diff --git a/dev-python/fakeredis/fakeredis-1.5.1.ebuild b/dev-python/fakeredis/fakeredis-1.5.1.ebuild
new file mode 100644
index 000000000000..7c66ea7651cb
--- /dev/null
+++ b/dev-python/fakeredis/fakeredis-1.5.1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 2020-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( pypy3 python3_{7..9} )
+inherit distutils-r1
+
+DESCRIPTION="Fake implementation of redis API for testing purposes"
+HOMEPAGE="
+ https://github.com/jamesls/fakeredis/
+ https://pypi.org/project/fakeredis/"
+SRC_URI="
+ https://github.com/jamesls/fakeredis/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~sparc ~x86"
+
+RDEPEND="
+ dev-python/redis-py[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+ dev-python/sortedcontainers[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/hypothesis[${PYTHON_USEDEP}]
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local excludes=(
+ # tests for use with aioredis, not packaged in ::gentoo
+ --ignore test/test_aioredis.py
+ # tests requiring lupa (lua support)
+ -k 'not test_eval and not test_lua and not test_script'
+ )
+
+ epytest "${excludes[@]}"
+}