summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAisha Tammy <gentoo@aisha.cc>2020-12-25 11:02:33 -0500
committerJoonas Niilola <juippis@gentoo.org>2021-01-18 11:27:38 +0200
commitb610f9aca781f439c9fafcbd7c6eb4714dd137ed (patch)
treef2f8b94c4a072b047efe675d61814629e03bd32d
parentnet-mail/poppassd_ceti: add missing test dep (diff)
downloadgentoo-b610f9aca781f439c9fafcbd7c6eb4714dd137ed.tar.gz
gentoo-b610f9aca781f439c9fafcbd7c6eb4714dd137ed.tar.bz2
gentoo-b610f9aca781f439c9fafcbd7c6eb4714dd137ed.zip
gui-apps/wayland-logout: version bump to 1.1
Package-Manager: Portage-3.0.12, Repoman-3.0.2 Signed-off-by: Aisha Tammy <gentoo@aisha.cc> Signed-off-by: Joonas Niilola <juippis@gentoo.org>
-rw-r--r--gui-apps/wayland-logout/Manifest1
-rw-r--r--gui-apps/wayland-logout/wayland-logout-1.1.ebuild26
-rw-r--r--gui-apps/wayland-logout/wayland-logout-9999.ebuild4
3 files changed, 29 insertions, 2 deletions
diff --git a/gui-apps/wayland-logout/Manifest b/gui-apps/wayland-logout/Manifest
index abc4336a7b56..d76802ec8537 100644
--- a/gui-apps/wayland-logout/Manifest
+++ b/gui-apps/wayland-logout/Manifest
@@ -1 +1,2 @@
DIST wayland-logout-1.0.tar.gz 16663 BLAKE2B 7f8932342cd584f9e8c6abcaf83b2a5ff7ff14eda00f6d47a402206cff5786a9f4d5fbd75b8704fd0c39fad9550e47dbd499ac4a9b233f63ee6ed80b544d4556 SHA512 2c31fe11d4e6de53c7e873e7d235c4dcfbcb1425f4d7d2969b623574dd0bea77ee1fd482949b09cd86a1755ed48f2a8b39e4b2db6adedaf6d465144e9ef71652
+DIST wayland-logout-1.1.tar.gz 17731 BLAKE2B 179fba23ff885746e6664022a1e427e0a29f59e92b29fdf84807729253d5e3f7d2cea31bd2108f2daeb1bf87fdfceb2ce93fdab4dd3e7a914baeff0102880c84 SHA512 3664c865044e81d7fc41b5888ea1a8669804642b05a518e418c222c90867d38ada4c7f6c5193a251f43498dc9e1a70d4bdf79034569b5add12007523aa011e03
diff --git a/gui-apps/wayland-logout/wayland-logout-1.1.ebuild b/gui-apps/wayland-logout/wayland-logout-1.1.ebuild
new file mode 100644
index 000000000000..19849dc6704e
--- /dev/null
+++ b/gui-apps/wayland-logout/wayland-logout-1.1.ebuild
@@ -0,0 +1,26 @@
+# Copyright 2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="general logout scripts for wayland compositors"
+
+HOMEPAGE="https://github.com/soreau/wayland-logout"
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/soreau/wayland-logout"
+else
+ SRC_URI="https://github.com/soreau/wayland-logout/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm64 ~x86"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+
+RDEPEND="sys-process/lsof"
+
+src_install() {
+ newbin wayland-logout.sh wayland-logout
+ doman wayland-logout.1
+}
diff --git a/gui-apps/wayland-logout/wayland-logout-9999.ebuild b/gui-apps/wayland-logout/wayland-logout-9999.ebuild
index edb385b32abf..19849dc6704e 100644
--- a/gui-apps/wayland-logout/wayland-logout-9999.ebuild
+++ b/gui-apps/wayland-logout/wayland-logout-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 2020 Gentoo Authors
+# Copyright 2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -22,5 +22,5 @@ RDEPEND="sys-process/lsof"
src_install() {
newbin wayland-logout.sh wayland-logout
- dosym wayland-logout /usr/bin/wlogout
+ doman wayland-logout.1
}