summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFabrice Delliaux <netbox253@gmail.com>2023-01-08 16:49:57 +0100
committerStephan Hartmann <sultan@gentoo.org>2023-01-19 19:49:46 +0100
commitb63872552463bee7d9d061c4d1cd0e0f62331fad (patch)
treee02509665431ee8712e7c7e7ed0939308a75ffd1
parentwww-client/opera: remove old (diff)
downloadgentoo-b63872552463bee7d9d061c4d1cd0e0f62331fad.tar.gz
gentoo-b63872552463bee7d9d061c4d1cd0e0f62331fad.tar.bz2
gentoo-b63872552463bee7d9d061c4d1cd0e0f62331fad.zip
dev-libs/hidapi: 0.12.0-r1 with some fixs
1. remove virtual/pkgconfig from BDEPEND (used by deprecated autotools build system) 2. swap DEPEND and RDEPEND 3. fix doxygen documentation generation : With USE="doc" enabled you'll get these warnings at compile phase : > warning: tag INPUT: input source '../hidapi' does not exist > warning: source '../hidapi' is not a readable file or directory... skipping. > warning: No files to be processed, please check your settings, in particular > INPUT, FILE_PATTERNS, and RECURSIVE > Doxygen version used: 1.9.5 Signed-off-by: Fabrice Delliaux <netbox253@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/29020 Signed-off-by: Stephan Hartmann <sultan@gentoo.org>
-rw-r--r--dev-libs/hidapi/hidapi-0.12.0-r1.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/dev-libs/hidapi/hidapi-0.12.0-r1.ebuild b/dev-libs/hidapi/hidapi-0.12.0-r1.ebuild
new file mode 100644
index 000000000000..6f2ed465adcc
--- /dev/null
+++ b/dev-libs/hidapi/hidapi-0.12.0-r1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake-multilib
+
+DESCRIPTION="A multi-platform library for USB and Bluetooth HID-Class devices"
+HOMEPAGE="https://github.com/libusb/hidapi"
+SRC_URI="https://github.com/libusb/hidapi/archive/${P}.tar.gz -> ${P}.tgz"
+
+LICENSE="|| ( BSD GPL-3 HIDAPI )"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc ~ppc64 ~riscv ~x86"
+IUSE="doc"
+
+DEPEND="
+ virtual/libusb:1[${MULTILIB_USEDEP}]
+ virtual/libudev:0[${MULTILIB_USEDEP}]"
+RDEPEND="${DEPEND}"
+BDEPEND="
+ doc? ( app-doc/doxygen )"
+
+S="${WORKDIR}/${PN}-${P}"
+
+multilib_src_compile() {
+ cmake_src_compile
+
+ if use doc && multilib_is_native_abi; then
+ cd "${S}/doxygen"
+ doxygen Doxyfile || die
+ fi
+}
+
+multilib_src_install() {
+ cmake_src_install
+
+ if use doc && multilib_is_native_abi; then
+ local HTML_DOCS=( "${S}/doxygen/html/." )
+ fi
+ einstalldocs
+}