summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAaron W. Swenson <titanofold@gentoo.org>2021-07-06 20:38:38 -0400
committerAaron W. Swenson <titanofold@gentoo.org>2021-07-06 20:38:38 -0400
commitb642f661af8b1c7f35d6f6b36a28af173fc7c51f (patch)
treec84752bfa7264f964cc1d9d83132af08a825a77e
parentdev-util/catalyst: Keyword 3.0.20 s390, #795318 (diff)
downloadgentoo-b642f661.tar.gz
gentoo-b642f661.tar.bz2
gentoo-b642f661.zip
dev-db/postgresql: Fix environment reset in pkg_config
Without resetting the environment the config phase results in the following non-fatal error message being produced: could not change directory to "/var/tmp/portage/dev-db/postgresql-13.1/homedir": Permission denied Package-Manager: Portage-3.0.9, Repoman-3.0.2 Signed-off-by: Martin Kletzander <nert.pinx@gmail.com> Closes: https://bugs.gentoo.org/796344 Closes: https://github.com/gentoo/gentoo/pull/18332 Signed-off-by: Aaron W. Swenson <titanofold@gentoo.org>
-rw-r--r--dev-db/postgresql/postgresql-10.17.ebuild2
-rw-r--r--dev-db/postgresql/postgresql-11.12.ebuild2
-rw-r--r--dev-db/postgresql/postgresql-12.7.ebuild2
-rw-r--r--dev-db/postgresql/postgresql-13.3.ebuild2
-rw-r--r--dev-db/postgresql/postgresql-14_beta2.ebuild2
-rw-r--r--dev-db/postgresql/postgresql-9.6.22.ebuild2
-rw-r--r--dev-db/postgresql/postgresql-9999.ebuild2
7 files changed, 7 insertions, 7 deletions
diff --git a/dev-db/postgresql/postgresql-10.17.ebuild b/dev-db/postgresql/postgresql-10.17.ebuild
index 866e2d6f6987..7723abe23530 100644
--- a/dev-db/postgresql/postgresql-10.17.ebuild
+++ b/dev-db/postgresql/postgresql-10.17.ebuild
@@ -391,7 +391,7 @@ pkg_config() {
einfo "Initializing the database ..."
if [[ ${EUID} == 0 ]] ; then
- su postgres -c "${EROOT}/usr/$(get_libdir)/postgresql-${SLOT}/bin/initdb -D \"${DATA_DIR}\" ${PG_INITDB_OPTS}"
+ su - postgres -c "${EROOT}/usr/$(get_libdir)/postgresql-${SLOT}/bin/initdb -D \"${DATA_DIR}\" ${PG_INITDB_OPTS}"
else
"${EROOT}"/usr/$(get_libdir)/postgresql-${SLOT}/bin/initdb -U postgres -D "${DATA_DIR}" ${PG_INITDB_OPTS}
fi
diff --git a/dev-db/postgresql/postgresql-11.12.ebuild b/dev-db/postgresql/postgresql-11.12.ebuild
index 5a20556a0fe5..07aed06687cf 100644
--- a/dev-db/postgresql/postgresql-11.12.ebuild
+++ b/dev-db/postgresql/postgresql-11.12.ebuild
@@ -388,7 +388,7 @@ pkg_config() {
einfo "Initializing the database ..."
if [[ ${EUID} == 0 ]] ; then
- su postgres -c "${EROOT}/usr/$(get_libdir)/postgresql-${SLOT}/bin/initdb -D \"${DATA_DIR}\" ${PG_INITDB_OPTS}"
+ su - postgres -c "${EROOT}/usr/$(get_libdir)/postgresql-${SLOT}/bin/initdb -D \"${DATA_DIR}\" ${PG_INITDB_OPTS}"
else
"${EROOT}"/usr/$(get_libdir)/postgresql-${SLOT}/bin/initdb -U postgres -D "${DATA_DIR}" ${PG_INITDB_OPTS}
fi
diff --git a/dev-db/postgresql/postgresql-12.7.ebuild b/dev-db/postgresql/postgresql-12.7.ebuild
index c6cea755c817..82e066d4d05b 100644
--- a/dev-db/postgresql/postgresql-12.7.ebuild
+++ b/dev-db/postgresql/postgresql-12.7.ebuild
@@ -388,7 +388,7 @@ pkg_config() {
einfo "Initializing the database ..."
if [[ ${EUID} == 0 ]] ; then
- su postgres -c "${EROOT}/usr/$(get_libdir)/postgresql-${SLOT}/bin/initdb -D \"${DATA_DIR}\" ${PG_INITDB_OPTS}"
+ su - postgres -c "${EROOT}/usr/$(get_libdir)/postgresql-${SLOT}/bin/initdb -D \"${DATA_DIR}\" ${PG_INITDB_OPTS}"
else
"${EROOT}"/usr/$(get_libdir)/postgresql-${SLOT}/bin/initdb -U postgres -D "${DATA_DIR}" ${PG_INITDB_OPTS}
fi
diff --git a/dev-db/postgresql/postgresql-13.3.ebuild b/dev-db/postgresql/postgresql-13.3.ebuild
index 9b8485c9bc0f..d71750a1cb74 100644
--- a/dev-db/postgresql/postgresql-13.3.ebuild
+++ b/dev-db/postgresql/postgresql-13.3.ebuild
@@ -388,7 +388,7 @@ pkg_config() {
einfo "Initializing the database ..."
if [[ ${EUID} == 0 ]] ; then
- su postgres -c "${EROOT}/usr/$(get_libdir)/postgresql-${SLOT}/bin/initdb -D \"${DATA_DIR}\" ${PG_INITDB_OPTS}"
+ su - postgres -c "${EROOT}/usr/$(get_libdir)/postgresql-${SLOT}/bin/initdb -D \"${DATA_DIR}\" ${PG_INITDB_OPTS}"
else
"${EROOT}"/usr/$(get_libdir)/postgresql-${SLOT}/bin/initdb -U postgres -D "${DATA_DIR}" ${PG_INITDB_OPTS}
fi
diff --git a/dev-db/postgresql/postgresql-14_beta2.ebuild b/dev-db/postgresql/postgresql-14_beta2.ebuild
index 0ef0e4f1672b..a9630c760e88 100644
--- a/dev-db/postgresql/postgresql-14_beta2.ebuild
+++ b/dev-db/postgresql/postgresql-14_beta2.ebuild
@@ -390,7 +390,7 @@ pkg_config() {
einfo "Initializing the database ..."
if [[ ${EUID} == 0 ]] ; then
- su postgres -c "${EROOT}/usr/$(get_libdir)/postgresql-${SLOT}/bin/initdb -D \"${DATA_DIR}\" ${PG_INITDB_OPTS}"
+ su - postgres -c "${EROOT}/usr/$(get_libdir)/postgresql-${SLOT}/bin/initdb -D \"${DATA_DIR}\" ${PG_INITDB_OPTS}"
else
"${EROOT}"/usr/$(get_libdir)/postgresql-${SLOT}/bin/initdb -U postgres -D "${DATA_DIR}" ${PG_INITDB_OPTS}
fi
diff --git a/dev-db/postgresql/postgresql-9.6.22.ebuild b/dev-db/postgresql/postgresql-9.6.22.ebuild
index 81db6bcb3596..6ef13fcda3a7 100644
--- a/dev-db/postgresql/postgresql-9.6.22.ebuild
+++ b/dev-db/postgresql/postgresql-9.6.22.ebuild
@@ -411,7 +411,7 @@ pkg_config() {
einfo "Initializing the database ..."
if [[ ${EUID} == 0 ]] ; then
- su postgres -c "${EROOT}/usr/$(get_libdir)/postgresql-${SLOT}/bin/initdb -D \"${DATA_DIR}\" ${PG_INITDB_OPTS}"
+ su - postgres -c "${EROOT}/usr/$(get_libdir)/postgresql-${SLOT}/bin/initdb -D \"${DATA_DIR}\" ${PG_INITDB_OPTS}"
else
"${EROOT}"/usr/$(get_libdir)/postgresql-${SLOT}/bin/initdb -U postgres -D "${DATA_DIR}" ${PG_INITDB_OPTS}
fi
diff --git a/dev-db/postgresql/postgresql-9999.ebuild b/dev-db/postgresql/postgresql-9999.ebuild
index e83be695c51b..106cb9fb88fe 100644
--- a/dev-db/postgresql/postgresql-9999.ebuild
+++ b/dev-db/postgresql/postgresql-9999.ebuild
@@ -402,7 +402,7 @@ pkg_config() {
einfo "Initializing the database ..."
if [[ ${EUID} == 0 ]] ; then
- su postgres -c "${EROOT}/usr/$(get_libdir)/postgresql-${SLOT}/bin/initdb -D \"${DATA_DIR}\" ${PG_INITDB_OPTS}"
+ su - postgres -c "${EROOT}/usr/$(get_libdir)/postgresql-${SLOT}/bin/initdb -D \"${DATA_DIR}\" ${PG_INITDB_OPTS}"
else
"${EROOT}"/usr/$(get_libdir)/postgresql-${SLOT}/bin/initdb -U postgres -D "${DATA_DIR}" ${PG_INITDB_OPTS}
fi