summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-02-25 06:43:07 +0100
committerMichał Górny <mgorny@gentoo.org>2023-02-25 07:02:08 +0100
commitb651718556fc54b9e3323eadbcf7a3c88d79fad2 (patch)
tree74a05c4575772da2131ea75ca0a5f9dbc9a23858
parentdev-python/python-slugify: Bump to 8.0.1 (diff)
downloadgentoo-b651718556fc54b9e3323eadbcf7a3c88d79fad2.tar.gz
gentoo-b651718556fc54b9e3323eadbcf7a3c88d79fad2.tar.bz2
gentoo-b651718556fc54b9e3323eadbcf7a3c88d79fad2.zip
dev-python/owslib: Bump to 0.28.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/owslib/Manifest1
-rw-r--r--dev-python/owslib/owslib-0.28.1.ebuild53
2 files changed, 54 insertions, 0 deletions
diff --git a/dev-python/owslib/Manifest b/dev-python/owslib/Manifest
index 0d441a46522b..7a6080285472 100644
--- a/dev-python/owslib/Manifest
+++ b/dev-python/owslib/Manifest
@@ -1,2 +1,3 @@
DIST OWSLib-0.28.0.gh.tar.gz 951384 BLAKE2B f3c69f9a2526d54c650fd37dd6e7d55b37b6cbc503d08105a1c7e685ebea76cb7471f6de634947b42a080535fbdbb5262b30771d22e32c977f2a579fe2bdb62c SHA512 4a5002a05c1616ca382aa85561cee950c707488feb37f0f29232758159abcef8545980361cb976240e9026937557ab349764f84c95091f9f3df8698498f47fde
+DIST OWSLib-0.28.1.gh.tar.gz 950453 BLAKE2B 8210efdea8ac2536348659a1bed46b5eb1b4da5a8b77979cc11d23273b1f806bef21d007ddd8a6961c16e241c4f3e18c93054c8abaa89baf8b765c98d74605d0 SHA512 bd62a5e371e64e0e256cc83d2f044294c20965f6b107b0dd9074ac752971620f01af4c7fc9a82e43dc81e71a6a36696b75403012841c28925b017d9c47b2d4a5
DIST owslib-0.27.2.gh.tar.gz 949148 BLAKE2B 2e12b43de3c3c362b03af15c93fe268e9ad8dd8647a18a8ef978203db896db65dd26cd20d6d58214880248593589604f764887b50c9eb8695d8e51accef3dfe8 SHA512 02c70731ef92783d53b8f0dff2cec7d28d14ac08b0a4b5090183f9eacf156d539c823fcd2ae480c07447e901697de498cdf2aaf27c8b6d46fa4cf8eb3679ceee
diff --git a/dev-python/owslib/owslib-0.28.1.ebuild b/dev-python/owslib/owslib-0.28.1.ebuild
new file mode 100644
index 000000000000..9ca97e344873
--- /dev/null
+++ b/dev-python/owslib/owslib-0.28.1.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit distutils-r1
+
+MY_P=OWSLib-${PV}
+DESCRIPTION="Library for client programming with Open Geospatial Consortium web service"
+HOMEPAGE="
+ https://geopython.github.io/OWSLib/
+ https://github.com/geopython/owslib/
+ https://pypi.org/project/OWSLib/
+"
+SRC_URI="
+ https://github.com/geopython/${PN}/archive/${PV}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+RESTRICT="test"
+PROPERTIES="test_network"
+
+RDEPEND="
+ dev-python/lxml[${PYTHON_USEDEP}]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+ dev-python/pytz[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/pillow[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ # connection errors
+ tests/test_wfs_generic.py::test_xmlfilter_wfs_110
+ tests/test_wfs_generic.py::test_xmlfilter_wfs_200
+)
+
+python_test() {
+ epytest -o addopts=
+}