summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEli Schwartz <eschwartz93@gmail.com>2024-03-06 16:59:02 -0500
committerSam James <sam@gentoo.org>2024-03-07 11:46:22 +0000
commitb66a63a35a46f130af96b806eb6e022d47a5810e (patch)
tree53585777194c87e88bf1f8e1d3db8ab0ba110424
parentdev-db/sqlitebrowser: drop old 3.12.2 (diff)
downloadgentoo-b66a63a35a46f130af96b806eb6e022d47a5810e.tar.gz
gentoo-b66a63a35a46f130af96b806eb6e022d47a5810e.tar.bz2
gentoo-b66a63a35a46f130af96b806eb6e022d47a5810e.zip
app-i18n/scim-tomoe: re-run autoreconf to fix LTO
The 2009 era distfile is so old that it probably has many bugs. We are particularly concerned by nm detection failing under LTO causing: ``` generating symbol list for `tomoe.la' /usr/bin/nm -B .libs/tomoe_la-scim_tomoe.o .libs/tomoe_la-scim_tomoe_prefs_widget.o | | /usr/bin/sed 's/.* //' | sort | uniq > .libs/tomoe.exp ../libtool: 1: eval: Syntax error: "|" unexpected ``` It also causes some implicit function declaration issues in configure tests, which we conveniently solve at the same time. Closes: https://bugs.gentoo.org/854669 Closes: https://bugs.gentoo.org/910677 Signed-off-by: Eli Schwartz <eschwartz93@gmail.com> Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--app-i18n/scim-tomoe/scim-tomoe-0.6.0-r3.ebuild10
1 files changed, 9 insertions, 1 deletions
diff --git a/app-i18n/scim-tomoe/scim-tomoe-0.6.0-r3.ebuild b/app-i18n/scim-tomoe/scim-tomoe-0.6.0-r3.ebuild
index c6c427a16733..7c25a86e597c 100644
--- a/app-i18n/scim-tomoe/scim-tomoe-0.6.0-r3.ebuild
+++ b/app-i18n/scim-tomoe/scim-tomoe-0.6.0-r3.ebuild
@@ -1,8 +1,10 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
+inherit autotools
+
DESCRIPTION="Japanese input method Tomoe IMEngine for SCIM"
HOMEPAGE="http://tomoe.sourceforge.net/"
SRC_URI="mirror://sourceforge/tomoe/${P}.tar.gz"
@@ -24,6 +26,12 @@ DEPEND="${RDEPEND}
PATCHES=( "${FILESDIR}"/${P}-gcc43.patch )
+src_prepare() {
+ default
+ # update the 2007 era configure / libtool scripts, which fail with LTO
+ eautoreconf
+}
+
src_configure() {
econf --disable-static
}