summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-08-27 08:53:51 +0100
committerSam James <sam@gentoo.org>2022-08-27 08:53:51 +0100
commitb679400f1f2047aeb7e03650a69002aae50ba95f (patch)
tree793d517b653ddb39d3e72f26619677f4acf8beb8
parentsys-libs/libselinux: drop removed ruby26 (diff)
downloadgentoo-b679400f.tar.gz
gentoo-b679400f.tar.bz2
gentoo-b679400f.zip
dev-ruby/http: drop 4.1.1
Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--dev-ruby/http/Manifest1
-rw-r--r--dev-ruby/http/http-4.1.1.ebuild46
2 files changed, 0 insertions, 47 deletions
diff --git a/dev-ruby/http/Manifest b/dev-ruby/http/Manifest
index 4cdab66abad6..41b2ecc8d0a2 100644
--- a/dev-ruby/http/Manifest
+++ b/dev-ruby/http/Manifest
@@ -1,2 +1 @@
-DIST http-4.1.1.gem 74240 BLAKE2B 350d4a2eb966f8dae05a206e20a92d8ce0601df36673cae8c969b8849d6715c5d0ab0e24c4b6cc4f117e4788e535296f86d5193198df4a8229572817c9cd3f75 SHA512 89e088521212293db692b66a7058327c215bba119b3f01d4120fd32f0754294d4cbada88ed9cffb6f182f6d712a0923dadfc645c1618e25a802fcc3d467356de
DIST http-4.4.1.gem 75776 BLAKE2B ab34a6a567842d52f9b7cbe3fc3fb8e4757f5cf1303deacdf2f2130a44e82fde64f0db561c3f8fc28100faea277a9c4a9352f95e6cb1359730b34e83a7b36d72 SHA512 6e43a8ae379d7c8a807a9a03c87bfb5ad1719f9838e26ac7a695220ee2bc50344accc2db268d30da175328fd5468b87ec8532d17ce42a5b74d6c2c4c281d1bc9
diff --git a/dev-ruby/http/http-4.1.1.ebuild b/dev-ruby/http/http-4.1.1.ebuild
deleted file mode 100644
index d9ea9b87273d..000000000000
--- a/dev-ruby/http/http-4.1.1.ebuild
+++ /dev/null
@@ -1,46 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-USE_RUBY="ruby24 ruby25 ruby26"
-
-RUBY_FAKEGEM_RECIPE_TEST="rspec3"
-
-RUBY_FAKEGEM_RECIPE_DOC="rdoc"
-RUBY_FAKEGEM_EXTRADOC="CHANGES.md README.md"
-
-inherit ruby-fakegem
-
-DESCRIPTION="An easy-to-use client library for making requests from Ruby"
-HOMEPAGE="https://github.com/tarcieri/http"
-
-LICENSE="MIT"
-SLOT="4"
-KEYWORDS="amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
-IUSE=""
-
-ruby_add_rdepend "
- >=dev-ruby/addressable-2.3:0
- >=dev-ruby/http-cookie-1.0:0
- dev-ruby/http-form_data:2
- >=dev-ruby/http_parser_rb-0.6.0 =dev-ruby/http_parser_rb-0.6*"
-
-ruby_add_bdepend "
- test? ( dev-ruby/certificate_authority dev-ruby/rspec-its )"
-
-all_ruby_prepare() {
- sed -i -e '/simplecov/,/end/ s:^:#:' \
- -e '1irequire "cgi"' spec/spec_helper.rb || die
-
- # Avoid specs that require network access
- sed -i -e '/.persistent/,/^ end/ s:^:#:' \
- spec/lib/http_spec.rb || die
- sed -i -e '/with non-ASCII URLs/,/^ end/ s:^:#:' \
- spec/lib/http/client_spec.rb || die
-
- # Avoid spec that may fail with a running web server
- sed -i -e '/unifies socket errors into HTTP::ConnectionError/,/^ end/ s:^:#:' spec/lib/http_spec.rb || die
-
- # Fix spec for production release
- sed -i -e '/User-Agent:/ s/.dev//' spec/lib/http/features/logging_spec.rb || die
-}