summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-11-02 07:51:50 +0100
committerMichał Górny <mgorny@gentoo.org>2022-11-02 08:37:22 +0100
commitb6835a82d43b90b34d08996c4c456c39b6100391 (patch)
tree1809e76eccbe585030d3f6f58a6fd2702d2e981f
parentdev-python/networkx: Bump to 2.8.8 (diff)
downloadgentoo-b6835a82.tar.gz
gentoo-b6835a82.tar.bz2
gentoo-b6835a82.zip
dev-python/sphinx_rtd_theme: Bump to 1.1.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/sphinx_rtd_theme/Manifest1
-rw-r--r--dev-python/sphinx_rtd_theme/sphinx_rtd_theme-1.1.0.ebuild43
2 files changed, 44 insertions, 0 deletions
diff --git a/dev-python/sphinx_rtd_theme/Manifest b/dev-python/sphinx_rtd_theme/Manifest
index 36c2ba7770a6..e8f13b0582d9 100644
--- a/dev-python/sphinx_rtd_theme/Manifest
+++ b/dev-python/sphinx_rtd_theme/Manifest
@@ -1 +1,2 @@
DIST sphinx_rtd_theme-1.0.0.tar.gz 2780623 BLAKE2B 02e72ddade0632423d21e512ab86fbdcc9f18eddbef328ba766f1b06a49c838808af4ee000e57c8f0f40112569b35c1b62c9c0c8853c237fd2ddb6de76d48a21 SHA512 06025445e1358c994bf0c15a382ec8f8f3f2114dfac19f340585a3660d91a279100c2d16ef665d9eb8d38b0e4ed264e96d3ac6814dd01b9430d2f8a0d8275178
+DIST sphinx_rtd_theme-1.1.0.tar.gz 2782178 BLAKE2B d121a9eb2514c5f23260bdb97e360d7a611b895a35155592671fab557995904d6ba2db8fdc83cec390acbf800442289138995f680655cc7a1d9ff9edfcaf557c SHA512 49a87d97a0d4edd8e5e1244fb02dcf37d06e4d64a97b939678ba006b1159b06f173d18a7f5b5eaefade8818a5bee1bb9455131bfd0ec54d42063295595d45b14
diff --git a/dev-python/sphinx_rtd_theme/sphinx_rtd_theme-1.1.0.ebuild b/dev-python/sphinx_rtd_theme/sphinx_rtd_theme-1.1.0.ebuild
new file mode 100644
index 000000000000..849354151794
--- /dev/null
+++ b/dev-python/sphinx_rtd_theme/sphinx_rtd_theme-1.1.0.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="ReadTheDocs.org theme for Sphinx"
+HOMEPAGE="
+ https://github.com/readthedocs/sphinx_rtd_theme/
+ https://pypi.org/project/sphinx-rtd-theme/
+"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-macos"
+IUSE=""
+
+RDEPEND="
+ dev-python/docutils[${PYTHON_USEDEP}]
+ >=dev-python/sphinx-1.6[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/readthedocs-sphinx-ext[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ # unpin docutils
+ sed -i -e '/docutils/s:<0.18::' setup.cfg || die
+ distutils-r1_src_prepare
+
+ # CI=1 disables rebuilding webpack that requires npm use
+ # yes, that surely makes sense
+ export CI=1
+}