summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-10-19 14:11:18 +0200
committerMichał Górny <mgorny@gentoo.org>2023-10-19 14:13:58 +0200
commitb6850910e4089720579247b513f1b7e79fb49626 (patch)
tree4291d3d5f3b7175e8e84a627a99a7128ca8cb6ee
parentdev-python/networkx: Bump to 3.2 (diff)
downloadgentoo-b6850910e4089720579247b513f1b7e79fb49626.tar.gz
gentoo-b6850910e4089720579247b513f1b7e79fb49626.tar.bz2
gentoo-b6850910e4089720579247b513f1b7e79fb49626.zip
dev-python/paste: Bump to 3.7.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/paste/Manifest1
-rw-r--r--dev-python/paste/paste-3.7.1.ebuild49
2 files changed, 50 insertions, 0 deletions
diff --git a/dev-python/paste/Manifest b/dev-python/paste/Manifest
index 0d415e6b21b4..bb2b6e8001f1 100644
--- a/dev-python/paste/Manifest
+++ b/dev-python/paste/Manifest
@@ -1,3 +1,4 @@
DIST Paste-3.5.3.tar.gz 638791 BLAKE2B 12bcd083ba87699c05c46b1d27757ef4de5f528ba4f01407c113cccc1c59975a6143b6831d1d640b0d0fb82995c7aefd5e14601795403512a2997bd8a9e55466 SHA512 3087ea7b6cc45a90b85c473cbff7f018ca961536ff70fbed4610f86dedc82cef0274ccddb767de411ec2955d0c265cb4e797a14a25697870c38667ccd7c4a2d8
DIST Paste-3.6.0.tar.gz 638953 BLAKE2B 89dc1b04c1b7eacae851900a274e5531ee568e2ef797b954e0c2e0b7bbe914e4bd129a5033919d914335680eb1aa57b115f647c65986ee4ae6e54a5edc9f16c5 SHA512 cacd3150da289f35960363bf77d9749b367ea857bebcfa601bd8410fb317a61ec357be0ef44fbdf9e576c3a3ec2934597d4e1a419f06e64f463705ebb6feb1bb
DIST Paste-3.6.1.tar.gz 638943 BLAKE2B 20ed0fd350f611e4b170431fbeea7ea34bca6f339f65bfaef15521dcef4d2408f532f787993a55940287bdeb5383f87d0a11909aded1785fa06dafb814b502eb SHA512 3e2b5c943e68f999e9f406cabd81c9a5fed0a3dea02400f8b42ed0dab7f70665fb69136fd4c00be758fa18634f0f546068e59d21d9aa934a5ed87f52a7e370c4
+DIST Paste-3.7.1.tar.gz 639191 BLAKE2B 5c36794e0d0aba9396a621933bfc2b600da5c951a6aed39ebcea8a1ad84449556a94bbf13651fe28c0886f826417ee0dfe6b82ad76c4956579b0a5795539ae3d SHA512 672f0476582b0c0f65a049800fbd23f7df2c62b405ed1b803474715a80d532bbf117558b201329967bf83f4c88c8740e5f626ff5c2dafa3eade04fccefd332b0
diff --git a/dev-python/paste/paste-3.7.1.ebuild b/dev-python/paste/paste-3.7.1.ebuild
new file mode 100644
index 000000000000..cbdcd33095e3
--- /dev/null
+++ b/dev-python/paste/paste-3.7.1.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYPI_NO_NORMALIZE=1
+PYPI_PN=${PN^}
+PYTHON_COMPAT=( python3_{10..12} pypy3 )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Tools for using a Web Server Gateway Interface stack"
+HOMEPAGE="
+ https://pythonpaste.readthedocs.io/en/latest/
+ https://github.com/cdent/paste/
+ https://pypi.org/project/Paste/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~x64-macos"
+
+RDEPEND="
+ >=dev-python/six-1.4.0[${PYTHON_USEDEP}]
+ !dev-python/namespace-paste
+"
+
+distutils_enable_tests pytest
+distutils_enable_sphinx docs
+
+python_compile() {
+ distutils-r1_python_compile
+ find "${BUILD_DIR}" -name '*.pth' -delete || die
+}
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # Internet
+ tests/test_proxy.py
+ )
+
+ [[ ${EPYTHON} == python3.1[12] ]] && EPYTEST_DESELECT+=(
+ # fails due to cgi deprecation warning
+ tests/test_cgiapp.py::test_form
+ )
+
+ epytest
+}