summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2017-11-04 00:42:33 -0400
committerTim Harder <radhermit@gentoo.org>2017-11-06 02:45:57 -0500
commitb69b1eb73e94e14a939e03854b347d8858b5b5ab (patch)
tree2029d0cc0c240058ee35d7a081678a2ac0f5504b
parentdev-python/unidecode: stable 0.04.20 for sparc, bug #616976 (thanks to Rolf E... (diff)
downloadgentoo-b69b1eb73e94e14a939e03854b347d8858b5b5ab.tar.gz
gentoo-b69b1eb73e94e14a939e03854b347d8858b5b5ab.tar.bz2
gentoo-b69b1eb73e94e14a939e03854b347d8858b5b5ab.zip
dev-util/umockdev: version bump to 0.9.4
-rw-r--r--dev-util/umockdev/Manifest1
-rw-r--r--dev-util/umockdev/files/umockdev-0.9.4-sysmacros.patch20
-rw-r--r--dev-util/umockdev/umockdev-0.9.4.ebuild34
3 files changed, 55 insertions, 0 deletions
diff --git a/dev-util/umockdev/Manifest b/dev-util/umockdev/Manifest
index 7b425a951cc4..d625e2fcaf33 100644
--- a/dev-util/umockdev/Manifest
+++ b/dev-util/umockdev/Manifest
@@ -1 +1,2 @@
DIST umockdev-0.8.11.tar.xz 741812 SHA256 222518a634c57b1d6d9f51b042e8c80641251260d9c43e6c6273d446d577ccb7 SHA512 dd6aa23873060c2778796f7300b61aa46e6f9bed8b2b2dc107eb747ade93f9d9027385a414f2107f3da4932065e1f7ec488cc91c6f24c3204a7abbbdf4cb8e84 WHIRLPOOL b736ca9d9f73294e5aabc3be75e006efcfdba8f8ecb96cdeb2fb88a12cc3ba53870c416c82c315acc7da7929d07a9efcdc6ceadaa324e0c63a9a60589d66148c
+DIST umockdev-0.9.4.tar.xz 754856 SHA256 968cea51804d1de7a1db1c96958326e2f2207a0fdaae18940445e29430e94468 SHA512 c291d3f40a0ab366f14021aa0960852de049f4299a0207d93cec28d5961f3bc7f89448add6f7b35c1262d805d1d638837d4d5e6b734879ffb5910da50019e1cd WHIRLPOOL 76ffb5c7d0ce53f1a7126247d8d7e9e99f7fafb537b19ef8ae48b794664a713c6ade3565abf20a1bbc10857dc8c4c20d3d75a4543dba7e010b63d4fe2a62f3a5
diff --git a/dev-util/umockdev/files/umockdev-0.9.4-sysmacros.patch b/dev-util/umockdev/files/umockdev-0.9.4-sysmacros.patch
new file mode 100644
index 000000000000..bfc8bc9ed535
--- /dev/null
+++ b/dev-util/umockdev/files/umockdev-0.9.4-sysmacros.patch
@@ -0,0 +1,20 @@
+--- umockdev-0.9.4/src/umockdev-record.c
++++ umockdev-0.9.4/src/umockdev-record.c
+@@ -30,6 +30,7 @@
+ #include <stdio.h>
+ #include <stdarg.h>
+ #include <sys/stat.h>
++#include <sys/sysmacros.h>
+ #include <errno.h>
+ #include <sys/types.h>
+ #include <glib/gstdio.h>
+--- umockdev-0.9.4/tests/test-umockdev-vala.c
++++ umockdev-0.9.4/tests/test-umockdev-vala.c
+@@ -36,6 +36,7 @@
+ #include <unistd.h>
+ #include <glib/gstdio.h>
+ #include <sys/stat.h>
++#include <sys/sysmacros.h>
+ #include <gobject/gvaluecollector.h>
+
+ #define _g_error_free0(var) ((var == NULL) ? NULL : (var = (g_error_free (var), NULL)))
diff --git a/dev-util/umockdev/umockdev-0.9.4.ebuild b/dev-util/umockdev/umockdev-0.9.4.ebuild
new file mode 100644
index 000000000000..56a4b358cf1e
--- /dev/null
+++ b/dev-util/umockdev/umockdev-0.9.4.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
+
+inherit python-any-r1
+
+DESCRIPTION="Mock hardware devices for creating unit tests"
+HOMEPAGE="https://github.com/martinpitt/umockdev/"
+SRC_URI="https://launchpad.net/${PN}/trunk/${PV}/+download/${P}.tar.xz"
+
+LICENSE="LGPL-2.1+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="static-libs test"
+
+RDEPEND="virtual/libgudev:=
+ virtual/libudev:=
+ >=dev-libs/glib-2.32:2"
+DEPEND="${RDEPEND}
+ test? ( ${PYTHON_DEPS} )
+ app-arch/xz-utils
+ virtual/pkgconfig"
+
+RESTRICT="test"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-sysmacros.patch #579988
+)
+
+src_configure() {
+ econf $(use_enable static-libs static)
+}