summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConrad Kostecki <conikost@gentoo.org>2021-07-11 22:55:21 +0200
committerConrad Kostecki <conikost@gentoo.org>2021-07-11 23:18:25 +0200
commitb69d01f630df828187efcd8712f82fd8f0af1c8c (patch)
tree2d11c8e52c45aa9c2fba6472c040781990a1b7a4
parentnet-misc/samplicator: migrate to GLEP 81 (diff)
downloadgentoo-b69d01f6.tar.gz
gentoo-b69d01f6.tar.bz2
gentoo-b69d01f6.zip
net-misc/samplicator: drop old version
Closes: https://bugs.gentoo.org/781431 Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
-rw-r--r--net-misc/samplicator/samplicator-1.3.6.ebuild53
-rw-r--r--net-misc/samplicator/samplicator-1.3.8_rc1.ebuild58
2 files changed, 0 insertions, 111 deletions
diff --git a/net-misc/samplicator/samplicator-1.3.6.ebuild b/net-misc/samplicator/samplicator-1.3.6.ebuild
deleted file mode 100644
index 9a434494afdd..000000000000
--- a/net-misc/samplicator/samplicator-1.3.6.ebuild
+++ /dev/null
@@ -1,53 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-inherit user
-
-DESCRIPTION="UDP packets forwarder and duplicator"
-HOMEPAGE="https://github.com/sleinen/samplicator"
-SRC_URI="https://github.com/sleinen/${PN}/releases/download/v${PV}/${P}.tar.gz"
-
-LICENSE="Artistic GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-
-pkg_setup() {
- # Add samplicator group and user to system
- enewgroup ${PN}
- enewuser ${PN} -1 -1 /etc/${PN} ${PN}
-}
-
-src_install() {
- # Install and copy documentation
- default
-
- # Install Gentoo init script and its config
- newinitd "${FILESDIR}"/${PN}.initd ${PN}
- newconfd "${FILESDIR}"/${PN}.confd ${PN}
-
- # Install manual page
- doman "${FILESDIR}"/${PN}.8
-}
-
-pkg_postinst() {
- ewarn ""
- ewarn "Don't specify the receiver on the command line, because it will get all packets."
- ewarn "Instead of this, specify it in a config file; defined in such way it will only get packets with a matching source."
- ewarn ""
-
- einfo "For every receiver type create a file in directory /etc/${PN} (see example below)"
- einfo "and specify the path to it in variable CONFIG of the corresponding initscript config file in /etc/conf.d/"
- einfo ""
- einfo "Receiver config examples: "
- einfo ""
- einfo " /etc/${PN}/netflow:"
- einfo " 10.0.0.0/255.0.0.0:1.1.1.1/9996 2.2.2.2/9996 3.3.3.3/9996"
- einfo ""
- einfo " /etc/${PN}/syslog:"
- einfo " 10.0.0.0/255.255.0.0:2.2.2.2/514 3.3.3.3/514"
- einfo ""
- einfo " /etc/${PN}/snmp:"
- einfo " 10.0.0.0/255.255.255.255:3.3.3.3/162"
-}
diff --git a/net-misc/samplicator/samplicator-1.3.8_rc1.ebuild b/net-misc/samplicator/samplicator-1.3.8_rc1.ebuild
deleted file mode 100644
index db20a1619e9d..000000000000
--- a/net-misc/samplicator/samplicator-1.3.8_rc1.ebuild
+++ /dev/null
@@ -1,58 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-MY_PV=${PV/_/}
-MY_P=${PN}-${MY_PV}
-
-inherit user
-
-DESCRIPTION="UDP packets forwarder and duplicator"
-HOMEPAGE="https://github.com/sleinen/samplicator"
-SRC_URI="https://github.com/sleinen/${PN}/releases/download/${MY_PV}/${MY_P}.tar.gz"
-
-LICENSE="Artistic GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-
-S="${WORKDIR}/${MY_P}"
-
-pkg_setup() {
- # Add samplicator group and user to system
- enewgroup ${PN}
- enewuser ${PN} -1 -1 /etc/${PN} ${PN}
-}
-
-src_install() {
- # Install and copy documentation
- default
-
- # Install Gentoo init script and its config
- newinitd "${FILESDIR}"/${PN}.initd ${PN}
- newconfd "${FILESDIR}"/${PN}.confd ${PN}
-
- # Install manual page
- doman "${FILESDIR}"/${PN}.8
-}
-
-pkg_postinst() {
- ewarn ""
- ewarn "Don't specify the receiver on the command line, because it will get all packets."
- ewarn "Instead of this, specify it in a config file; defined in such way it will only get packets with a matching source."
- ewarn ""
-
- einfo "For every receiver type create a file in directory /etc/${PN} (see example below)"
- einfo "and specify the path to it in variable CONFIG of the corresponding initscript config file in /etc/conf.d/"
- einfo ""
- einfo "Receiver config examples: "
- einfo ""
- einfo " /etc/${PN}/netflow:"
- einfo " 10.0.0.0/255.0.0.0:1.1.1.1/9996 2.2.2.2/9996 3.3.3.3/9996"
- einfo ""
- einfo " /etc/${PN}/syslog:"
- einfo " 10.0.0.0/255.255.0.0:2.2.2.2/514 3.3.3.3/514"
- einfo ""
- einfo " /etc/${PN}/snmp:"
- einfo " 10.0.0.0/255.255.255.255:3.3.3.3/162"
-}