summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2022-09-02 17:52:13 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2022-09-02 18:17:08 +0300
commitb6a4ab00fbb44e99cbcbcb667d58c915ba56c8d0 (patch)
treeecdb0b77367aaefcccb0087131ee2028c774b9b8
parentdev-python/prettytable: drop 3.4.0 (diff)
downloadgentoo-b6a4ab00.tar.gz
gentoo-b6a4ab00.tar.bz2
gentoo-b6a4ab00.zip
dev-python/pathable: new package, add 0.4.3
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
-rw-r--r--dev-python/pathable/Manifest1
-rw-r--r--dev-python/pathable/metadata.xml13
-rw-r--r--dev-python/pathable/pathable-0.4.3.ebuild28
3 files changed, 42 insertions, 0 deletions
diff --git a/dev-python/pathable/Manifest b/dev-python/pathable/Manifest
new file mode 100644
index 000000000000..28d17c8e2e1b
--- /dev/null
+++ b/dev-python/pathable/Manifest
@@ -0,0 +1 @@
+DIST pathable-0.4.3.gh.tar.gz 21412 BLAKE2B 6f62cd879723ff14c2fd7100c9ce7135d200fe04afb473180518ed2e80c5bc5836f82334b1dbbbc8fa80b428fa33db1a8ffafcd8b756cc00a24a809094f61dd2 SHA512 5481ba1e6f4ab4318b9a7bd1d1ddd152f715b001bc7edd1b1221501da1a95578ee6601ce4ce0bdb98773c7954212687d249418e69acef1b350fc5d6cb188dbfc
diff --git a/dev-python/pathable/metadata.xml b/dev-python/pathable/metadata.xml
new file mode 100644
index 000000000000..8ce0babd047a
--- /dev/null
+++ b/dev-python/pathable/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <stabilize-allarches/>
+ <upstream>
+ <remote-id type="pypi">pathable</remote-id>
+ <remote-id type="github">p1c2u/pathable</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/pathable/pathable-0.4.3.ebuild b/dev-python/pathable/pathable-0.4.3.ebuild
new file mode 100644
index 000000000000..2713754dec4e
--- /dev/null
+++ b/dev-python/pathable/pathable-0.4.3.ebuild
@@ -0,0 +1,28 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=poetry
+PYTHON_COMPAT=( pypy3 python3_{8..11} )
+inherit distutils-r1
+
+DESCRIPTION="Object-oriented paths"
+HOMEPAGE="
+ https://pypi.org/project/pathable/
+ https://github.com/p1c2u/pathable
+"
+SRC_URI="
+ https://github.com/p1c2u/pathable/archive/${PV}.tar.gz -> ${P}.gh.tar.gz
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ sed -e '/--cov/d' -i pyproject.toml || die
+ distutils-r1_src_prepare
+}