summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEli Schwartz <eschwartz93@gmail.com>2024-03-01 02:43:58 -0500
committerSam James <sam@gentoo.org>2024-03-03 04:00:12 +0000
commitb6bfb7ce52d2f05ed2deda2aa94bf46e51d56844 (patch)
treec0fe23fb94e66415d884a98d5f7eb4335cc7bdf3
parentsys-fs/e2fsprogs: drop 1.47.0-r2 (diff)
downloadgentoo-b6bfb7ce52d2f05ed2deda2aa94bf46e51d56844.tar.gz
gentoo-b6bfb7ce52d2f05ed2deda2aa94bf46e51d56844.tar.bz2
gentoo-b6bfb7ce52d2f05ed2deda2aa94bf46e51d56844.zip
dev-python/shiboken6: disable terrible default of forcing limited API
The python Limited API allows you to compile a native extension once for e.g. python 3.8, create a wheel package, and then install that on any version of python 3.8+. This is inherently non-useful to distros, which compile the extensions for each build regardless. The Limited API is slower than the internal API, and benefits nothing at all for our use case. But shiboken defaults to creating one. Manually pass the option to disable it. The Limited API builds of shiboken also have LTO issues that the regular builds do not. Odd. See comments at https://bugreports.qt.io/browse/PYSIDE-2619 (Note that there are other LTO issues with shiboken which are fixed in git dev, so we can't remove filter-lto yet.) Bug: https://bugs.gentoo.org/925479 Signed-off-by: Eli Schwartz <eschwartz93@gmail.com> Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--dev-python/shiboken6/shiboken6-6.6.2-r1.ebuild (renamed from dev-python/shiboken6/shiboken6-6.6.2.ebuild)1
1 files changed, 1 insertions, 0 deletions
diff --git a/dev-python/shiboken6/shiboken6-6.6.2.ebuild b/dev-python/shiboken6/shiboken6-6.6.2-r1.ebuild
index 4187835e2818..181ab1d02922 100644
--- a/dev-python/shiboken6/shiboken6-6.6.2.ebuild
+++ b/dev-python/shiboken6/shiboken6-6.6.2-r1.ebuild
@@ -127,6 +127,7 @@ src_configure() {
-DPYTHON_CONFIG_SUFFIX="-${EPYTHON}"
-DPYTHON_EXECUTABLE="${PYTHON}"
-DUSE_PYTHON_VERSION="${EPYTHON#python}"
+ -DFORCE_LIMITED_API=OFF
)
# CMakeLists.txt expects LLVM_INSTALL_DIR as an environment variable.
local -x LLVM_INSTALL_DIR="$(get_llvm_prefix)"