summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-07-29 14:54:14 +0200
committerMichał Górny <mgorny@gentoo.org>2022-07-29 14:54:14 +0200
commitb6cb279290c1ea703e01e9d9fe7ef024025544f1 (patch)
treeb5f62ede23abdd087f88682cde999cb8a50a9492
parentdev-python/prompt_toolkit: Remove old (diff)
downloadgentoo-b6cb279290c1ea703e01e9d9fe7ef024025544f1.tar.gz
gentoo-b6cb279290c1ea703e01e9d9fe7ef024025544f1.tar.bz2
gentoo-b6cb279290c1ea703e01e9d9fe7ef024025544f1.zip
dev-python/ipyparallel: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/ipyparallel/Manifest1
-rw-r--r--dev-python/ipyparallel/ipyparallel-8.3.0.ebuild89
2 files changed, 0 insertions, 90 deletions
diff --git a/dev-python/ipyparallel/Manifest b/dev-python/ipyparallel/Manifest
index 21c466ede8bc..6fec217c7f7b 100644
--- a/dev-python/ipyparallel/Manifest
+++ b/dev-python/ipyparallel/Manifest
@@ -1,2 +1 @@
-DIST ipyparallel-8.3.0.tar.gz 6862893 BLAKE2B 9009f0fa06422b4dcd9e920d6a568030ff9b20695f3a9eab0f730b48c08465bba7682929c139bac3ef65739be2152224ca922faa6a02b6d73be2f3fb572afa26 SHA512 01ae448cd3274aa752abb033706e77584bc164c7cad626970269e516d33dda949fc0bab9a5cc3f018b2aaac60ee55078780c02ba3c9a2079f12036a869a1f339
DIST ipyparallel-8.4.1.tar.gz 6843301 BLAKE2B 1ca0056cfa6827f5eb145584ea634d224119a485f1139964988b07bcd164fe392bb032794098bccdf67b31f74030e62e917c0a451809e0d14fae323308b2b0ab SHA512 640489b3920b91e1b2f83def00a06e8ec45c61bd7ebe33a3e4a30560e2b0acdbe0a98a685d868dd7bce4c65920d378ab69efca75cf0ae7f164ee792c870a297e
diff --git a/dev-python/ipyparallel/ipyparallel-8.3.0.ebuild b/dev-python/ipyparallel/ipyparallel-8.3.0.ebuild
deleted file mode 100644
index 6693ba03636f..000000000000
--- a/dev-python/ipyparallel/ipyparallel-8.3.0.ebuild
+++ /dev/null
@@ -1,89 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=standalone
-PYTHON_COMPAT=( python3_{8..10} )
-PYTHON_REQ_USE="threads(+)"
-
-inherit distutils-r1 optfeature
-
-DESCRIPTION="Interactive Parallel Computing with IPython"
-HOMEPAGE="https://ipyparallel.readthedocs.io/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="amd64 arm arm64 hppa ~ia64 ppc ppc64 ~riscv ~s390 sparc x86"
-
-RDEPEND="
- dev-python/entrypoints[${PYTHON_USEDEP}]
- dev-python/decorator[${PYTHON_USEDEP}]
- >=dev-python/pyzmq-18[${PYTHON_USEDEP}]
- >=dev-python/traitlets-4.3[${PYTHON_USEDEP}]
- >=dev-python/ipython-4[${PYTHON_USEDEP}]
- dev-python/jupyter_client[${PYTHON_USEDEP}]
- dev-python/jupyter_server[${PYTHON_USEDEP}]
- >=dev-python/ipykernel-4.4[${PYTHON_USEDEP}]
- dev-python/psutil[${PYTHON_USEDEP}]
- >=dev-python/python-dateutil-2.1[${PYTHON_USEDEP}]
- dev-python/tqdm[${PYTHON_USEDEP}]
- >=www-servers/tornado-5.1[${PYTHON_USEDEP}]
-"
-BDEPEND="
- dev-python/flit_core[${PYTHON_USEDEP}]
- test? (
- dev-python/ipython[test]
- dev-python/mock[${PYTHON_USEDEP}]
- dev-python/pytest-asyncio[${PYTHON_USEDEP}]
- dev-python/pytest-tornado[${PYTHON_USEDEP}]
- dev-python/testpath[${PYTHON_USEDEP}]
- )
-"
-
-# TODO: package myst_parser
-# distutils_enable_sphinx docs/source
-distutils_enable_tests pytest
-
-PATCHES=(
- "${FILESDIR}"/${PN}-7.1.0-test-timeouts.patch
- "${FILESDIR}"/${PN}-8.3.0-additional-test-timeouts.patch
-)
-
-src_configure() {
- export IPP_DISABLE_JS=1
-}
-
-python_test() {
- local EPYTEST_DESELECT=(
- # we don't run a mongo instance for tests
- ipyparallel/tests/test_mongodb.py::TestMongoBackend
- # TODO
- ipyparallel/tests/test_util.py::test_disambiguate_ip
- # Gets upset that a timeout _doesn't_ occur, presumably because
- # we're cranking up too many test timeouts. Oh well.
- # bug #823458#c3
- ipyparallel/tests/test_asyncresult.py::AsyncResultTest::test_wait_for_send
- # We could patch the timeout for these too but they're going to be inherently
- # fragile anyway based on what they do.
- ipyparallel/tests/test_client.py::TestClient::test_activate
- ipyparallel/tests/test_client.py::TestClient::test_lazy_all_targets
- ipyparallel/tests/test_client.py::TestClient::test_wait_for_engines
- )
- [[ ${EPYTHON} == python3.10 ]] && EPYTEST_DESELECT+=(
- # failing due to irrelevant warnings
- ipyparallel/tests/test_client.py::TestClient::test_local_ip_true_doesnt_trigger_warning
- )
- epytest
-}
-
-python_install_all() {
- distutils-r1_python_install_all
- # move /usr/etc stuff to /etc
- mv "${ED}/usr/etc" "${ED}/etc" || die
-}
-
-pkg_postinst() {
- optfeature "Jupyter Notebook integration" dev-python/notebook
-}